Jump to content
Sign in to follow this  
Guest ezadin

3D Desktop

Recommended Posts

Guest ezadin

Hi,

 

I am new to Linux and I run Mandriva Free Spring 2007. When I try to conifgur 3D Desktop effect or Metissa but then I get the answer No 3D Desktop effects.

If I run ( Mndriva Linux 2007Spring one cdrom :D ) it works and I can configure Metissa or 3D Desktop but not when I am running Mandriva Free Spring 2007.DVD. :wall:

 

can sombody help me please :unsure:

 

 

[moved from Software by spinynorman - welcome aboard :)]

Share this post


Link to post
Share on other sites

Welcome aboard. :)

 

Could you please tell us the graphic card that you are using? It is very probable that you need to install some graphics drivers, as Mandriva ONE includes proprietary drivers for nvidia and ati while Mandriva Free is a 100% free software release, thus does not ship with proprietary software (it will have to be added later, using e.g. the available software mirrors).

Share this post


Link to post
Share on other sites
Guest ezadin

Hi,

 

the graphic card is NVIDIA GeForce4 MX 4000 (128 MB). But as I say ther is no problem with Mandriva Linux 2007 spring one.cdrom-i586.iso

( also free software release) but with Mandriva-linux-2007-spring-free-dvd-i586.iso

Share this post


Link to post
Share on other sites

Mandriva "One" includes the proprietary nvidia driver, while Mandriva "Free" does not...

So- after installing "Free" to harddisk, just install the proprietary nvidia driver (it's in /current/i586/media/non-free/release).

Share this post


Link to post
Share on other sites
Guest ezadin

thank you for answering

here

 

(Index of /Mandrake/current/i586/media/non-free/release)

 

I have found thes

 

 

 

[ ] nvidia71xx-1.0-7184.6mdv2007.1.i586.rpm 11-Apr-2007 17:28 3.0M

[ ] nvidia71xx-kernel-2.6.17-13mdv-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia71xx-kernel-2.6.17-13mdventerprise-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia71xx-kernel-2.6.17-13mdvlegacy-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia96xx-1.0-9631.3mdv2007.1.i586.rpm 11-Apr-2007 17:28 3.8M

[ ] nvidia96xx-kernel-2.6.17-13mdv-9631-1mdk.i586.rpm 11-Apr-2007 17:28 1.6M

[ ] nvidia96xx-kernel-2.6.17-13mdventerprise-9631-1mdk.i586.rpm 11-Apr-2007 17:28 1.6M

[ ] nvidia96xx-kernel-2.6.17-13mdvlegacy-9631-1mdk.i586.rpm 11-Apr-2007 17:28 1.6M

[ ] nvidia97xx-1.0-9755.1mdv2007.1.i586.rpm 11-Apr-2007 17:28 4.3M

[ ] nvidia97xx-kernel-2.6.17-13mdv-9755-1mdk.i586.rpm 29-Mar-2007 20:30 2.2M

[ ] nvidia97xx-kernel-2.6.17-13mdventerprise-9755-1mdk.i586.rpm 29-Mar-2007 20:30 2.2M

[ ] nvidia97xx-kernel-2.6.17-13mdvlegacy-9755-1mdk.i586.rpm 29-Mar-2007 20:30 2.2M

[ ] nvidia_legacy-kernel-2.6.19.1-2mdvsmp-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia_legacy-kernel-2.6.20-1mdv-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia_legacy-kernel-2.6.20-1mdvsmp-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

[ ] nvidia_legacy-kernel-2.6.20.0.rc5-2mdvsmp-7184-1mdk.i586.rpm 11-Apr-2007 17:28 1.2M

 

so which one is the right one :unsure:

Share this post


Link to post
Share on other sites

My guess is that you would need

nvidia97xx-1.0-9755.1mdv2007.1.i586.rpm

 

but instead of just installing that one, I suggest you add the various repositories (link at top of this page: easy-urpmi ) and then use the MCC to setup your graphics, then choose to use the proprietary driver.

If you need more precise info, just ask here.

Share this post


Link to post
Share on other sites

There's no need guessing... you can easily find the driver version that suits you.

What's the output of

uname -a

at a root console? ( "kdesu konsole" to open it).

 

PS: That said, its quite likely that Artee "guessed" the correct driver version.

Edited by scarecrow

Share this post


Link to post
Share on other sites

artee's suggestion is best.

 

Follow the instructions at:

 

http://wiki.mandriva.com/en/Docs/Basic_tas...tions_available

 

to add the non-free repository (and others) as an available source for packages on your system. Then re-run the graphics card configuration utility, re-select your graphics card, and it will ask if you want to use the proprietary driver. Say 'yes'. Then restart the system.

 

That's the easiest way to enable the proprietary driver.

Share this post


Link to post
Share on other sites
Guest ezadin

Hi,

thank you to all who try to help me :D

 

the output of

uname -a

is

 

Linux localhost 2.6.17-13mdv #1 SMP Fri Mar 23 19:03:31 UTC 2007 i686 AMD Athlon GNU/Linux

 

And when I try to install nvidia97xx-1.0-9755.1mdv2007.1.i586.rpm I got this ( urpmi database locked ). Also when follow the instruction of Easy- Urpmi and try

urpmi.addmedia main ftp://sunsite.informatik.rwth-aachen.de/p...ia/main/release with media_info/hdlist.cz

urpmi.addmedia --update main_updates ftp://carroll.cac.psu.edu/pub/linux/distr...ia/main/updates with media_info/hdlist.cz

urpmi.addmedia contrib ftp://sunsite.informatik.rwth-aachen.de/p...contrib/release with media_info/hdlist.cz

urpmi.addmedia --update contrib_updates ftp://ftp.fh-wolfenbuettel.de/pub/os/linu...contrib/updates with media_info/hdlist.cz

in console as root I get also ( urpmi databas is locket..) and even when I Try to update it is the same ( urpmi database is locket.)

 

so what dose that mean ?? what I have to do now ?? :mellow:

Share this post


Link to post
Share on other sites

Open a terminal, and do

ps -e | grep rpm

and please post the output (if any) here. If there is no output, as root do

rm -f /var/lib/urpmi/.LOCK

and

rm -f /var/lib/urpmi/.RPMLOCK

exactly as I have typed them. Then try again.

Share this post


Link to post
Share on other sites

You need the RPM mentioned by Artee, PLUS "nvidia97xx-kernel-2.6.17-13mdv-9755-1mdk.i586.rpm" (notice the matching with your running kernel which you got with the uname command).

If you have other nvidia* packages installed, remove them.

For removing the lock, get ABSOLUTELY sure urpmi/ the packege installer are not running, and follow Greg2.

Share this post


Link to post
Share on other sites
Guest ezadin

so now urpmi databas is NOT locket any more. After following easy urmpi instruciton and installing nvidia97xx-1.0-9755.1mdv2007.1.i586.rpm I still have no 3 D Desktop effect.

 

I try to install nvidia97xx-kernel-2.6.17-13mdv-9755-1mdk.i586.rpm but I get this (....retrieving is failed : curl is failed : exited with 9 ) and after I click OK I get this (installation is failed dkms-minimal >= 1.90 needed by nvidia97xx-kernel-2.6.17-13mdv-9755-1mdk.i586.rpm.

 

 

 

You need the RPM mentioned by Artee, PLUS "nvidia97xx-kernel-2.6.17-13mdv-9755-1mdk.i586.rpm" (notice the matching with your running kernel which you got with the uname command).

If you have other nvidia* packages installed, remove them.

For removing the lock, get ABSOLUTELY sure urpmi/ the packege installer are not running, and follow Greg2.

Share this post


Link to post
Share on other sites

dkms-minimal should certainly exist... it might be a mirror syncing error. I can see many mirrors out of sync (e.g. my favorite NTUA one) due probably to the upcoming Mandriva 2008.0 release.

Try later, or switch to another mirror- or download dkms-minimal by hand and install it.

Share this post


Link to post
Share on other sites

please do it the way I suggested. It is the easiest way. No manual installation of packages is required. If you install the packages manually you still have to change the actual X configuration, which you should do using the graphics card configuration tool - which would install the package for you anyway. so there's no point installing them manually. it's just added complication.

Share this post


Link to post
Share on other sites
Guest ezadin

After long time trying ...... I HAVE SUCCEEDED B) B) B) B) . thank you all :D

Edited by ezadin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...