Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
darkstar

External USB - NTFS volume no longer automounted

Recommended Posts

Hi,

 

I've upgrqded some pqckqges (usb stuff) in my spring 2007.1 and my external USB disk, NTFS formatted, which was read/write user accesible, is no longer automounted.

 

Any clues?

 

Please help!!!

 

d*

Share this post


Link to post
Share on other sites
you could try (re)-installing and running ntfs-config

 

I'v actually tried but it only allows selecting or disabling write acces to external NTFS volumes.

That I checked and it is enabled...

I am going insane on this.

 

Is there a way I can check recently installed packages, thus backibg up latest known working status AFAYK?

D*

Share this post


Link to post
Share on other sites

Not using automount myself, but I'm sure you were using either ivman or usbmount to automount your removable media, and somehow you either wiped their settings or they got removed/broken. Check the actual status and settings of the one you use.

NTFS-config is a fat useless beast, which does a very simple thing and for that it needs to install a sheetload of gnome dependencies. Nobody needs it (not even Gnome users- only Ubuntu newbies may wrongly think they need it because it's "simple" and "idiotproof"), removable NTFS volumes can be initialized much easier:

touch 10-ntfs-policy.fdi
nano 10-ntfs-policy.fdi

 

Now copypaste to nano ( shift+insert) the following mumbojumbo:

 

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<!-- mount ntfs volume with the ntfs-3g driver to enable write support -->
<device>
	<match key="volume.fstype" string="ntfs">
		<match key="@block.storage_device:storage.hotpluggable" bool="true">
			<merge key="volume.fstype" type="string">ntfs-3g</merge>
			<merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
			<append key="volume.mount.valid_options" type="strlist">locale=</append>
		</match>
	</match>
</device>
</deviceinfo>

 

On locale=</append> you can replace /append with /en_US.UTF8 or whatever encoding you are actually using- else some files may not be visible at all after mounting.

Now copy this to your hal policies folder (in my case it's /etc/hal/fdi/policy), restart hal, and you are set- no need for ntfs-config... factly, the above hal rule takes care of more things.

Edited by scarecrow

Share this post


Link to post
Share on other sites

Perhaps the volume was not clean unmounted....the best way to solve this is to plug the drive to a windows box and run the safely remove hardware procedure....that should unmount the drive in a safe way.

ntfs-3g should complain about this when you try to mount the drive...just check the syslog for any output on this.

I myself had the same problem with this. :wall:

 

Cheers....

Share this post


Link to post
Share on other sites

Don't think it is my case. I do normally umount external volumes, not simply turn them off.

It's weird: I upgraded some packages, thru the auo-upgrade feature and found myself with no access to neither NTFS NOR FAT32 external storage bxes.

So I believe this has got really nothing to do with the filesystem type. Might it be something wrong with HAL?

 

d*

 

Perhaps the volume was not clean unmounted....the best way to solve this is to plug the drive to a windows box and run the safely remove hardware procedure....that should unmount the drive in a safe way.

ntfs-3g should complain about this when you try to mount the drive...just check the syslog for any output on this.

I myself had the same problem with this. :wall:

 

Cheers....

Share this post


Link to post
Share on other sites

I do agree on NTFS-config. Does not do the job. However I might have simplified my issue. I can not access both of my external disks: NTFS AND FAT32.

They simply don' show up in /media, once I turn them on.

got a better clue?

 

 

 

Not using automount myself, but I'm sure you were using either ivman or usbmount to automount your removable media, and somehow you either wiped their settings or they got removed/broken. Check the actual status and settings of the one you use.

NTFS-config is a fat useless beast, which does a very simple thing and for that it needs to install a sheetload of gnome dependencies. Nobody needs it (not even Gnome users- only Ubuntu newbies may wrongly think they need it because it's "simple" and "idiotproof"), removable NTFS volumes can be initialized much easier:...

Share this post


Link to post
Share on other sites

Is hald running normally?

Power on the USB disk, and do a routine

dmesg | grep usb

 

If the disk is recognized you should see somewhere a line like

usbcore: registered new interface driver usb-storage

Then try mounting it manually and do a filesystem check.

Share this post


Link to post
Share on other sites

I'm not at home, currently. I will check if the daemon is running properly.

 

However I still wonder what might have happened during the package upgrade I ran....

Will follow your advice and post the results later this evening.

Thanks,

d*

Share this post


Link to post
Share on other sites

This probles has ben solved

 

--------------------------------------------------------------------------------------

I had installed a 7ports, externally powered USB HUB to face lack of available ports on my case.

This hub strangely caused both external volumes to not being automounted when powered on.

The issue was solved by simply removing the DC adapter plug from the hub, thus having the hub powered by my 500W power supply, though the case’s USB port.

Even more weird was the fact that this situation was not occurring when running two other installed distributions: Ubuntu 7.04 Feisty and Ubuntu Gutsy b1 (future 7.10).

Obviously I could never imagine it could have been a problem related to a self powered USB 2 hub.

 

Thanks for your help and I hope this may serve as a solution to anyone else having to face the same snag…

 

D*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×