Jump to content
Sign in to follow this  
busted

Printer problem

Recommended Posts

I have just purchased an HP Photosmart C4180 All-in-One printer, copier, scanner and set it up to my computer which is running Mandriva Spring "Free". I connect to the internet via a Netgear DG834G Modem/Router but for some reason it will not print out anything. Would appreciate any and all help and advice. Big thanks

Share this post


Link to post
Share on other sites

Hi SoulSe

To be honest with you i am a Linux n00b and although i use a NETGEAR DG834G Modem/Router to get online i have connected the Photosmart C4180 All-in-One to my computer. I didn't even know about using a Linux driver from HP or even how to install one if i did. Could i connect the printer to the ModemRouter via another Ethernet cable? Any help and advice would be really appreciated. Big thanks

Share this post


Link to post
Share on other sites

If the device has an Ethernet port and HP's print server on board (sorry, don't have time to look it up right now) then you can plug the printer straight into the router and access it via the network, which is the best route to go.

 

Otherwise, HP does have a driver for the printer for Linux, which you will need irrespective of how the printer is connected. Using the official driver will yield the best results. There are also instructions on the HP site for installing the driver. So step 1 is head over to www.hp.com and look up your printer ;)

Share this post


Link to post
Share on other sites

How is the printer connected? Directly to the PC via USB? I have a Netgear DG834GT router which is more or less the same as yours, so I doubt you'll be able to connect it directly to the router unless the printer has a network card inside it and an IP address configured.

Share this post


Link to post
Share on other sites

When the printer is connected to the computer and i start it up i get the following message;

 

Please insert the medium named "installation i586 CD 1" on device [/dev/hdc]

 

I have been looking for a driver and have found "hplip-2.7.7.run". So could someone tell this old n00b how i can install the driver please. Thanks for all help and advice.

Share this post


Link to post
Share on other sites
When the printer is connected to the computer and i start it up i get the following message;

 

Please insert the medium named "installation i586 CD 1" on device [/dev/hdc]

Have you tried inserting the CD or DVD that you have installed your system with?

 

hplip is on your installation CD and or DVD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...