Jump to content

Wireless Problem...

Guest Cromzinc

Recommended Posts

Guest Cromzinc

Hey, working with gateway 32bit laptop. installed mandriva, and said that my wireless wasn't configured, so went to configure it, and asked for the right driver or firmware, and I think it wanted the windows one, not to sure. don't know much about it.


Mandriva said its a broadcom bcm4318 card.


im not sure what to do next. any help in getting this working...please.


Link to comment
Share on other sites

I have that exact same card in my laptop. You need bcmwl5.inf and bcmwl5.sys windows drivers. It doesn't matter where you put them. Then just run networking, wireless through mcc. It'll search for drivers and then if will ask you if you want to use windows drivers. You then navigate to bcmwl5.inf and then just follow the steps using the wizard. Don't forget to do modprobe ndiswrapper when you're done. Run ndiswrapper -l and it should show you that the drivers are installed.


You can also try the native drivers. They're built into the kernel and you follow the following steps. urpmi bcm43xx-fwcutter

let it download and extract firmware.

cp the *.fw files from /lib/firmware to /lib/hotplug/firmware (you have to create this directory).

use mcc to set your wireless connection up. This card does not support WPA so if you want encryption you need to use WEP.


Good luck.

Link to comment
Share on other sites

Mayby a stuppid question but how do i extract the firmware from the *.sys file, i've never used bcm43, because i still using 2006 with NdisWrapper. I'll wait until 2008 comes out


It's not a .sys file. And when I used the native drivers it automatically extracted the firmware. I just had to copy it to the new directory. But I agree with adamw. Try ndiswrapper first.

Link to comment
Share on other sites

I'm having a lot of trouble getting the same (well at least similar, uses the bcm43xx module or bcmw15 drivers) card going. Came as the built-in WiFi on my Dell D-420, running 2007 Spring. It is recognized, as:


Dell Wireless 1390 WLAN Mini-PCI Card

Vendor ID: 0x14e4

Device ID: 0x4311


Basically, so far I have:


Installed the 'bcm43xx-fwcutter' package and successfully downloaded and extracted the firmware files to /lib/firmware. I also copied the .fw files to a /lib/hotplug/firmware directory as Mystified suggested.

Did 'modprobe bcm43xx' OK. I also setup the 'bcm43xx' module to load at boot. Either way, 'lsmod' says it loads sucessfully.



# iwconfig

lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.


Setup using MCC of course fails as soon as I click on 'Wireless Connection' with: "Unable to find network interface for selected device (using bcm43xx driver).


So I installed ndiswrapper, went to Dell.com and downloaded the bcmw15 drivers, both the latest version and an earlier one. Installed everything (apparently successfully) but with either driver version:


# ndiswrapper -l

bcmw15 invalid driver


Again, of course setup using MCC fails.


I'm open to suggestions. WiFi is the only thing on this laptop that has me beat. Bluetooth, 3G wireless, SD card reader, sound, display, ethernet, mouse pointer & touchpad - all the hardware works fine except the friggin' WiFi.


Edited by Crashdamage
Link to comment
Share on other sites

  • 2 weeks later...

It's a little late but I just saw your post. Not sure but you might need this driver R115321.EXE http://support.dell.com/support/downloads/...;cs=19&l=en You also need to remove the Broadcom native driver. In Debian I had to blacklist it but I'm not sure what you do in Mandriva.

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for the long delay, work is **really** keeping me hoppin' right now, just very limited time to fool with this.


Not sure but you might need this driver R115321.EXE

I'm not sure where you found that driver and the link you gave didn't work. But I just searched dell.com again and they list 2 available drivers for my Broadcom 1390 WLAN mini-card (built-in wifi):

R140747.exe (this is the apparently the same as the factory pre-loaded one)


R151517.exe (latest update)

I've tried both plus copying the original R140747 driver from the WinXP Pro install. Using any of the 3 always results in:


# ndiswrapper -l

bcmwl5 invalid driver


You also need to remove the Broadcom native driver. In Debian I had to blacklist it but I'm not sure what you do in Mandriva.

I blacklisted it to prevent it from loading at boot.

# lsmod

shows the bcm43xx module is not loading and that ndiswrapper is, but then it fails loading the driver:


# dmesg | grep ndiswrapper

ndiswrapper version 1.21 loaded (preempt=no,smp=yes)

loadndisdriver: load_driver(361): couldn't load driver bcmwl5


I'm still really stuck on this. Tried various stuff found from Google searches but no joy. Maybe the sensible thing to do would be to get an Intel-based mini-card and trash the friggin' Broadcom, but I haven't found a source for one.

Edited by Crashdamage
Link to comment
Share on other sites

I've tried the NDISWRAPPER and the native bcm and it makes NO difference, oCCASIONALLY when i get a signal it's VERY weak so I still recommend, and still use, and will continue to pay for:




i wish I could tell you WHAT makes the differences, but my experience (with 4 different distros - MDV, FEDORA, SUSE and Xandros) have shown me that its MUCH simpler to use and every single time, my signal is ALWAYS much much stringer.


best $20 ive spent.


nicest part is that since the license is tied to the MAC address of the NIC< I can use it on my laptop with any or as many distros as I want.



Link to comment
Share on other sites



OK, sounds good and I like supporting companies that support Linux. I'll do $20 to make this go.


To get rid of possible conflicts with Linuxant, I first uninstalled ndiswrapper. I had already blacklisted the bcm43xx module so it would not load at boot.


Restarted the machine and tried installing and configuring Linuxant. Pretty slick Windoze-type GUI installer, worked very well - but only up to a point. After successfully downloading and installing the rpm, it went about building and installing the 'driverloader' kernel module. All good. But it then failed with a 'No device found' message in the console box, then popped up a window complaining my WLAN mini-PCI card was not present, not detected or the driver was incorrect. It suggested removing and reinstalling the card or choosing another driver. Since WiFi works fine with XP, trying the first suggestion made no sense. Choosing any of the drivers I have did not help, even if I browsed directly to and tried loading the OEM driver straight from the XP Pro install partition.


Still, the Broadcom card is found as the Linuxant installer says I have a:


Broadcom bcm43xx

Version 10/12/2006


MCC finds it as:


Dell wireless 1390 WLAN Mini-PCI

Vendor ID: 0x14e4

Device ID: 0x4311


So it IS detected, at least to a point. And at this point, I'm stuck again. Unless someone has a better idea soon I'm probably gonna throw in the towel on getting the friggin' Broadcom to go and look for an Intel 3945-based mini-PCI card, though that's not an easy way out either as Dell no longer will supply one. Finding one sure to fit and work in a D420 appears to be tricky.


I'd much rather give $20 to Linuxant to show support for what is clearly a nice bit of noobie-friendly software, but I just want this to work and the Broadcom is a serious piece of crap.

Link to comment
Share on other sites

Have you tried the bcmwl5a driver with ndiswrapper instead of the bcmwl5 one? That's the one that I have to use on my dell with a broadcom chipset wireless mini-pci card.


Also, what version of ndiswrapper are you using? If you installed ndiswrapper via mandirva's rpm, you have to make sure the rpm you used was compiled on the same kernel you are using or you get the "invalid driver" error message when you try to load ndiswrapper. If all else fails, I'd try uninstalling mandriva's ndiswrapper rpm and compiling the most recent ndiswrapper from source.




Make sure you have the correct kernel source installed before doing so.

Link to comment
Share on other sites

I generally endorse the compiling ndiswrapper from scratch idea on any currently released MDV simply because we always used to ship a crappy out of date version of ndiswrapper, and this is true in 2007 Spring. The latest versions work rather better than the one in Spring, so if it doesn't work right away, compiling is not a bad idea.


2008 will actually come with a very recent ndiswrapper, which is good.

Link to comment
Share on other sites

I'll try installing the latest ndiswrapper version and see what happens.


But my gut feeling is that it won't make a difference. Look at it this way: All 3 methods I've tried - native bcm43xx module, ndiswrapper, and Linuxant - have puked. 3 outta 3 ain't good and there must be a reason.


1. The bcm43xx module failed because it could not find the hardware.

2. The ndiswrapper built and loaded the module but failed installing the driver, also raising the possibilty it was unable to properly detect the hardware.

3. Linuxant built and loaded the 'driverloader' module but failed loading the driver, again suggesting possibly it could not properly detect the hardware.


Now, maybe #1 failed simply because the native bcm43x module sucks.

Maybe #2 failed because I did not use the latest version. We'll see about that. But somehow I doubt it, mostly because...

#3 failed in the same way as #2, it loaded the module but not the driver. If #2 failed because it was a bit out of date, that problem should've been corrected by installing #3, which custom builds and installs the lastest version. And remember that Linuxant is, after all, basically a customized ndiswrapper.


IOW, this frustrated Linux pinhead thinks it's very unlikely all 3 would fail (particularly Linuxant) unless there was another common underlying cause. In my case, I think it HAS to be something with hardware detection, but I'm not enough of a guru to how to troubleshoot the detection thing beyond what I've already done. Normally, I'd probably just install a later kernel version (I'm using and see if that fixed it. But...


1. I have other no real reason to update the kernel.

2. I've also built and installed a couple of other custom modules against this kernel and all is good to go.

3. Everything but WiFi is working SO well I kinda hate to rock the boat.


I'll do some more searching for a useable Intel 3945-based mini-PCI card. If that fails, then (unless someone has a suggestion about troubelshooting detection of my Broadcrap card) I'll try a kernel update and start over.

Link to comment
Share on other sites

I hate to sound like a newbie and ask a silly question, but my ACER has a REALLY small button on the FRONT edge (that doubles as an LCD).


and if you "accidentally" push it (as I often do, especially loading and unloading it from my case), it turns the card OFF.


sw still detects it, but all installers say that its OFF or not working.


I actually did an entire OS reload the 1st week I had it (their support guy didnt bother to mention it when I called), because I turned the card off.


but if youve loaded the linuxant driver you should email them, ive always had VERY fast support from them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...