Jump to content

Gentoo Apache problem [solved]

Recommended Posts

I have nut, my ups monitor set up so I can access it via localhost/nut. My Document root setting is /var/www/localhost/htdocs

inside this I have forum, which is my test copy of the board and nut. But when I try to access localhost/nut I get access denied. I don't understand why it works for forum and not for nut.


I also have cgi set in httpd.conf because nut uses cgi-bin.


Any suggestions?

Link to comment
Share on other sites

Apologies, I should have read your original post better.


Another silly question: have you checked that your permissions are all OK for nut (are you running any other security that could be preventing apache from serving nut)?

Link to comment
Share on other sites

I don't have anything that I know of that would be causing problems.


I have cgi-bin in apache.


These are my permissions:

localhost log # ls -l /var/www/localhost/cgi-bin/nut
total 629
-rwxr-xr-x 1 root root 530156 May 11 16:18 htsearch
-rwxr-xr-x 1 root root	268 May 11 16:18 printenv
-rwxr-xr-x 1 root root	757 May 11 16:18 test-cgi
-rwxr-xr-x 1 root root  29120 Jun  1 16:27 upsimage.cgi
-rwxr-xr-x 1 root root  33024 Jun  1 16:27 upsset.cgi
-rwxr-xr-x 1 root root  32064 Jun  1 16:28 upsstats.cgi
localhost log # ls -l /var/www/localhost/htdocs/nut
total 16
-rwxr-xr-x 1 root root   62 May 11 16:13 bottom.html
-rwxr-xr-x 1 root root  623 May 11 16:14 header.html
-rwxr-xr-x 1 root root  503 May 11 16:14 index.html
-rwxr-xr-x 1 root root 2750 May 11 16:14 nut-banner.png

apache error_log says

[Sat Jun 02 10:51:39 2007] [error] [client] Directory index forbidden by rule: /var/www/localhost/htdocs/nut/


I haven't found anything in htdocs or nut that would interfere.

Link to comment
Share on other sites

Well it opens but I think I have an .htaccess problem.

When I click on Statistics I get cannot open /etc/hosts.conf. When I click on settings I get: Error: Can't open upsset.conf to verify security settings.

Refusing to start until this is fixed.


I have .htaccess in cgi-bin with the following:

<Files upsset.cgi>

deny from all

allow from





In /etc/hosts.conf I have:

MONITOR belkin@localhost "Local UPS"




I also added this to httpd.conf. But I think I'm missing something somewhere.

According to a nut developer you need this to secure your ups.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...