Jump to content

"glxgears" command restarts the X-server [solved]


Recommended Posts

Hi all! Yesterday, I installed mandriva 2007 spring- till yesterday, I used mandriva 2007 RC2 sunna. But, there is a small problem- when I type glxgears into console, X-server restarts. I have installed mesa-demos, libmesagl1 and libmesagl1-devel. Here is my Module section of xorg.conf:

Section "Module"

# Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

#Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"


I've installed already dkms-nvidia97xx-1.0-9755.2plf2007.1.i586 - my videocard is nvidia GeForce FX 5500


How to fix that problem with glxinfo? I had the same problem with 2007 "sunna" rc2 version- but after installing mesa-demos everything was fine. My xorg.conf "module" section was the same as posted above. Thanks in advance

Link to comment
Share on other sites

# Load "dbe" # Double-Buffering Extension

The '#' means this line is a comment; in my xorg.conf this line is not commented out. The following command allows you to check whether 3D acceleration is running:


glxinfo | grep render

This should return a.o. the following line "direct rendering: Yes". If 'No' then you are not running 3d-aceleration. Also check that you actually use the nvidia driver (there should be a line Driver "nvidia" in the xorg.conf file).

Edited by pindakoe
Link to comment
Share on other sites

Section "Device"

Identifier "device1"

VendorName "nVidia Corporation"

BoardName "NVIDIA GeForce FX - GeForce 7950"

Driver "nvidia"

Option "DPMS"



This is Device section for the videocard in my xorg.cong. Yeah, I know that # is comment, but before Spring I used mandriva 2007 Sunna RC2 and the xorg.conf was the same, and glxgears worked fine


I know glxinfo command, but it also restarts X-server

Edited by Nik123
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...