Jump to content
Sign in to follow this  
Pluto

Problem: Mandriva 2007 Italian & English [solved]

Recommended Posts

Pluto, I haven't looked at my boy's desktop for a long time, and I have made some updates, so I thought I better check. Anyway, I just switched my desktop over to Italian (using gnome), and everything seems to be in Italian. Firefox is in Italian, along with all the menus. OpenOffice is in Italian, along with all the menus. Terminal is in Italian, as you can see below.

 

[kieth@localhost Desktop]$ su

Parola d'ordine:

[root@localhost Desktop]# adsl-start

........... Connected!

[root@localhost Desktop]#

 

What is it that you still see in English?

 

Kieth

Share this post


Link to post
Share on other sites
What is it that you still see in English?

For example, my terminal is all in English, I have "FIle - Edit - View - Terminal - Tabs - Help" on the up bar; right-click on Terminal gives me "Open terminal - Open tab - Close windows - Change profile..."; on desktop I have "Applications - Places - System". If I log-out and select Italian I expect all is in Italian, not only something. Firefox now is in Italian, after I uninstalled previous verions and installed Firefox 2. OpenOffice needed a language change: after I did it now is in Italian. "Confogure your computer" is also all in English. I'll try to switch on more times the language with Gnome...

 

I hope these info could be useful to understand what's going on... :unsure:

Share this post


Link to post
Share on other sites

Go to Configure your computer and type in your password. Press the button that lets you add software. Then in the search space, type in locales. You will get a list of files. Then scroll down and see if you have the file installed. While I'm thinking of it, have you updated your programs (aggiornamenti)? If not, you can also do that, as it might help.

Share this post


Link to post
Share on other sites

Yes, locales-it are installed and Mandriva was succesfully updated (I downloaded and installed 131 packages). I think at this time the problem isn't so big: Firefox and OpenOffice are both in Italian and if the rest is in English... I will accept it.

 

Of course, if you have solutions let me know! :D

Share this post


Link to post
Share on other sites

Well, I'm confused. I tried to set my Firefox to Italian, but completely without success. I can't believe it's so difficult! I know you've solved it by removing and installing v2 by hand, but that's not everyone's ideal solution.

 

Firstly I installed the "it" rpm, that went fine and I can even see the result in Tools->Extensions. But still everything's in English. I restart Firefox, same. I change the "language of web pages" also to Italian, that certainly has an effect on eg http://debian.org because that page shows up in Italian. But menus still in English. I go into about:config, and change the settings general.useragent.locale=it and intl.locale.matchOS=false but still nothing. Very strange.

 

Also I tried that mozillaitalia link to install the xpi but it just gave me an error message in Italian which I didn't understand :P

 

So, sorry but I tried and failed. There must be someone on here who's managed to get Firefox to speak their language (without installing v2 by hand), mustn't there??

Share this post


Link to post
Share on other sites

Sorry I didn't comment on this sooner. To be honest, I haven't even look in "Art and Design" for some time. Anyway, I can easily change from Italian to English and back again, having everything in Italian. I believe the reason is because when I originally installed Mandriva, I chose to install Italian as a second language. There must be some packages/files that are installed at that time that make the difference. When I choose the Italian language, it isn't just Firefox that changes, but everything.

 

Kieth

Share this post


Link to post
Share on other sites

Could the problem of changing languages be related to the problem that hirohitosan encountered and solved, at: link This is what he did:

I found the problem. For those who are interested: In the file /usr/share/X11/xkb/symbols/ro

at:

 

include "ro (std) ";

delete semicolon ;

the new line will looks like

include "ro (std) "

 

and you're done

 

My 'it' file reads:

// $XKeyboardConfig: xkbdesc/symbols/it,v 1.6 2005/01/16 02:18:20 svu Exp $

 

// based on a keyboard map from an 'xkb/symbols/it' file

// 17 May 2003 Modified by Sebastiano Vigna (vigna@dsi.unimi.it)

//

// $XFree86: xc/programs/xkbcomp/symbols/it,v 1.4 2003/04/19 12:22:12 pascal Exp $

 

partial default alphanumeric_keys

xkb_symbols "basic" {

 

include "latin(type4)"

 

name[Group1]="Italy";

 

key <TLDE> { [ backslash, bar, notsign, brokenbar ] };

 

key <AE02> { [ 2, quotedbl, twosuperior, dead_doubleacute ] };

key <AE03> { [ 3, sterling,threesuperior, dead_tilde ] };

key <AE04> { [ 4, dollar, onequarter, oneeighth ] };

 

key <AE10> { [ 0, equal, braceright, dead_ogonek ] };

key <AE11> { [apostrophe, question, grave, questiondown ] };

key <AE12> { [ igrave, asciicircum, asciitilde, dead_circumflex ] };

 

key <AD11> { [ egrave, eacute, bracketleft, braceleft ] };

key <AD12> { [ plus, asterisk, bracketright, braceright ] };

 

key <AC10> { [ ograve, ccedilla, at, dead_cedilla ] };

key <AC11> { [ agrave, degree, numbersign, dead_abovering ] };

 

key <AB06> { [ n, N, ntilde, Ntilde ] };

key <AB08> { [ comma, semicolon, dead_acute, multiply ] };

key <AB09> { [ period, colon,periodcentered, dead_diaeresis ] };

key <AB10> { [ minus, underscore, dead_macron, division ] };

 

key <BKSL> { [ ugrave, section, dead_grave, dead_breve ] };

 

key <LSGT> { [ less, greater,guillemotleft,guillemotright] };

 

include "level3(ralt_switch)"

};

 

partial alphanumeric_keys

xkb_symbols "nodeadkeys" {

 

// Modifies the basic italian layout to eliminate all dead keys

 

include "it(basic)"

 

name[Group1]="Italy - Eliminate dead keys";

 

key <AE02> { [ 2, quotedbl, twosuperior, doubleacute ] };

key <AE03> { [ 3, sterling,threesuperior, asciitilde ] };

 

key <AE10> { [ 0, equal, braceright, ogonek ] };

key <AE12> { [ igrave, asciicircum, asciitilde, asciicircum ] };

 

key <AC10> { [ ograve, ccedilla, at, cedilla ] };

key <AC11> { [ agrave, degree, numbersign, degree ] };

 

key <AB08> { [ comma, semicolon, acute, multiply ] };

key <AB09> { [ period, colon,periodcentered, diaeresis ] };

key <AB10> { [ minus, underscore, macron, division ] };

 

key <BKSL> { [ ugrave, section, grave, breve ] };

};

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...