Jump to content

Nvidia drivers and hardware acceleration [solved]


Recommended Posts

Love the logo on the new .9629... don't love 500fps and no direct rendering. Please help me get them back!


glxinfo gives

direct rendering: No

server glx version string: 1.2

client glx version string: 1.4


xorg.conf is


Section "ServerLayout"

Identifier "layout1"

Screen "screen1" 0 0

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"



Section "Files"


# font server independent of the X server to render fonts.

# minimal fonts to allow X to run without xfs

FontPath "unix/:-1"

FontPath "/usr/share/fonts/misc:unscaled"



Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer



Section "ServerFlags"


#DontZap # disable <Crtl><Alt><BS> (server abort)

# allows the server to start up even if the mouse does not work

#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

Option "allowmouseopenfail"



Section "InputDevice"

Identifier "Keyboard1"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "gb"

Option "XkbOptions" "compose:rwin"



Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"



Section "Monitor"

Identifier "monitor1"

VendorName "Generic"

ModelName "1024x768 @ 70 Hz"

HorizSync 31.5 - 57.0

VertRefresh 50.0 - 70.0

ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630

ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616



Section "Device"

Identifier "device1"

Driver "nvidia"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce4 (generic)"



Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultDepth 24

Option "DPMS"

SubSection "Display"

Depth 8

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"


SubSection "Display"

Depth 15

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"


SubSection "Display"

Depth 16

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"


SubSection "Display"

Depth 24

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"




Section "Extensions"

Option "Composite"


Edited by Dustpuppy
Link to comment
Share on other sites

Er, no. I tried to at one point and nearly trashed the system (full story over in software), so I've left it well alone since.


The thing is, I was running the .8 driver before, and it was fine.


ETA: this is desktop 1, so its a geforce 4 mx440 card.

Edited by Dustpuppy
Link to comment
Share on other sites

The last time I had this on Mandriva, it was a security setting which disabled 3D acceleration- but please allow me looking at some old notes (some 3 years old) to tell you which security setting needs relaxation to bring 3D back. I cannot do anything directly, as I don't have any Mandriva installation handy right now.

Link to comment
Share on other sites

Direct Rendering (3D Hardware Acceleration) is usually provided by the DRI extension. Not with nVidia binary drivers. Don’t load the DRI extension, instead make sure the GL library files in /usr/lib/ are the ones provided by nVidia. It should like this (XXXX is the nVidia Driver version).


#> ls -l /usr/lib/libGL.so*

lrwxr-xr-x 1 root root 17 2004-10-10 21:53 libGL.so -> libGL.so.1.0.XXXX

lrwxr-xr-x 1 root root 17 2004-10-10 21:53 libGL.so.1 -> libGL.so.1.0.XXXX

-rwxr-xr-x 1 root root 423832 2004-10-09 13:42 libGL.so.1.0.XXXX

-rw-r--r-- 1 root root 1946800 2004-02-15 22:37 libGL.so.1.4.500

#> ls -l /usr/lib/libGLcore.so*

lrwxr-xr-x 1 root root 21 2004-10-09 13:42 libGLcore.so.1 -> libGLcore.so.1.0.XXXX

-rwxr-xr-x 1 root root 7132152 2004-10-09 13:42 libGLcore.so.1.0.XXXX

#> ls -l /usr/X11R6/lib/libGL.so*

lrwxrwxrwx 1 root root 26 2005-03-24 21:19 libGL.so.1 -> /usr/lib/libGL.so.1.0.XXXX


If the links are not correct replace them:


#> ln -sf /usr/lib/libGL.so.1.0.XXXX /usr/lib/libGL.so

#> ln -sf /usr/lib/libGL.so.1.0.XXXX /usr/lib/libGL.so.1

#> ln -sf /usr/lib/libGLcore.so.1.0.XXXX /usr/lib/libGLcore.so.1

#> ln -sf /usr/lib/libGL.so.1.0.XXXX /usr/X11R6/lib/libGL.so.1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...