Jump to content

Samba and Groups


Recommended Posts

My samba stuff has been up and running for a long time, and I have lived with this issue but what to fix it...


Machine1: user-Amy ; group-Amy

Machine2: user-Travis ; group-Travis


So, when my wife writes to the samba shares on the Linux box from WinXP, it assignes the group to her and I can see the files, but I can't change anything and vice-versa. I have a group 'Parents' on the Linux box that we both belong to and I would like when we write to the Samba shares from Windows that it use this group.


I have done some searches and I must be using the wrong key words as I can't find where I would change the Samba user/group assignment. And maybe it is just a Linux side change where I remove that group and only assign us to the parents group.

Link to comment
Share on other sites

Well, here is what I found out so far.


I created a test user and made the default group 'parents' on the linux side. When that user logs on now from windows it does pick that group. I also made the share create permissions give the group ability. I have to test that, but I don't see why that part will not work.


Is this then the correct way to handle this?

Link to comment
Share on other sites

you may try the option below inside your shared folder defined at smb.conf

comment = shared
path = /home/shared
read only = no
valid users = user1 user2 +parents
inherit permissions = Yes


-valid users are user1 user2 and all member of group parents

-inherit permision, if you chmod 770 the /home/shared folder

all files on it and the said folder will have a 770 permission, which allow user and group to have a rw permission.

Edited by aioshin
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...