Jump to content

MCC recovery

Guest veorves

Recommended Posts

Guest veorves

A few months ago I updated my computer from Mandriva 2005 to 2006 ; in the process, I somehow lost MCC.


I am not totally worried about that, as I can reach most install options through webmin (that still works quite well) but along with MCC loss some settings such as automatic CD and DVD drives have also disappeared, and I'm not an absolute champion of the command line yet.


However, I've tried to re-install MCC from urpmi, and every time I've tried I got the usual message "all packages are already installed", but I still can't launch it.


What I get when I try to launch it from konsole (as root) is the following :


can not find function c::bind_textdomain_codeset

c::AUTOLOAD() called from /usr/lib/libDrakX/mygtk2.pm:21

(eval)() called from /usr/lib/libDrakX/ugtk2.pm:37

ugtk2::BEGIN() called from /usr/lib/libDrakX/mygtk2.pm:0

(eval)() called from /usr/lib/libDrakX/mygtk2.pm:0

(eval)() called from /usr/sbin/drakconf.real:36

main::BEGIN() called from /usr/lib/libDrakX/mygtk2.pm:0

(eval)() called from /usr/lib/libDrakX/mygtk2.pm:0

Compilation failed in require at /usr/lib/libDrakX/ugtk2.pm line 37.

BEGIN failed--compilation aborted at /usr/lib/libDrakX/ugtk2.pm line 37.

Compilation failed in require at /usr/sbin/drakconf.real line 36.

BEGIN failed--compilation aborted at /usr/sbin/drakconf.real line 36.


Thanks in advance for help & advice

Link to comment
Share on other sites

Upgrades are problematic. It is best to have the /home directory on a seperate partition and perform a fresh install with new releases.

Do an update off all "drake" tools. I would recommend configuring urpmi with EasyUrpmi found at the top of our board. Then install all of the updates.

Link to comment
Share on other sites

Yes, of course it is. But, by installing the latest tools, urpmi should catch the gtk updates as well. This problem also occurs if one mixes mde rpms with standard kde rpms, although I think mmodem has said he is finally using the new gtk now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...