Jump to content
ulukaj

nvidia geforce mx440

Recommended Posts

The other driver if dkms-nvidia doesn't work is:

 

urpmi dkms-nvidia_legacy

 

but I would do this first:

 

urpme dkms-nvidia

 

first to remove the one that didn't work. But see my previous post, as I need more information from you than you are supplying to be able to help you. I can't help without it.

Share this post


Link to post
Share on other sites

well the only thing I didnt post is

[ulukaj@localhost ~]$ urpmq --list-media

The Ultimate Linux Desktop DVD (cdrom1)

The Ultimate Linux Desktop DVD (cdrom2)

The Ultimate Linux Desktop DVD (cdrom3)

The Ultimate Linux Desktop DVD (cdrom4)

The Ultimate Linux Desktop DVD (cdrom5)

The Ultimate Linux Desktop DVD (cdrom6)

 

[ulukaj@localhost ~]$ uname -r

2.6.12-21mdk

 

I also have the corresponding kernel-source since it appeared in control center for deinstallation

 

more:

 

[root@localhost ulukaj]# urpmi dkms-nvidia_legacy

Please insert the medium named "The Ultimate Linux Desktop DVD " on device [/dev/hdd]

 

and finally

[root@localhost ulukaj]# urpme dkms-nvidia

unknown package: dkms-nvidia

 

I installed the kernel with urpmi and kernel-source with control center

Edited by ulukaj

Share this post


Link to post
Share on other sites

That's fine, just wanted to make sure the running kernel matched the kernel source installed. That's usually where problems come.

 

I noticed you don't have any other sources than your DVD media. Click the easy-urpmi link at the top of this page and add sources for main, contrib, plf-free, plf-nonfree, jpackage and updates. You'll have more luck with dkms then, because you can't get all the packages.

 

Did you try the link I provided for downloading the nvidia driver directly from nvidia? You might have more luck with this, unless you try the legacy dkms info first that I provided too.

 

And post back let us know how you get on after trying both of these.

Share this post


Link to post
Share on other sites

I installed the legacy driver but I havo no improvement in preformance

 

I have a side question : how come there are windows drivers specific to every nvidia video card but for linux its just one?

Edited by ulukaj

Share this post


Link to post
Share on other sites

You might need to edit /etc/X11/xorg.conf and change:

 

Driver "nv"

 

to:

 

Driver "nvidia"

 

otherwise it uses the basic nvidia driver, and not the accelerated one.

Share this post


Link to post
Share on other sites

well there is some improvement.

I changed driver from "nv" to "nvidia"

after that I ran urpmi dkms-nvidia (for some unknown to me reason settings for urpmi had disappeared so I first added media)

 

in console everything was ok no warnings or errors popped up

so I rebooted

X didn`t start the error was sth like "no usable modes found "or sth like that so I put my dvd in and updated the system

I chose legacy for video card

X didn`t start again

 

urpme dkms-nvidia uninstalled latest driver

after reboot X ran fine but my network connection settings seemed to have disappeared so i had to configure network too

 

now Im with the legacy driver

latest nvidia driver is said to be for geforce/quadro so why the heck wouldn`t it install

I`ll take some other distro this is too much for a newbie

:wall:

Edited by ulukaj

Share this post


Link to post
Share on other sites
I installed the legacy driver but I havo no improvement in preformance

 

I have a side question : how come there are windows drivers specific to every nvidia video card but for linux its just one?

 

With Linux, there are 3 types. IA32 for 32 bit versions of Linux. IA64 for Intel 64 bit processors I think, and the AMD64 for AMD 64 bit processors.

 

With Linux, it's not like Windows having 98/NT/2000/XP and different versions of drivers. Linux is Linux, regardless of Ubuntu, they all run the same kernel more or less. That's why there are a lot less drivers listed.

 

well there is some improvement.

I changed driver from "nv" to "nvidia"

after that I ran urpmi dkms-nvidia (for some unknown to me reason settings for urpmi had disappeared so I first added media)

 

in console everything was ok no warnings or errors popped up

so I rebooted

X didn`t start the error was sth like "no usable modes found "or sth like that so I put my dvd in and updated the system

I chose legacy for video card

X didn`t start again

 

urpme dkms-nvidia uninstalled latest driver

after reboot X ran fine but my network connection settings seemed to have disappeared so i had to configure network too

 

now Im with the legacy driver

latest nvidia driver is said to be for geforce/quadro so why the heck wouldn`t it install

I`ll take some other distro this is too much for a newbie

:wall:

 

As I mentioned before, if no luck with dkms-nvidia or dkms-nvidia_legacy, try the drivers direct from nvidias website and use the instructions I provided.

 

But if you do use another distro, it might work better, but then again it might not. But give it a go, see what you prefer to use and get working.

Share this post


Link to post
Share on other sites
try the drivers direct from nvidias website and use the instructions I provided.

I tried numerous times!In fact I have three drivers downloaded from this site and I followed every directions like switching to runlevel 3

and then ./driver name.It simply won`t install

10x alot to everyone,especially to ianw1974.I`m sorry for losing your time and mine too.

 

I am now downloading suse with ktorrent after that I wil format my hard disk gladly

Edited by ulukaj

Share this post


Link to post
Share on other sites

I normally do:

 

sh drivername

 

just in case it wasn't installing when you were typing the name directly. Hope you have more luck with SuSe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...