Jump to content

Popfile [solved]


Recommended Posts

I have been trying to get Popfile running. I installed it using urpmi. When I try to connect to I get

The connection was refused when attempting to contact


I get the same error message when tryijng to connect using http://localhost:8080. From what I understand, after connecting, I shoudl be able to configure the bucketts.


If I do a 'chkconfig --list' i get the follwoing line:

popfile 0:off 1:off 2:off 3:on 4:on 5:on 6:off


So, it appears to be enabled for run levels 3, 4, and 5.


If I do a 'popfile stop' the last few lines show:


[/code] Starting...

{core: history mq config


A copy of POPFile appears to be running.

Attempting to signal the previous copy.

Waiting 10 seconds for a reply.


The other POPFile failed to signal back, starting new copy


{interface: html xmlrpc}

{classifier: bayes}

{proxy: smtp pop3 nntp}


POPFile Engine v0.20.0 running

Can't locate object method "get_user_path_" via package "POPFile::History" at POPFile/History.pm line 1167.


Any thoughts on what to do to get this going?

Link to comment
Share on other sites

I ran namp and it reports that port 8080 is in fact closed. Now I know what ports are open, and 8080 is not one of them.


How do I open this port? Never had to do this before. Thanks in advance.

Link to comment
Share on other sites

When popfile successfully starts, you will be able to connect to it....the port will open. Your problem is here:

POPFile Engine v0.20.0 running
Can't locate object method "get_user_path_" via package "POPFile::History" at POPFile/History.pm line 1167

Which means popfile died. I have found no answer to the problem.

The "There seems to be a running instance..." error is one I have been getting lately, even though popfile is not actually running. It's annoying but harmless.

Link to comment
Share on other sites

O.K. I got popfile going to the point where I can connect to port localhost:8080. Here is what I had to do. I had attempted to follow the install instructions to install popfile from the tar archive. That did not work, I cound not get this step to work. " chkconfig --add /etc/init.d/popfile " I then made the mistake of installing the rpm using urpmi. That produced the errors above. Lesson learned... :wall:


To get things going, I uninstalled the rpm, and then went back through the install instructions and wipped out all the files I had installed from the tar archive.


Next I installed using the rpm. I can now connect to localhost:8080. :thumbs: Thank-you for the help! :thanks:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...