Jump to content

lucent drivers, mandrake 10.2

Guest Carmelo

Recommended Posts

Guest Carmelo

The explanation that was given here won't work for my PC, I think it's because the version, and because I can't post this there, I will post it here..... so ....Does anyone know where to find drivers for Mandrake (Mandriva) 10.2 , kernel 2.6.11, and how to install them, and to work........??? :help: (rpm link would be great ....(working rpm)). :wall:




tnx for the help in advance. :thanks:

Link to comment
Share on other sites



You need to have the kernel source installed. It should be on your Mandrake CD.

Use the rpm package manager in kde and search for "kernel" if you see the kernel source with the same version as the kernel you have then install it.


I used a non mdk one from here and the makefile ran alright. However, the modem initializes and kppp can query it but I can't get it to dial. :angry:


I haven't tried the newer drivers (I hadn't noticed them, so I'll try them tonight). The read me files are very helpful so check them out.


If you have any luck then let me know as it's driving me mad too.

Link to comment
Share on other sites

Hey there guys, I can appreciate your hardship here, been trying to build a working driver for my scatty winmodem (don't flame me, I bought the box well over three years ago when winmodems were allegedly the in thing......!).


Just managed to get the kernel source to compile last night (been at this for a couple of days, total linux noob here), had to quit as it was waaay past my bedtime. Will be having another run this evening, let you all know how I get on.



Link to comment
Share on other sites

Below are instructions on how to get a Lucent Winmodem to run under Mandriva Linux LE 2005/Mandriva Linux 10.2


I have just collected the information from different read me files that came with the drivers and made them a little easier for newbies, like me, to understand.









You will need to have the kernel source installed.

Go to Rpmdrake and search under "kernel"

Rpmdrake can also be found under the menu as follows:


System/configuration/packaging/install software


For me the source came under "kernel-source-2.6-2.6.11-6mdk"

Check your kernel to make sure that the source is the same version by running


uname -r


This will give you the kernel version

If you can't find the kernel source in Rpmdrake then it is probably already installed, check /lib/modules/"yourKernelVersionHere"





Now download the modem drivers from here:




I used this driver:




Uncompress the driver to a temporary directory


open the makefile


Inside the makefile change the following line


KERNEL_DIR := /lib/modules/'uname -r' /build


KERNEL_DIR := /lib/modules/2.6.11-6mdk


NOTE: yours might be different check /lib/modules for your folder name.


Do the same for the line

INSTALL_DIR := /lib/modules/'uname -r' /other

replacing the 'uname -r' with the folder name you had above.


now run the makefile, do this using the console make sure you are in the directory of your ltmodem-2.6-alk-7 and type




If you have the kernel source installed correctly the make file should create two files inside the modem driver folder, these being:





Copy these two files to the following directory if they aren't already there.




NOTE:replace the "2.6.11-6mdk" in the path with whatever you have for your version.


Then type


depmod -a






Now we need to create the device /dev/ttyLTM0 by doing the following you need to be root so type the following to gain root privileges:




You will be prompted for the root password, once you have entered this type the below to creat the device


mknod --mode=0660 /dev/ttyLTM0 c 62 64


Now go into the docs folder that came with the drivers you downloaded and copy the file called ltmodem.rules to your folder /etc/udev/rules.d if you see a file called modem.rules then delete that.


The above process will create a symbolic link from the device /dev/ttyLTM0 that you created with the /dev/modem device each time you start up the computer.


If you find that you don't have a /etc/udev folder then udev isn't installed on your system. In this case you will need to manually create the link by typing

ln -s /dev/ttyLTM0 /dev/modem

You will probably have to do this everytime you start up, remember you need to be root to do this. * See the end of this document for more info if you don't have udev


now edit your /etc/modeprobe.conf file and add the following lines


alias /dev/modem ltserial

alias char-major-62 ltserial

alias /dev/ttyLTM0 ltserial


The original modem driver read me file has the last line "alias /dev/ttyLTM0 ltserial" as "alias /dev/tts/LT0 ltserial" however I didn't find that to work.










Now open kppp (Menu Internet/Remote Access) push the "Configure" button click the "Modems" tab and add a new modem.


In the Modem device setting choose "/dev/modem" and select connection speed as "57600".


Now click the "Modem" tab and push the button "Query Modem" if this works then the drivers are probably doing their magic. Now configure your account to add the phone number for your ISP and your login and password.


You may need to manually enter the dns server addresses if you find that when you connect you can't load a web page but you can ping internet addresses by their IP number. Get your dns server addresses from your ISP's website or phone them.






If you find that your modem dials your isp however there doesn't seem to be any traffic and you can't ping IP addresses then check your firewall.


Open your firewall via the menu System/Configuration/Configure your Computer.


Go to the icon called "Set up a personal firewall......"

Ignore the first screen unless you want to turn the firewall off completely or you plan on running servers that require ports opened.


On the next screen choose "ppp+" to indicate to the firewall that you are using a modem to connect. Click OK


Pleae note that I have only been using Linux for 4 days so if this doesn't work then don't flame me. I find that my modem is very tempremental and can take a few tries to get going, sometimes a shutdown and restart of the system is required to get it going. My modem was very tempremental under Win xp until I got better drivers so it might not be too bad with your system.





* If you aren not using udev and you had to manually create a link between /dev/ttyLTM0 and /dev/modem then add the following to your /etc/modprobe.conf file:


install winmodem /sbin/modprobe ltserial

alias /dev/modem ltserial

alias char-major-62 ltserial

alias /dev/tts/LT0 ltserial


If you already changed the modprobe.conf file earlier then make sure it looks like the above.


Then add the following line to your /etc/modprobe.preload




This should hopefully keep the link between /dev/ttyLTM0 and /dev/modem devices alive each time you reboot.

Link to comment
Share on other sites

  • 1 month later...
Guest tuxboy2k5


I followed the procedure you have outlined above. However, it still would not work. I notice that if I use simplyMepis it does work but on a /dev/slamr0. Also, from your guide above, I have done the mknod command and it created the device files. Whenever I reboot the machine per your instruction, the device file is gone. I have done an lsmod and ltmodem is there. Something I have done wrong?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...