Jump to content

2 minute pause between lilo and boot up [solved]


Recommended Posts

FIXED see my last post below. This has to do with dma timeout errors.




I am new here and fairly new to Linux.

I've just installed Mandriva LE 2005 (Download edition)


My problems is after selecting Linux under Lilo, the splash screen comes up with the progress bar and nothing happens for about 2 minutes.


My hard disk light is on but I can tell it isn't spinning the hard disk on which Linux is installed as that is a noisy hard disk and you can hear it spin.


Then after this pause linux boots up fine and everything works normally. This happens every time I boot/reboot. I wouldn't mind if the pause weren't so very looooong.



My system is as follows:

Dual boot Win XP Pro and Mandrake 2005 LE

AMD Athlon 3000 +

1024 MB of 333 Mhz DDR

40 GB HD (C:/ for WIN XP)

20 GB HD (the primary partion has Linux installed)

GA 7VAX Gigabyte Motherboard

Via KT 400 Chipset

ATi Radeon 9800 Pro

Creative Audigy Soundblaster (Has Firewire port on it)


Now I would post a print of my dmesg from boot up but I don't think this would help as this problem seems to occur with nothing running. All I see is the splash screen and the progress bar not moving. Then when boot up starts I can go into interactive mode but there are no problems during the actual boot, once it gets going.


I noticed the same kind of pause whilst installing Mandriva, after selecting the keyboard it paused for about 45 seconds before continuing with the installation.


I have installed this installation successfully as a virtual machine on Win XP using VMware and there are no problems with this so I don't think the media or the downloaded data is corrupted.


I have disabled my onboard network card in case this was the culprit.


Lilo is installed on the MBR.


I'm guessing that Linux doesn't like something on my bios or my CMOS settings, or maybe the amount of Ram I have?



Edited by Xnomad
Link to comment
Share on other sites

I have done a google search and found the following info:


edit /etc/lilo.conf and change devfs=mount to devfs=nomount , save, run lilo, make sure udev is enabled (chkconfig udev on), reboot.


Does that help?

Link to comment
Share on other sites

Ok fixed it!


The problem was a dma timeout error on my hdb (the hard disk with Mandriva installed) it's an old hard disk and I read that this can be due to bad sectors which is probably the case with the old disk. I've tried to fix these sectors before in the past but that's another story.


I booted up linux using the failsafe option in lilo and the error messages came up. Under regular booting you are not able to see these messages as the splashscreen hides them and it occurs well before you can push esc for the verbose boot up.


So I went into /etc/lilo.conf and added the following to the default linux section.


append=" ide=nodma"


this turns off dma support for all drives.


If there already is an "append" line in your lilo then just add the ide=nodma inside the " " after the other arguments that follow "append="


once I saved that I ran /sbin/lilo and then rebooted and the boot process was what I would call normal. :D


Only problem is that udma is turned off for all drives so playing DVD's is a problem. I used


hdparm -d1 /dev/dvd


(-d1 flag turns dma on and -d0 turns dma off for the respective device.)


to enable dma for the dvd, I haven't checked to see if I have to do this every time after a reboot.


EDIT: to get hdparm to enable dma on the dvd player at reboot type the following line into your /etc/rc.local fiel


hdparm -d1 /dev/dvd


or even this (stolen from another site)


Tuning the Drive


It may come as a surprise to learn that you can tune your DVD and CD-ROM drives as easily as you can tune your hard disks. The hdparm utility can optimize drive performance to peak efficiency, run it (as root) with at least the following parameter options:


hdparm -c1 -d1 -a8 -u1 /dev/hdd




where -c1 enables 32-bit I/O, -d1 enables DMA access, -a8 sets the filesystem read-ahead value and -u1 sets the drive's interrupt-unmask flag. /dev/hdd should specify your particular DVD drive device location.


The parameters shown above work well with my DVD drive, but I urge you to read the hdparm manual page (man hdparm) before running the utility. Your DVD drive is a read-only device, so filesystem corruption is not an issue here. You might, however, inadvertently lower your drive's efficiency with non-optimal settings.

Edited by Xnomad
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...