Jump to content

linksys wag54g


Recommended Posts

Hello all,


I just bought a linksys 54g wireless modem/router, but i can't set it up. I was stupid and tried the wizards, but that didn't work of course. The situation now is:

1) can't connect to the modem; this should be done with a web browser, but the connection is refused.

2) eth0 is, netmask


Does anyone have any ideas?



Link to comment
Share on other sites

Usually, they set the default IP address to something like or Have you been able to connect to it at all?


If not, this may be why. If it's ethernet based, then it shouldn't be a problem providing you have the correct IP range, and you can use a web browser to connect to most of them.


Hope this helps!

Link to comment
Share on other sites

Additionally, if you were able to connect and now can't, there will be a reset button on the router to set it back to the factory defaults.

Link to comment
Share on other sites

If your ethernet is, then you would have a prob. Set it to and subnet of then you can see your router.


Then what you can do is change the IP of the router to the 10 range you had before, and then switch your PC IP back to it's original one, and then go back into the router, and carry on configuring.

Link to comment
Share on other sites

I changed eth0 to the values you advise, but I still can't see the router. More precisely, i set it to these values:



IPADDR= # or whatever your IP address is to be - see above

NETMASK= # or if your IP address is 10.x.x.x

NETWORK= # or if your IP address is 10.x.x.x or if your IP address is 192.168.2.x

BROADCAST= # or if your IP address is 10.x.x.x or if your IP address is 192.168.2.x




taken from streeter's howto.


But still no luck.



Link to comment
Share on other sites

Do you have lights on your PC ethernet card, and also lights for the port you are plugged into on the router?


My ethernet is configuring as follows: - PC ethernet - Subnet Mask - Default Gateway - which points to the router's IP.


DNS - the ISP supplied

DNS - the ISP supplied (I have two in case one server fails).


There is a hosts: line in your nsswitch.conf, what does this say? It should say:


hosts: files nisplus nis dns wins (maybe not wins depending on your config).

Link to comment
Share on other sites

There is a tiny light on the ethernet card, but not on the port of the router.


Where do I set the default gateway?


I haven't set the dns yet, because the modem/router is supposed to do that, once I can connect to it.


And the hosts are the same as yours, except wins.


I also tried pinging, and I got response from the ethernet card, but not from the router.


Also (I hang my head in shame) I put the right cable in between the card and the router (I'd been using a phojne cable), but alas that didn't solve it either.


I really appreciate your help btw, thanks.



Link to comment
Share on other sites

I have normally configured mine using the GUI interface for Linux Mandrake 10.1.


I'm not sure what distro you use, but I reckon it would configure the same. The gateway is just to route everything that's not on your network, ie internet traffic.


So, as your IP is, and you have the subnet as, the gateway would be


Your dns would have to be specified if you are using a static IP. If you obtain DHCP instead, then the gateway will assign it when you connect. What might be good, to ensure connectivity, is set the PC to DHCP and see if it picks up an IP address. If it doesn't, then there is definitely a connectivity issue between your PC and router.


The PC is patched to one of the four ethernet ports, and not the WAN port on the router? (just making sure).

Link to comment
Share on other sites

No, don't need PPP, this is for dialup connections, modems, USB adsl, that sort of stuff.


You're just using the ethernet, so that's cool. Boot to KDE, then go to mcc and configure the network there.


I don't know your router specifically, but normally they do have link lights to show which port your connected to. Check for numbers on the front or lights near the patch at the back for activity.

Link to comment
Share on other sites

Hi derxen


Can you post the output of

ifconfig eth0


route -n

for us? We need to make sure that eth0 is coming up correctly.


As ianw says, you could also try DHCP - Install the dhcp-client package (if it's not already installed) and type

dhclient eth0

. This should get the IP set up from the WAG54G even if you have set it up to come up manually - no need to change ifcfg-eth0 at this stage.


Have you any other machines on the network?


There should be a link light on the FRONT of the WAG54G, corresponding to the port used by the ethernet cable - which should be a straight through type (1-1, 2-2 etc)



Link to comment
Share on other sites

It's difficult posting output, because I'm writingt this from a laptop that's still connected to the net via another modem. Everything is messed up now, after I tried to set things up via drakconnect: I'm not at localhost anymore, but at, and eth0 is gone. eth0 came up well before that. Running dhclient gave a negative too, únknown hardware address type 776', and 'no dhcp offers received.


The light is not blinking, and there are no other machines on the network. I'm stumped.



Link to comment
Share on other sites

OK, try this.


Go to MCC - "Configure Your Computer".


Go to Hardware.


Double click hardware icon.


Select network card.


Click Run Config tool.


Choose LAN option.


Supply the details for hostname - whatever you want to call the machine eg: mylinuxmachine

Give IP address

Give Subnet

Give Gateway

Give DNS addresses


Or alternatively set as DHCP if you wish.


No need to set anything on zeroconf.

Edited by ianw1974
Link to comment
Share on other sites

Finally checked the cables again, pushed them a bit, and got the lights on. Sorry about the anticlimax. Thanks for all your help, it was the bit about the lights that did it in the end, but I learnt a lot along the way.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...