Jump to content

Need help doing jpg's


Recommended Posts

I am new to linux. In fact this is my first week. Please go easy. Do not assume I know anything.


OK, here goes. I do ebay. I need to know how to get the jpg's that my camera [ I have an Olympus C-3030] puts on a smart digital card on my computer [without using windows programs, I already know how to do it with windows programs]. :cheeky: I have a usb cable that hooks up to my camera and I have a card reader... one in one of my computers and one that uses a usb port.


Then I need to know how to find the files so I can use a program to resize them. I also need a program to do the resizing.


After that I need to know how to find them so I can upload them to ebay or my web page[using some kind of ftp program...not sure if linux has something simular ]. :help:


Is there a how to for this?? I used google.com/linux and the form search with no luck. :wall:


Surly there is a photo buff out there who knows how to do this. I know I can't be the only one who wants to do this.


If there is someone close to Port St. Lucie, Fl. That would be willing to walk me through this, I would be very greatful. I used to run dive and fishing charters and could swap info for info. :beer::thanks:


Thanks Ron

Link to comment
Share on other sites

I think digikam supports you camera (in my list it says olympus c-3030z) but maybe it's close enought to work. Else usb mass storage will probably work.


To instal digikam. As root type: urpmi digikam. To get the picks: plug the usb cable directly from your camera in the PC. Start digikam, configure it for use with your camera. click on camera, click on download etc etc. It's as simple as that.


For a simple resize use the digikam plugins (urpmi digikam-plugins). Rightclick on the pic and choose transform.


Konqueror is an FTP client. Just type the ftp adress in the adress-bar and drag and drop the photos to the site.


Linux is so much easier than windows :D


Have fun.

Link to comment
Share on other sites

plug the camera into the usb port, turn on the camera. if it doesn't automount, in terminal as root do.........


mount /mnt/removable


open Konqueror file manager (or your favourite file manager), go to the /mnt/removable/ directory, you should be able to browse your camera & view pics.


easiest way to resize/manipulate them is to simply use Gimp. i do it all the time. nurn them to disc if you like using K3b.


when done playing, in terminal as root do.........


umount /mnt/removable


turn off the camera, unplug it, done.



Edited by chris z
Link to comment
Share on other sites

OK . I played with digikam and it and the Gimp drove me crazy. :screwy: It did see my camera and let me down load the images, but would not let me put them into a folder I saved for them??? Then neither would resize the images or shrink them down to a size I could use to upload to ebay or my web page. I know I hit every button on digkam with no luck. I went to their web site and it show all kinds of things that I could not get the program to do. Maybe I am missing some plug ins or something[ could be operator error] did open up a the terminal [myname@localhost mds63]$ urpmi digikam-plugins

bash: urpmi: command not found

[myname@localhost mds63]$. I probably did that wrong too. :wall:


Gimp was the same way only a whole lot more intense. I know that was operator error.


So I went to the ImageMagick web site. This looks to be what I want. How do I get it??? Remember I have never done this before. Is there a How to some where for this? I know with windows you click on the down load button, it puts it on your desktop as a .exe. You click on that and it loads. I know that it is not that way in linux and I have really been dreading that I would have to try and do this.


I have already messed up 3 times so far and have had to uninstall and reinstall. :wall:


I do not know what is going to happen with this one as I read in one of the post that you could put more than one distro and windows on a hard disk in any order as long as windows was first and the boot loader would see all of them. I put windows ME first along with all the programs I need for it on about 5gb, :jester: [ boy was that fun] That left me 10 more GB'sThen I deleted the messed up M 10.1 ce. Put on Ubunto. Booted and Ubunto came up fine.Then M 10.1 ce again. When I booted back up it only saw linux, safe and windows. When I clicked enter on linux it booted M 10.1 ce. No ubuntu to be found. :oops: I belive I have bit the big one. So although I am not afraid of trying different things , I am tired of screwing up and having to start over again. Which I see that in my near future. I do not want to shut my computer down till I learn how to down load programs. I figure this will save me a few headaches. PLEASE :help: Thanks, Ron


I even found a way to screw up my avitar :lol2:

Link to comment
Share on other sites

you need to be root to run urpmi. To get ImageMagick, do 'urpmi ImageMagick' , as root. The graphical software installer, on the Mandrake menu somewhere, can do everything urpmi does - go ahead and use that if it feels more comfortable. Just search for ImageMagick, then install it - or digikam-plugins, or whatever package you want.


You can fix the bootloader, no reinstall needed. You just need to configure it to point at your Ubuntu as well as MDK and Windows. I'm not great on bootloaders so I'll let someone else help you here, just posting early to make sure you don't go reinstalling yet :)

Link to comment
Share on other sites

You may already have ImageMagick, go to the mandrake control panel (open a terminal and type MCC) and look for software and see if you can figure out whether you have image magick.


also, open a terminal console and type


rpm -qa image | more


should list all software packages with image as part of the package.. (think I have this right)

Link to comment
Share on other sites

Sounds to me you started off the wrong foot here. My piece of advise would be to start fresh and use aRTEE's instructions found elswhere here on this forum to install the mandrake version u like. If being fresh I suggest to go for the official install of mandrake 10.0, or if you are willing to become member for a small fee you can now download 10.1 official.. Then during install just select all the desktops, ie kde, gnome and others. That installs more programs so you can try them and see which one fits your needs.


But there is no cutting corners. Everytime I hear someone say 'i only need' turns out to be that they need a lot lot more than the initial thought and it becomes more complicated in the process. So again start fresh but more detailed now. The programs I use for this type of work is Gimp v2 to edit the images (if you know adobe photoshop, this is a breeze, if you don't a nightmare worth investing your time cuz your abilities to edit the images is near endless) then I use kbear to manage my website (ftp) and blue fish to edit html documents and the like. All these packages you can install using the mandrake control center (star>system>configure your computer). If you take your time to get to know these programs you will be the master of your entire website (and camera). :banana:

Link to comment
Share on other sites

OK I downloaded all the updates from Easy Urpmi for 10.1 OFFICIAL. Probably did it wrong because It said Installation Failed.some files are missing, then the mirror sites I used followed by you may want to up date your urpmi database.


Anyway when I rebooted, I ended up with 10.1 Official. Things are a little goofy but I will cross that later.


I did urpmi ImageMagic. It said it was already there. I opened MCC to find ImageMagic. Software> Install. Typed in ImagicMagic. It found 3 things ... all documents I think. It would not let me down load the abiword " due to unsatisfied abiword[==2.1.7]". Not sure what that means ,Other than "YOU AIN'T GETTIN IT!!".


Tried the other two. Could not do it as when I put CD 2 in hdc it would not read the CD in the drive. I had the same problem when I first down loaded Mandrake 10.1ce. I had to put it in the hdd drive. Also sound does not work in hdd. It worked before I down loaded 10.1 Official. :screwy:


Even If I get the documents. I still can not find the ImageMagic program to install just the info for it. Of course even if I could find it not sure how to install. :help:


Now I went back and typed urpmi ImageMagic and it said it urpmi database locked. Have messed up again??? :wall:


Boy, I do not know what is going on.I must have locked the workstation somehow...human glitch. I rebooted because Rosegarden locked up. Now just for grins I did urpmi ImageMagic. It came back with The following packages contain ImageMagic. ImageMagic ImageMage-doc.So I did mcc again with the same problems as above with the cd drives. :help: I do not know whether it is a hardware or software problem. I am thinking software. :help: Thanks Ron

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...