Jump to content
Sign in to follow this  
MadHattr

linksys pcmcia nc100

Recommended Posts

:help: I just finished installing mandrake 10 on my compaq presario 1700t, i am trying to get it on the internet via my new linksys etherfast nc100 i have the device pluged in, but it does not show up in hardrake is there anything i must do to detect and or install a pcmcia driver or whatever would be needed? This is my first time installing linux on a labtop so any thing of help would be thankful :banana:

 

[moved from Hardware by spinynorman]

Share this post


Link to post
Share on other sites

One easy thing to try - put your card in and hook up the ethernet cable. Put install cd-1 in and reboot. Rerun the install and choose the "upgrade" option. Don't select any new pckages. With any luck, the install program will detect your new card and set it up for you automagically.

Share this post


Link to post
Share on other sites

Ok, i did the upgrade and it said something about loading pcmcia but when i go to the internet configuration of the install it says select the network interface to configure, and all it shows is the built in conexant|LANfinity ethernet card. This card is broken and does not work, the computer thinks it does but it does not connect to the internet, thus the reason i am trying to use a pcmcia ethernetcard. I have gone through the bios and there is no way to turn off the ethernet card? is there something i must first do to get it to reconize the pcmcia card as my ethernet card?

 

at boot it says starting pcmcia: cardmgr socket 0 linksys network everywhere np100 [ OK ]

 

Also the hardware is not listed in hardrake

Edited by MadHattr

Share this post


Link to post
Share on other sites

The first thing to check is whether you have pcmcia enabled in mcc>System>Services. See if it's set to start on boot and if it's currently running. Given your boot merssages, it should be. Also, open a console, su to root and run:

 

# lsmod

 

and see if the pcmcia_core module is listed in the output. It should be. Finally, run:

 

$ lspci

 

with the card inserted and see if the card is picked up in the output. If it's not in mcc, it probably won't be.

 

That will give you some basic info on what's going on.

 

Another suggestion if you don't have a lot of data that you want to save in your current mdk install is to try mdk10.1-CE. It's much improved for laptops. I had a lot of hardware detection problems on my new dell inspiron 5160 when I tried to install mdk10 that disappeared with mdk10.1-CE. If you want to go this route, do a fresh install instead of an upgrade.

Share this post


Link to post
Share on other sites

There is a known bug in Mandrake 10 OE that doesn't load the modules needed for pcmcia cards. To work around it, edit your /etc/modprobe.preload file and add these two lines

 

yenta_socket

cardmgr

 

reboot and check whether your pcmcia card works. Don't forget to install the pcmcia rpms and turn on the pcmcia service in drakxservices.

Share this post


Link to post
Share on other sites

OK, i went ahead and did an upgrade with 10.1 ce everything installed but the ethernet card has not been detected and internet is still not working. When i type lsmod it lists

 

pcmcia_core 59972 3 pcnet_cs,ds,yenta_socket

 

pcnet_cs is the module needed for my ethernet card so i am assuming the computer atleast knows it has it installed?

 

How can i select this device for use as my ethernet card? it does not show up in harddrake or crakeconnect or whatever the wizard was for internet

Share this post


Link to post
Share on other sites

On the tray to the right on the bottom, do you have an icon that looks like two plugs disconnected? If you do, right click and select "connect eth0" (or whatever device is there).

It take a few seconds but you should see the icon change state and appear connected.

For what ever reason, when 10.1 starts, it doesn't start connected by default and you have to manually start it.

If this doesn't work, then in MCC remove all connections and reinstall and set up all parameters (keys, etc.) Then repeat the process.

Share this post


Link to post
Share on other sites

This is progress. I assume the card is being recognized and the driver is loading. You should see the card listed in lspci. The driver for your card is autoloaded at boot from /etc/modprobe.conf. Double check to make sure this is the case by opening the file and seeing a line like this is there:

 

alias eth1 pcnet_cs

 

You will also see an entry for eth0 which is your old nic.

 

That's the first step in setting up a nic, dermining the chipset for the nic and getting the right driver loaded. The system will then recognize the nic and you can set up the network interface for it. That's done by creating a text config file in /etc/sysconfig/network-scripts. That's what mcc does but in the past, I've found it doesn't work very well when you have multiple nics.

Let me walk you through how to do this manually. Your going to have to edit some config files and you will need to be root to do so. Open a console and run:

 

$ kdesu konqueror

 

Enter your root password when prompted and konqueror will come up with root privileges. Navigate to /etc/sysconfig/network-scripts. You should see some text config files in there of the form "ifcfg-eth0", "ifcfg-lo" and possibly "ifcfg-eth1". Double click on ifcfg-eth0 and the text will come up in kwrite for viewing. This is the network config file for your on board nic. Mandrake probably set this up as your default automatically. If your using dhcp(i.e. you don't have a static ip), it will probably look something like this:

 

DEVICE=eth0

BOOTPROTO=dhcp

NETMASK=255.255.255.0

ONBOOT=yes

METRIC=10

 

Since your not using this interface, change ONBOOT=yes to ONBOOT=no. Next, you have to create a config file for eth1, your pcmcia nic. If you don't have an ifcfg-eth1 create one by making a new text file(right click in konqueror>Create New>File>Text File) and name it ifcfg-eth1. Open the file you just created and copy and paste the text from ifcfg-eth0 to ifcfg-eth1 and change DEVICE to eth1 and ONBOOT to yes. ifcfg-eth1 will then look like this:

 

DEVICE=eth1

BOOTPROTO=dhcp

NETMASK=255.255.255.0

ONBOOT=yes

METRIC=10

 

 

Now to test it. Open a console, su to root and run:

 

 

# ifdown eth0

# ifup eth1

 

 

That shuts down eth0 and brings up eth1. See if you can surf the internet.

If not post back. There might be a problem with your domain name server from your isp not being set up correctly during your install. That's easy to fix but I don't want to go into it if it's not a problem.

 

EDIT IMPORTANT: Are you sure that's the right driver for your nic? A quick google seems to indicate that it should use the tulip driver. If you don't have the right driver loaded, your nic won't work and "ifup eth1" will fail with an error message. If that happens, try running:

 

# rmmod pcnet_cs

# modprobe tulip

# ifup eth1

Edited by pmpatrick

Share this post


Link to post
Share on other sites

I assume the card is not listed in mcc>Hardware as well. What do you get when you run:

 

# ifconfig

 

If your dual booting with windows, is the card recognized in windows?

Share this post


Link to post
Share on other sites
Guest MadHatter

Yes, it is recognized in Windows. Why can't you give me some information that is helpful? Good grief!

 

[edited by spinynorman]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...