Jump to content
Sign in to follow this  
hopeful

problems after updating Offical

Recommended Posts

Hi

 

I have installed 10 official set everything up and a few days ago I updated everything with control centre update software. Ever since I have numerous crash messages coming up re Kconquer etc and I have lost system out of the menu, I have also become stuck in init 3 -though this may have happened when I installed the Nvidia drivers. The installation works but I cannot login as gnome etc and I would like to be able to get System back so I can configure desktop etc. Any ideas?

 

Confused

Share this post


Link to post
Share on other sites

Wow.

 

First, boot and login. su to root and use your favorite editor to edit the /etc/X11/XF86Config file to use the "nv" driver. This will get you back to your gui without having to trouble shoot the nvidia just yet. Do that first and then let's try to take one problem specifically at a time.

Share this post


Link to post
Share on other sites

Dear Ixthusdan

 

Thank you for the reply. I have tried to do what you say but I cannot work out what to change in the XFConfig file. Where will I find the driver to change?

I fully agree with one step at a time.

 

Hopeful

Share this post


Link to post
Share on other sites

Find the following section, toward the bottom:

Section "Device"
   Identifier "device1"
   VendorName "NVidia"
   BoardName "NVIDIA GeForce FX (generic)"
   Driver "nvidia"
   Option "DPMS"
EndSection

 

Change "nvidia" to "nv" on the driver line.

Share this post


Link to post
Share on other sites

You'll know if you are in init 3 if you are booing to console. To get back to init 5, switch to root and type:

init 5

Reboot and you should get the gui next time.

Edited by spiedra

Share this post


Link to post
Share on other sites

OK.

There are two things you can do. Actually, the easiest is to edit /etc/initab.

 

Find this line

id:3:initdefault:

 

Change it to read this:

id:5:initdefault:

 

Reboot.

Share this post


Link to post
Share on other sites

Hello lxthusdan. I think you mean inittab. I don't think there is a initab.

I have made a note of the hint. Thanks very much. :thumbs:

Cheers. John.

Share this post


Link to post
Share on other sites
Hello lxthusdan.              I think you mean      inittab.          I don't think there is a      initab.

I have made a note of the hint.              Thanks very much. :thumbs: 

Cheers.              John.

Hi Ixthusdan and AussieJohn

 

Thanks for the advice it worked a treat :thanks:

 

Now to the next step all the crash messages I get. These are along the lines "the application unknown (usually K something ge kmix etc) crashed adn caused signal 11 *SIGSEGV). I have been getting these since I either installed How to, into the menu or updated myfiles. I have also not been able to configure KDE with LookandFeel because System no longer appears in Menu.

 

Anyway thanks for the help, it is great to be able to use Windowmaker again.

 

happy hopeful :thumbs:

Share this post


Link to post
Share on other sites

OK

 

Something is borked in kde. Be certain that your updates included all depends. Did you allow the MCC update to install all updates including the depends?

 

Another thing to try is check if it's not something in your user kde fle In /home/yourusername, find a file .kde. (the dot hides it) Re-name the file to .kde-back, and lauch kde with your user again. It will make new pref files, and if it works, then something is wrong in your user files and not kde.

 

The fact that windwmaker works means x.org is ok. (Or x).

Share this post


Link to post
Share on other sites

Regarding missing titles in the Menu. You can fix that by opening Konsole and typing menudrake . This will open menudrake for you so you can do a menu recovery.

 

At the top left side, click on File then click on Reload System Menu.

 

You will see a little zig-zag activity and then you can close menudrake and the next time you select Menu, you should see all the apparently missing items.

 

Cheers. John.

 

Using Konsole, you can also open up KDE Control Centre for Look & Feel by simply typing kcontrol .

 

Using Konsole, you can also open up Mandrake Control Centre by simply typing mcc .

Edited by AussieJohn

Share this post


Link to post
Share on other sites
Regarding missing titles in the Menu.  You can fix that by opening Konsole and typing    menudrake  .    This will open menudrake for you so you can do a menu recovery. 

 

At the top left side, click on File  then click on  Reload System Menu.

 

You will see a little zig-zag activity and then you can close menudrake and the next time you select Menu, you should see all the apparently missing items.

 

Cheers.                      John.

 

Using Konsole,  you can also open up KDE Control Centre for Look & Feel  by simply typing    kcontrol        .

 

Using Konsole,  you can also open up Mandrake Control Centre    by simply typing    mcc            .

 

Hi Aussiejohn

 

I tried kcontrol and got the following message

[otto@localhost otto]$ kcontrol

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/kids/ group not valid.

kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/

[otto@localhost otto]$ KCrash: Application 'kcontrol' crashing...

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/kids/ group not valid.

 

Is this any help?

 

Cheers

 

Hopeful

Share this post


Link to post
Share on other sites

If you are logging into kde as root, the root desktop does not contain icons. It is deliberate.

 

Do you have a regular user who does not have root permissions?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...