Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here

Alcatel Speedtouch 330 USB ADSL modem - Working!!

Recommended Posts

Hi people,


Just thought i would how i got the modem working on my machine as most people who have broadband in the UK will have this modem and most mandrake 10 users will be using the 2.6 kernel. I have seen other howto's but i only got mine working using advice from a combination of howto's.


Go here




and down load the latest speedtouchconf.tar.gz


download the firmware from here




(unless you have a silver modem , if so go here




untar the speedtouchconf.taz.gz


go to the newly created directory and copy the firmware.zip file to it.


edit the speedtouchconf.sh file and comment out the following lines (by putting a # at the start of the lines that you want to comment out)


# if [ -z "${USB_TYPE}" ]; then

# echo $"No USB Bus found!" | tee -a $LOGFILE

# error=`expr $error + 2`

# fi


become root and ./speedtouchconf.sh


you will have to enter your username and password and your vpi/vci

- in the uk its 0 38


set it to load at boot




your (hopefully) onilne


when i've got a bit of cash i'm getting a router to stop the silly usb modem problems! Remember the OS was free !


Hope this has helped someone


[moved from Hardware by spinynorman - thanks, lets-eat-gary :)]

Share this post

Link to post
Share on other sites
Guest coman

This really works. The speedtouchconf.sh script printed something like "No USB bus found". I hashed the lines in the script (I put # before those 4 lines). And another problem occured in the last stage. It wrote that it couldn't find the microcode, though it had been found before. Solution to this problem is to use microcode provided by official site of Thomson: http://www.speedtouchdsl.com/dvrreg_lx.htm . So you should use instead of rev4fw.zip , KQD6_204.zip . Of corse you just put it still zipped in the folder of speedtouchconf.sh script. I'll try to pass this news as far as I can. In a few days time installation guide on Mandrake 10 Official should be published on http://speedtouchconf.sourceforge.net/ . They are quick - that's why I think so.

P.S. I used the newer script -> 12.08.2004

Great thanks to lets-eat-gary !!!!!!!!! thank You one more time. We should drink once ;)

Share this post

Link to post
Share on other sites

Lets eat gray


I have to thank you from the bottom of my heart for supplying the instructions for setting up speedtocuh 330. I have spent nearly two weeks pulling my hair out, reinstalling and in the process lossing my windows partition and then erasing it. The sense of achievement is wonderfully. Thank you so much.

To all those seeking to set up speedtouch carefully follow the instructions and you will get there.

A question though lets eat gray. I am at present setup to load at boot, is there a way I can set up an ican which will allow me to connect and disconent at will?

Once again many thanks



Share this post

Link to post
Share on other sites
Guest jterryc

:D Ditto on the Last. Being new to Linux I spent the last week trying to fathom out the Benoit Papillaut OpenSource driver, and was about to give up. This worked a treat, now to sort out my TV Card and WAN.

One thing when I first ran this it was looking for Command BC, I found a rpm on the installation disk for a mathematical prog BC and installed this ran it again with great success.


Share this post

Link to post
Share on other sites
Guest stureid

Further to other users' comments, may thanks to lets-eat-gary for his excellent advice.


I too wasted lots of time and effort following bad instructions, but with this advice my installation finally works!


A word of advice - this method requires installation of gcc and bc for it to work - Just use the 'Install software' option in the configuration menus and search on the names 'gcc' and 'bc'. No need for a reboot, you can then install the drivers.



Share this post

Link to post
Share on other sites

I found during setup I had to have the system security setting on 'standard' rather than 'high', or shorewall was interfering with the setup. I've switched it back now with no ill-effects (so far...).

Edited by Dustpuppy

Share this post

Link to post
Share on other sites
Guest xalen

I'd like to say a big thank you to lets-eat-gary. I'm a complete linux newbie. I'd been trying loads of different ways to get my Speedtouch 330 working. Finally came across this and once again found it didn't work but probably from me trying so many different things. So I reinstalled Mandrake 10.0 and started again using only this how to. Only problem I had was as another person above had with bc. Just did a search for bc and found a file named bc-1.06-11mdk.i586.rpm Double clicked this file to install. Ran the configuration ./speedtouchconf.sh (Obviously I'd made the changes specified in the how to before my previous attempt) Now I'm online in Mandrake 10.0

Share this post

Link to post
Share on other sites

Just a quick update to say that the same method works for me with Mandrake 10.1 community.


after looking at a few distro's Mandrake i the only one i can use this modem with the 2.6 kernel (i want to use the 2.6 kernel as it is faster - enemy terrority seems mush faster/smoother using 2.6)


Here are MY findings


- Mandrake 9 - 10 - 10.1 works (with the edits to the script)

- Suse 9.1 works (until reboot - i have to install the driver (and put all the isp details) again to online)

- Mepis 2004.01 - (really fast distro - faster than mandrake 10.1) - could only get it online using the 2.4 kernel

- Yoper 2.1 (fastest OS i've ever seen) - no joy at the minute


Does anyone know of other distros that work


.... stiil need to get a router!

Share this post

Link to post
Share on other sites
Guest mcewena1


A few years ago I had Mandrake 8 installed and was very happy. Then I went to broadband and............ couldn't get the speedtouch going so went back to ******


Now there's no turning back



Share this post

Link to post
Share on other sites
Guest sleeper_service

Thanks, lets-eat-gary - worked a treat B)


I have to stress how important it is to ensure 'gcc' and 'bc' are installed before you start. I missed that the first time and had problems as a result.


Another rod I made for my back was having the alcaudsl.sys file (copied from Windows partition) in the same directory as speedtouchconf.sh from previous attempts. It seemed as though the shell script would pick alcaudsl.sys before rev4fw.zip, and on my system the script eventually failed when using the microcode from alcaudsl.sys. Once I deleted alcaudsl.sys, the script used rev4fw.zip instead and worked fine for me.


Can't thank you all enough as getting connected via broadband is a major breakthrough for me - I can now hang around here and ask lots of irritating newbie questions ;)

Share this post

Link to post
Share on other sites

this is being worked on for 10.1OE to hopefully have it work more or less out of the box, and have the connection properly controlled by Mandrake's networking tools. There's a thread on the Cooker ML discussing it and apparently it's pretty close now. It'd be a huge help if people could try installing Cooker and see how it deals with their Alcatels, and post the results to Bugzilla or the Cooker ML...

Share this post

Link to post
Share on other sites

btw, we had one of those nasty frog Alcatel modems a couple of years back for a while, and had fun getting it to work in 8.2...managed it in the end but dumped it pretty fast for a better modem and a nice router, hehe.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now