Jump to content
Sign in to follow this  
Lord Kenneth

Removable harddrive crazy mounting problem on boot

Recommended Posts

These keep on appearing when I boot up! I never know how many removable things I cam going to have. Usually around 3 or so.

 

I only have one removable hdd. how can I get it so it doesn't give me two useless other "removable"s (the number of the actual hard drive changes, too, sometimes it is removable2, or removable3, or just plain removable)?

 

It gets annoying adding all those useless things to the desktop, too.

Share this post


Link to post
Share on other sites

Do you always have this hdd hooked up when you boot ? I am not sure, but it sounds like your fstab entry for it is not quite right, so it keeps making a new entry for it on every bootup.

Share this post


Link to post
Share on other sites

/dev/ide/host0/bus0/target0/lun0/part3 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/ide/host0/bus0/target1/lun0/part5 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,ro 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,ro 0 0
/dev/ide/host0/bus0/target0/lun0/part1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
/dev/ide/host0/bus0/target0/lun0/part5 /mnt/win_d ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
none /tmp tmpfs defaults 0 0
/dev/hdb1 swap swap defaults 0 0
none /mnt/removable supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable2 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable3 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable4 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable5 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable6 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

 

Yes. it's always on when it boots.

Share this post


Link to post
Share on other sites

Yep, same problem. Try this:

 

In your fstab delete these entries

none /mnt/removable supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable2 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable3 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable4 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable5 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable6 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

and replace with this:

/dev/sda1 /mnt/removable vfat umask=0,rw,user,noauto,exec 0 0

Make sure you have a "removable" directory in your /mnt. Most likely it will be there already. Then reboot. I know, this is probably not necessary, but I'm still new to Linux myself. Make sure you turn off your removable drive before you shut down. When you restart, turn your removable drive back on, before you boot. Your machine will probably say it found new hardware, and ask if you want to run the appropriate setup util. Just say no. When you get to your DE, open up a terminal and type

mount /mnt/removable

You should be able to do this without being root. If you want to unmount it type:

umount /mnt/removable
You may notice right now that transfer rate from your removable drive is slow, this will fix that also. Don't ask me why, but it did for me.

 

Hope this helps. Post back again with results.

Edited by kmc77

Share this post


Link to post
Share on other sites
that worked but it screws up again when I reboot.

 

this is really really annoying. I might switch to gentoo with all these problems mandrake has given me...

LOL....

 

and after you installed gentoo you'll realise how simple this was to stop.

 

Just go to the MCC services... and disable harddrake at boot.

then it will stop recreating the supermount stuff.

 

Supermount has always given trouble and Mandrake have pretended for years it doesnt ... its just the way its always been like having the acpi in the standard install kernel so that half the people that try Mandrake never get past the install before going back to windows...

 

 

to do this in gentoo you would go and modify the init scripts by hand.

Share this post


Link to post
Share on other sites
and after you installed gentoo you'll realise how simple this was to stop.

 

Just go to the MCC services... and disable harddrake at boot.

then it will stop recreating the supermount stuff.

:lol: Oh sure, do it the easy way :lol:

 

I guess I should give it a try that way also. I have just been making sure the drive was unmounted and turned off before rebooting, and turned back on again before booting. Of course, I rarely reboot so I don't notice it that much. Thanks for the tip Gowator. I learn something new in Linux every day.

Share this post


Link to post
Share on other sites

its bvc's tip.... I disabled supermount completely and like you I rarely reboot anyway...

 

I havent actually done it myself ....

you can also use chkconfig from the CLI...

this is a really cool tool and much better for servers... I_Think its what mandrake services is using ion the background...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...