Jump to content
Kieth

skype [solved]

Recommended Posts

I know this topic has been covered several times, even by me, but this time I can't figure out how to get the video working. I've googled until my eyes are starting to bug out. I think I'm just missing a file somewhere, but I obviously cannot find it. As always, I'm mine own worse enemy. The problem was caused by my upgrading my system, then "demoting" it back to 2009.1. After I quit using 2009 a couple of years ago, my computer just wasn't been the same, but always had some annoying "twitches" here and there. When I had 2009.1 the first time, the video in skype was working, and even with 2010, but after going to 2011, no. I even went to using backports from MIB. That's when things were the best, but still not perfect. I got frustrated with it all, and decided to return to 2009.1. I think my computer is just getting too old for the new programs. Anyway, back to my present problem. I'm still using the script that Ian wrote for me. V4l works, because when I put this command, vlc v4l:///dev/video0, in console, vlc comes on. Obviously my web cam works with cheese, too. If I start skype in console, there are no messages.

 

Ideas? Thanks,

Kieth

Edited by Kieth

Share this post


Link to post
Share on other sites

Try running skype from the console and see what it complains about in the console window. This is the best way to see what's going on, usually if something is missing it will tell you. I have a feeling though that the module is either not loaded for the camera, or the wrong one, or conflict between two modules.

Share this post


Link to post
Share on other sites

Thanks for the reply. When I open up skype in console, it doesn't complain about anything. Then I go to options in skype and test the video, and there are still no complaints.

 

With the command dmesg | less, I get the following reading about CIF, which is my web cam.

 

usb 2-1: New USB device found, idVendor=093a, idProduct=2468

usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

usb 2-1: Product: CIF Single Chip

usb 2-1: Manufacturer: Pixart Imaging Inc.

usb 2-1: configuration #1 chosen from 1 choice

gspca: main v2.4.0 registered

gspca: probing 093a:2468

pac207: Pixart Sensor ID 0x27 Chips ID 0x00

pac207: Pixart PAC207BCA Image Processor and Control Chip detected (vid/pid 0x093A:0x2468)

gspca: probe ok

usbcore: registered new interface driver pac207

pac207: registered

usb 2-2: new full speed USB device using uhci_hcd and address 3

EXT4 FS on sdb1, internal journal on sdb1:8

 

Thanks again.

Kieth

Share this post


Link to post
Share on other sites

Check that this file exists:

 

/usr/lib/libv4l/v4l1compat.so

Share this post


Link to post
Share on other sites

Yup, it's there. In the same directory, there's also v4l2convert.so. In fact, with the script you gave me, I also tried that other file, with no luck of course.

Share this post


Link to post
Share on other sites

I enable main, contrib, non-free, plf free and plf non-free backports, did a normal update via console (with MCC, it didn't give me any updates), and now the video works. Others can see me now!!! (Lucky them!! :lol2: )

Share this post


Link to post
Share on other sites

I enable main, contrib, non-free, plf free and plf non-free backports, did a normal update via console (with MCC, it didn't give me any updates), and now the video works. Others can see me now!!! (Lucky them!! :lol2: )

For what it's worth updating via MCC only looks at repositories marked as Update whereas
urpmi --auto-update

looks at all enabled repositories, even newly added ones.

Share this post


Link to post
Share on other sites
For what it's worth updating via MCC only looks at repositories marked as Update whereas

 

urpmi --auto-update

 

looks at all enabled repositories, even newly added ones.

 

Ahhhhh, that explains it. :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...