Jump to content

X not starting after NVIDIA driver update [solved]

Guest Van

Recommended Posts

Hi Iam running 2009.1 spring power pack, after using the(MCC)and updating the nvidia drivers and rebooting, now X does not start.

When in safe mode/console mode and I try to start X I get the error message "Error: API mismatch: the NVIDIA kernel module has version 180.51, but this NVIDIA driver component has version 256.35."

I have had this once before and managed to find a fix for this on Mandriva Bugzilla. I had kept a printout of this but lost it in a cleanup. I have been looking on the Mandriva Bugzilla site but as yet I can not find it.

The fix was to use urpmi in the command line to do the following:


Update media

Remove/uninstall all NVIDIA drivers

Install current NVIDIA drivers


Run XFdrake, configure card



I am not sure if I have missed any steps in the above and what the actual command line structure for these commands are.


I have been running Mandriva since the days of Mandrake off and on for a while, and totally for the last 2 years, but I have been amiss in not learning how to use the command line more often. I have used it for various procedures and fixes but I am not very Fluent in it. (Rough would a better word)


Any help in the above would be greatly appreciated, thanks.

Link to comment
Share on other sites

Just a quick tip: Make sure that you install the correct drivers for your nvidia card, as there are several to choose from. For older cards like the nvidia 5200 FX (which I use), there is e.g. the 173-series-driver that you have to install. Read the description of the driver-package, it will tell you, if you chose the right or the wrong driver. If you have a package/driver-mismatch, you will not get a fully working graphical environment.


Oh, and ... welcome aboard. :beer:

Link to comment
Share on other sites



Have made some progress I think.


Removed nvidia drivers "urpme -a nvidia-"

Tried using info from Mandriva Community wiki "Updating proprietary drivers from backports"

Unfortunately it didn't work.

Using XFdrake managed to get it running on free nv driver at 640 x 480 and now trying to use the MCC GUI to install correct drivers.

No luck as yet.

Cheers Van

Link to comment
Share on other sites

Suggest to simply start with xfdrake. It will pull in packages as needed and allow you to select card, monitor etc. In case this does not work manual repairs are need, first establish what sort of Nvidia card do you have; nvidia has three different drivers for different groups of cards (very old, old and current cards). The package summary will explain what is for what (urpmq --summary -a x11-driver-video-nvidia). You may know, or can spot this during booting. Also believe that the command 'lspci' will help you further. Then check that you have all the necessary software installed: X11-driver for nvidia, nvidia kernel module, DKMS (kernel module management system) and kernel source. The key is to ensure the following four things:


  • Your x11-driver-nvidia package should be suitable for the card you have (description lists that). Note the version number, here 173.14
  • The dkms-nvidia package also should be version 173.14
  • The kernel module, nvidia...-kernel should be version 173.14 AND should include the kernel version of the current kernel (uname -a)
  • You have the kernel sources for the current kernel version installed

Below is what I have on my 2010.2 installation:


dkms-minimal-2.0.19-20mdv2010.1 installed
dkms-2.0.19-20mdv2010.1 installed

Use rpm -qa | grep 'nvidia\|dkms\|kernel' to see what you got.


In addition you will require a dozen or so packages for software development (gcc, make, multiarch-utils, some other -devel software). Urpmi selects this when you select the kernel-devel sources. During install some software will be prepared and after reboot system should load the new nvidia kernel module and later other driver files.


Usually either the version numbers mismatch somewhere or the driver rebuil fails. Can you check your system with this info and see if that helps enough?

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for that, I'm not having much luck at the moment the spare PC I was using to help fix the main unit died hardware failure. Thats why the delay.


Used the command you suggested to see what I have installed and found that I have too many desktop kernels loaded. I used incomplete commands updating from the backports. Lack of knowledge. (urpmi kernel-$ (desktop')-latest kernel-$(desktop')-devel-latest


Can I use something like the following:

urpme -a kernel-$ (desktop')-latest kernel-$ (desktop')-devel-latest to remove the including desktop, kernel, server & devel?

Then do the same for the other desktops using their individual numbers one by one until I have only the ones that I require left? or is there a better way?


In hope Van

Link to comment
Share on other sites

  • 1 month later...

Thanks for your help, problem solved.


Used the commands you suggested to find out what NVIDIA components/drivers I had loaded.

Only worked once or twice then not at all.

In the end since I had the system running on the free nv driver at 640 x 480 I used the MCC to solve the problem.

I had unfortunately loaded up 6 more "Nvidia- current-kernel-" (6 Various desktop and server versions)

Carefully noting what was list on the grub splash screen list, I went into the MCC and the software section.

Using the search facility I located the various desktop kernels and unticked them one by one then rebooted.

I went back into the MCC and the Hardware Section checking on the video card settings. The system detected the remaining desktop kernels and asked to install the correct drivers for them, which I did.

On successfully rebooting all that remained was to reset the screen resolution, which I did.


Thanks again fort all of your help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...