Jump to content

symlink to a target directory [solved]

Recommended Posts

I'm can not create a symbolic link to a directory. I have read, and re-read the man page. I can not get it right.


What is the trick?


I have tried:

ln -s --target-directory=linux- 
ln: missing file operand
Try `ln --help' for more information.


Operand is missing? O.K. so I tried,

ln -s --target-directory=linux- linux

This didn't work as I expected either. It created a link called 'linux' in the target directory, not in the directory I was in.


I need a command that will create a sym link to the target, called linux, in the directory I'm in. The old link is pointing to the wrong source for the current kernel, and I can not get vboxdrv to compile.


Your help is always appreciated...



[moved from Software by spinynorman]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...