Jump to content
highking

MCNLive Kris Beta/RC

Recommended Posts

MCNLive Kris - BETA/RC

 

After a few years of silence around MCNLive, here we are again with a brand new MCNLive release, based on Mandriva 2010.0!

 

It won't have all the nice features you might remember from MCNLive, but the most important things are there. Copy2ram is present, remastering on-the-fly is possible again and even booting from USB is no problem at all!

 

Note that the way MCNLive is put on an USB stick has slightly changed. There is no wizard for this anymore, but you can simply dd the iso image to your stick, just like Mandriva One. You should even be able to use Mandriva Seed to put the image on your stick! :)

 

As I said, there are things which we didn't got running (which doesn't mean it won't return in a next release, just not on "Kris"). For example persistent changes with a loopfile are not possible. Also the boot screens are not graphical (the boot menu still is though).

 

Since you need a lot more memory to run Mandriva 2010.0 with KDE 4.3 then you needed to have in order to run Mandriva 2007.1 with KDE 3.5, we added a bootoption 'useswap', which searches your drive for swap partitions and enables them, giving you some more space to breathe in. ;)

 

 

The name "Kris"

Kris is offcourse the nickname of the original MCNLive maintainer, so in some way this can be seen as a tribute to her work. On the other hand, a kris or keris can be a weapon, which is processed in the wallpaper.

 

mcnlive-kris-beta2-desktop.png

 

 

ISO contents

MCNLive Kris is based upon a fully updated Mandriva 2010.0 release, with KDE SC 4.3 as desktop environment. SMplayer is added for your multimedia needs and since we do have a remaster option, we added K3B to enable you to burn the remaster directly. :)

 

Firefox is the default web browser but you can use Konqueror from the menu if you wish.

 

As you see, "Kris" is not filled with loads of software, but since you are able to remaster it you can easily create your own version with the pieces of software you need. :icon_idea:

 

 

Beta testing

While most should work fine, it can perfectly be that it won't work on your hardware. Besides you might find some issues we haven't found ourselves. If you run into problems running "Kris", please let us know by replying in this topic. Please do not reply with "it doesn't work", but try to ground your reply. One small side note: if your hardware doesn't work on Mandriva One, it probably won't on MCNLive either.

 

In case of hardware problems, the output of this command can be very helpful:

lspcidrake -v

 

 

Putting "Kris" on USB

As said, you should be able to use Mandriva Seed, but if you're not affraid to use the command-line you can easily use the dd-command. Note that you put the image over the whole stick, not on a partition so you lose all contents of the stick!

dd if=mcnlive-kris-beta1.iso of=/dev/sdX bs=8M && sync

Where you change sdX into the device of your choice. Please be careful selecting the right device or you might overwrite your harddrive. ;)

 

 

Download

You can download the beta on one of these mirrors:

ftp://ftp.nluug.nl/pub/os/Linux/distr/man...l/mcnlive/Kris/

ftp://ftp.surfnet.nl/pub/os/Linux/distr/m...l/mcnlive/Kris/

 

If you like torrents, you can check out our page on OssT:

http://www.osst.co.uk/Download/?id=32

Edited by highking

Share this post


Link to post
Share on other sites

Update 03-18-2010:

The second beta has hit the mirrors!

 

Most important changes since the first beta:

- Mounting local partitions when using copy2ram has been fixed.

- The remaster script now checks if there is a partition for the temp files before going on.

- The vesa bootoption now places a default xorg.conf when none was written by drakx11.

- Antialias settings have been fixed.

- Allowed root login through KDM.

Share this post


Link to post
Share on other sites

And here it is! The third beta!

Kinda hoped to be releasing the first RC now, but since some big troubles were found in the second beta I thought it would be a good idea to do one quick beta before.

 

Download

Beta 3 can be directly downloaded from the mcnlive.info site at this point. The mirrors don't have it yet.

 

http://www.mcnlive.info/downloads/mcnlive-kris-beta3.iso

MD5: 073b4739443fb07389428b23364c2e18

 

Most significant changes since beta 2:

The new bootoption "nomount" is introduced to prevent the system to mount your local partition on boot. This option is in the menu as well to make your life a bit easyer. ;)

 

Some more control over the halt script. The remaster script does not touch it anymore. The hmconfig script now checks if it is running "live" and removes the live halt if not. The init script now checks if the halt script is there already and doesn't replace it if our script is already there.

 

Fonts in KDE should look a lot better. :)

Share this post


Link to post
Share on other sites

I am really enjoying the MCN-live kris, I have done a remaster and it works great on all my tested computers, emachine t6420, Acer Aspire One netbook

however i am having a issue with putting the .iso on my usb sticks

 

I have used the suggested dd method and it works however not on my netbook, I have other hybrid isos that it will not boot too and so far i have isolated

it down to the very first attempt at putting the .iso on the stick, I have only been successfull using mobilin image-writer but on a brand new usb stick and when used the stick is not mounted but then the writer puts it on the stick and it works on every machine including the Acer.

 

Now I have used the dd method and it only works on my emachine and my lenovo, I just dont know what the difference is when the unmounted stick is used to put the .iso and when i use either methods. Any ideas ? since i know what works i will continue with that but it would be nice to know why these other methods are failing on the netbook.

I dont believe its a mcnlive kris remaster issue, its something to do with the format of the stick itself and the bios of the Acer not being compatible.

 

keep up the great work HighKing, I really am enjoying this project....i have the beta 3 too by the way ;)

Share this post


Link to post
Share on other sites

Hi.. this is a strange issue, but I do not believe it has anything to do with "Kris" at all, but more on the stick (or the machine) as you suggest yourself. Have you tried Mandriva-Seed to dump the image on a stick?

Share this post


Link to post
Share on other sites

No i havent, i wonder if you have to format before trying the seed, its one of the few programs i have not tried, good suggestion.

I have just figured its something with the process of mounting or not but am at a loss why the strange part is that i can boot

the stick on another machine, that suggests that the image is on it ok, just something with the files system, I saw a comment from

fdisk which said that i was using more than 1024 cylinders and that it causes a problem with some bios's , perhaps thats it and maybe what happens if you do the process on a mounted stick, I just dont know. but i will try the seed and see.

Share this post


Link to post
Share on other sites

i downloaded the "seed" from here: ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/MandrivaLinux/official/iso/2010.0/mandriva-seed.sh

in a terminal as root: sh mandriva-seed.sh mcnlive-kris-beta3.iso /dev/sdb

 

The menu popped up and I selected the above iso, it showed that /dev/sdb was the device to be written, it completed successfully.

I tried it on my Acer Aspire One D150 with booting from a powered down state, selecting F12 the screen just froze, it was unable

to go forward with that stick in place.

I removed the stick and tried it in my Emachine t6420, selected USB with F10 and it booted the mcnlive-kris-beta3.iso fine.

 

from fdisk -l:

Disk /dev/sdb: 2003 MB, 2003795968 bytes

64 heads, 32 sectors/track, 1910 cylinders

Units = cylinders of 2048 * 512 = 1048576 bytes

Disk identifier: 0xfa9acd3d

 

Device Boot Start End Blocks Id System

/dev/sdb1 * 1 381 390143+ 17 Hidden HPFS/NTFS

-------------------------------------------------------------------------------------------------------------------------------

 

fdisk -l on a stick with beta2 but created by makeing sure it was not mounted. created using image-writer a usb stick creator and a brand new 2gb stick never having been used before. (when i get another new stick i will use seed in a similar fashion for comparison.)

 

Disk /dev/sdb: 2000 MB, 2000682496 bytes

64 heads, 32 sectors/track, 1907 cylinders

Units = cylinders of 2048 * 512 = 1048576 bytes

Disk identifier: 0x6567d1a8

 

Device Boot Start End Blocks Id System

/dev/sdb1 * 1 377 386047+ 17 Hidden HPFS/NTFS

 

 

They both appear to be very similar when it comes to start and end tracks..sigh, very strange they perform differently on that netbook. I have a 2nd netbook with windows only on it, i will try the sticks on it to see what happens but i think they have the

same bios. again, I do not think this is related to mcnlive. thanks.

Share this post


Link to post
Share on other sites

Well on the netbook it just hangs and wont leave the bios boot screen until i remove the stick, but on the other desktops it boots

right up to the mcn live grub screen where i can make selections as necessary, seems so silly it doesnt work on the netbook but next time i get a brand new stick (which happens at least once a month) i will try the trick of unmounted and the seed script, that script is very well written and looks really robust when compared to others attempts.

Share this post


Link to post
Share on other sites

Since this issue is so weird i am updating this thread. I have a Attache 1gb stick which i use regularly for different distros to test them but now am focused on this netbook not being able to boot. I dont know if its significant or not but here is a fdisk -l

of the stick after using mandriva seed and putting the latest mandriva 2010 beta on it. The stick booted on the netbook, simply

amazing. I used fdisk /dev/sdb and deleted the old and then created a new partition but this is the result...

 

Disk /dev/sdb: 1007 MB, 1007681536 bytes

64 heads, 32 sectors/track, 961 cylinders

Units = cylinders of 2048 * 512 = 1048576 bytes

Disk identifier: 0x2f83c158

 

Device Boot Start End Blocks Id System

/dev/sdb1 676 676 1024 c W95 FAT32 (LBA)

Partition 1 has different physical/logical endings:

phys=(163, 63, 32) logical=(675, 63, 32)

/dev/sdb2 * 1 675 691199+ 17 Hidden HPFS/NTFS

 

I tried Mcn-live beta 3 on this same stick and it works on the netbook too.....seems that using

usb sticks on netbooks can be very picky.

Share this post


Link to post
Share on other sites

wirechief,

 

Can you try a bios update or set the bios to boot directly from the usb-stick so you don't need F12.

I have a acer110 which is not to different from a 150 and everything works great.If you can boot from other computers and not from the acer150 i think it's a bios problem.

Share this post


Link to post
Share on other sites

I agree with your assessment. Its likely a bios issue however I have never flashed one and can really live with this knowing

a work around exists. I have mcn live kris installed on it but the curiousness of this behavior led me to posting here. I thought

perhaps its the cylinder boundary of 1024 that is known to cause issues and perhaps it is, the 1gb stick booted fine the others were 2gb and 4gb, I plan on getting new ones and testing my theory with using the seed script on them.

The bios is set with a boot order of USB HD , USB flash, then Hard drive.

Share this post


Link to post
Share on other sites

I'm afraid we cannot solve this one for you. If it would at least start to boot, we could see where it hangs and try to solve that, but this can only be a bios issue in my opinion. Bummer. :(

Share this post


Link to post
Share on other sites

yes it is a bummer, thank you for reviewing this. I agree it does appear to be a bios issue with Acers Aspire One, at least with the ones i have.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...