Jump to content

Lost cdrom under MDV 2009.1 [solved]

Guest gordon

Recommended Posts

My cdrom drive was always viewable under Dolphin until recently. Now clicking on the cdrom icon gives an empty folder (but it still works fine under Windws). I have cdrom and cdrom1 under /media.


I went to the MCC and verified the settings of the two local disks (DVD player and CD burner)... it asked me if I wanted to write the changes to fstab, which I did. That did nothing for my problem. I then read that you no longer need an fstab entry for your removable media so I commented the entries out, but here's the problem...


The MCC shows:

Mount point: /media/cdrom

Device: sr0

Name: HL-DT-ST CD-RW GCE-8487B

Type: auto

Options: umask=0,users,iocharset=utf8,noauto,ro,exec


Mount point: /media/cdrom1

Device: sr1


Type: auto

Options: umask=0,users,iocharset=utf8,noauto,ro,exec


But the actual links generated are reversed for the cdroms:

lrwxrwxrwx 1 root root 3 2010-02-12 14:08 cdrom -> sr1

lrwxrwxrwx 1 root root 3 2010-02-12 14:08 cdrom1 -> sr0

lrwxrwxrwx 1 root root 3 2010-02-12 14:08 cdrw -> sr1

lrwxrwxrwx 1 root root 3 2010-02-12 14:08 cdrw1 -> sr0


but the dvd entry is fine (and works well):

lrwxrwxrwx 1 root root 3 2010-02-12 14:08 dvd -> sr1


I tried reversing the links, but after reboot they have returned to the original incorrect settings.

So if they're not in fstab, where are they set from under MDV 2009.1???

Hopefully this backward setting of the sim links is why Dolphin cannot read the contents of the drive.

Link to comment
Share on other sites

OK - although commenting them out serves the same purpose ... I have done so and rebooted just to be complete. No change in the problem ....


I realize that I was confusing /dev/cdrom and /media/cdrom and apparently "HAL" (or hald - the hal daemon) is the source of the cdrom entries that mysteriously reappear after I delete them, and perhaps the source of the backwards seeming listing of /dev/cdrom and /dev/cdrom1.


k3b can access both drives cleanly, and vlc (but not amarok) can play audio off the cdrom, but I have been stymied on accessing text or jpeg files from the cdrom since Dolphin does not seem to be able to read files from the drive.


Maybe this is a kde4 issue? Should Dolphin be able to list the cdrom files or am I trying to use the wrong tool for the job?

Link to comment
Share on other sites

k3b seems to access the drive information directly, and can rip an audio file but does not show the image/text files off a data-CD

under its directory tree, /media/cdrom and /media/cdrom1 are empty.


I tried:

[root@localhost gordon]# mount /dev/sr0

mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

[root@localhost gordon]# umount /dev/sr0

umount: /dev/sr0: not mounted


But, when I play the music cd on vlc I have to select /dev/sr0 to find the cdda files so it appears to be mounted even with an audio CD in the drive!

Link to comment
Share on other sites

Audio CD's don't mount.


If mounting from the command line, you cannot just supply the device or even mount point because it hasn't any reference place (such as fstab) to check for completeness - that's why it didn't work. If it's not in fstab, you would have to do this:


mount /dev/sr0 /media/cdrom


for example. If it is listed in fstab, then you can do things like this:


mount /dev/sr0
mount /media/cdrom


both would effectively mount to the place noted in fstab, so, if you had in fstab /dev/sr0 pointing to /media/cdrom, then both those commands would mount accordingly without explicitly mounting it in the first example I put here where you have to supply the device and mount point.

Link to comment
Share on other sites

Mea culpa!


It is already fixed (probably by cleaning up fstab, but I noow realize the disk I was given with picture files that wouldn't read was a DVD!

It was never going to read in the cd drive ....


Now for a different forum because it is a Windws UDF and won't show up on my machine.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...