Jump to content

Firefly Media Server [solved]


Recommended Posts

I installed the application from MCC and it appeard to install fine and I am able to start it. Everything actually looks pretty good except the main thing... I can't seem to see it from anything :)


I am able to access the web page from anywhere on the network in the house.

I have tried to see the server with Amarok running on the same machine, iTunes on windows boxes in the house and Winamp with DAAP plugin on windows boxes, nothing wants to see it.


the avahi-daemon appears to be running and on boot it looks like everything registers (well, nothing fails, but I don't now what I should see)


Log file from a start as root:

2009-12-29 13:45:11 (b739c6c0): Firefly Version svn-1696: Starting with debuglevel 5
2009-12-29 13:45:11 (b739c6c0): Loaded plugin /usr/lib/mt-daapd/plugins/rsp.so (rsp/svn-1696)
2009-12-29 13:45:11 (b739c6c0): Loaded plugin /usr/lib/mt-daapd/plugins/ssc-script.so (ssc-script/svn-1696)
2009-12-29 13:45:11 (b739c6c0): Loaded plugin /usr/lib/mt-daapd/plugins/out-daap.so (daap/svn-1696)
2009-12-29 13:45:11 (b739c6c0): Plugin loaded: daap/svn-1696
2009-12-29 13:45:11 (b739c6c0): Plugin loaded: ssc-script/svn-1696
2009-12-29 13:45:11 (b739c6c0): Plugin loaded: rsp/svn-1696
2009-12-29 13:45:11 (b739c6c0): Starting signal handler
2009-12-29 13:45:11 (b739c6c0): Initializing database
2009-12-29 13:45:14 (b739c6c0): Starting web server from /usr/share/mt-daapd/admin-root on port 3689
2009-12-29 13:45:14 (b739c6c0): Listening on port 3689
2009-12-29 13:45:14 (b739c6c0): Starting server thread
2009-12-29 13:45:14 (b739c6c0): Serving 6008 songs.  Startup complete in 3 seconds
2009-12-29 13:45:14 (b739c6c0): Rescanning database
2009-12-29 13:45:14 (b6348b70): Cannot resolve /usr/share/mt-daapd/admin-root//upnp-basic.xml
2009-12-29 13:45:14 (b6348b70): Thread 0: Entering ws_returnerror (404: Not found)
2009-12-29 13:45:14 (b6348b70): Cannot resolve /usr/share/mt-daapd/admin-root//upnp-basic.xml
2009-12-29 13:45:14 (b6348b70): Thread 1: Entering ws_returnerror (404: Not found)


I am not sure what the error is from, but the file is definitely not at that location.. I don't see it in the package if I were to build from scratch either.

Any help or what I should look for would be greatly appreciated!

Link to comment
Share on other sites

Ok, I think I have figured out the MAIN part and can now see the server and play music from it!!


Lots more reading, lots more digging and finally found what I was looking for when I read the urpmi distribution note for the 30th time... avahi..


Looks like all I had to do was create a service file to let it know to broadcast. Does an admin want to mark this as solved? One comment line about configuring avahi in the distribution would be of great help, or the distribution having the service file..



<?xml version="1.0" standalone='no'?>
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">


 <name replace-wildcards="yes">%h</name>



Link to comment
Share on other sites

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...