Jump to content
Sign in to follow this  
Yankee

Upgrading to KDE 4.3.2

Recommended Posts

I was running 2009.1 with KDE 4.2.4

 

Well I did it. It took me awhile to figure out what I should do, and even longer to hit the GO button....but it worked. Kopete quit, but I got it fixed. It is much faster!!! Lots of changes.

 

STEP 1:

 

NOTE: Copy the text below to a text editor or even the address bar. Remove the $ from them(ftp$). I did that so the board would not see it as a URL and shorten it.

 

I added media sources (copy these to a console, I did this all in KDE as root). These are one line each. Copy the first 3 lines all at once and then the second 3 lines all at once. Just remove the $

 

urpmi.addmedia KDE4.3.2NOARCH ftp$://ftp.pbone.net/mirror/ftp.kde.org/pub/kde/stable/4.3.2/Mandriva/2009.1/noarch/media/kde43/ with media_info/hdlist.cz

 

urpmi.addmedia KDE4.3.2MAIN ftp$://ftp.pbone.net/mirror/ftp.kde.org/pub/kde/stable/4.3.2/Mandriva/2009.1/i586/media/kde43/ with media_info/hdlist.cz

 

STEP 2:

 

In a console type: drakrpm-edit-media --expert

 

This is to allow ticking update in the media manager for the two new sources so it will know to check for updates in them. Go to media manager and check Update for the two new sources.

 

Go to update and it should list the KDE 4.3.2 updates for your system and what you have installed.

 

STEP 3:

 

Hit update!

 

This was a pain because it said the packages had no key and kept asking do you want to install anyway. Hit yes. You have to baby sit it. I didn't know how to fix this so I hung in there till done.

******************************

How to fix Kopete:

 

I had very little trouble. To fix kopete find (google) these:

 

pidgin-plugins-2.6.2-4mdv2010.0.i586.rpm

 

libortp8-0.15.0-1mdv2009.1.i586.rpm

 

I installed them one at a time after the upgrade and a full reboot, in the order they are listed.

When you install the second one it will get a couple more dependencies (insert your DVD) but Kopete worked after that.

******************************

 

 

I'm no expert but I did upgrade KDE years ago, to 3.1 from 2.x I believe. I got help here to do that so I thought I'd post this to help some of you out. I hope it works. I have no serious problems that I know of. It boots and Kopete was the only thing that broke that I can find.

 

GOOD LUCK! You'll love the speed, especially if your on an older machine like mine (Athlon 1800+).

It really makes a difference!

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

 

This was a pain because it said the packages had no key and kept asking do you want to install anyway. Hit yes. You have to baby sit it. I didn't know how to fix this so I hung in there till done.

******************************

 

 

 

Had this same issue when updating the laptop.

But someone attended me using the following command±

 

urpmi --auto-update --no-verify-rpm

 

And that the trick when updating my desktop later on. All went smooth.

 

Share this post


Link to post
Share on other sites

Congratulations! I want to update to KDE4.3.2 as well. I have an important report that I am in the final stages of, and I can't afford to have my system down if I bork it. It shouldn't happen, but you never know :)

 

So an update will happen over the next few weeks I hope.

 

I have KDE4.3.1 currently, I used the mirror below, and never had any key signature issues:

(Note, this is only the i586 media source)

 

http://gd.tuwien.ac.at/kde/stable/4.3.1/Mandriva/2009.0/i586/media/kde43

 

I will be impressed if the speed is improved again.

Share this post


Link to post
Share on other sites

I have found a bug. I'm looking around. I can live with it I guess. I just copied and pasted the bug report:

 

Every time that I reboot or shutdown/power-on my machine, compositing is disabled. After each reboot, I must manually go into System Settings > Desktop and select "Resume Compositing" or hit Shift + Alt + F12.

 

Reported here on Kubuntu:

2009-09-19

OS: Kubuntu 9.04 (64-bit)

Kernel: 2.6.28-15-generic

KDE: 4.3.1

 

https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/424866

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...