Jump to content
Sign in to follow this  
mittfh

Closing Sound Preferences also closes RhythmBox

Recommended Posts

One more reason to hate Pulse-bl**dy-Audio and its tight integration into GNOME 2.26 (as shipped with Mandriva 2009.1)...

 

1) Load RhythmBox

2) Right-click on the volume icon on the taskbar and enter Sound Preferences

3) Close Sound Preferences

4) RhythmBox also closes.

 

Is this likely to be some configuration thing, or can anyone else reproduce it?

 

-oOo-

 

Meanwhile, although I can still get into GNOME-Alsamixer (to tweak the actual mixer channels on my SB Live), I can't save the settings. I'm sure I could in previous versions, but since the 2009.1 upgrade it throws a mini panic attack because the channel names contain a comma. I've seen a 'patch' on the net, but I assume this only works if it's compiled into GNOME-Alsamixer or GConf or something... could someone enlighten me?

Share this post


Link to post
Share on other sites

Likely a segfault/bug.

Actually while not a GNOME fun, I do like Rhythmbox, despite its heavy GNOME dependencies. I think I like Listen 0.6.X better, but it's really a matter of taste.

Can you repeat the instance, but running rhythmbox like

strace -o debug.log rhythmbox

After the crash, you will find a file named "debug.log" at your user's root folder (it can be quite large) which you can submit either here, or at the Mandriva bugtracker.

Share this post


Link to post
Share on other sites

Righteo, I've zipped the stack trace (6.9MB --> 242KB) and reproduced the console output below:

 

[ben@LinuxBox ~]$ strace -o debug.log rhythmbox
The program 'rhythmbox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
 (Details: serial 21574 error_code 3 request_code 20 minor_code 0)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

 

OK then, let's try the sync parameter...

 

[ben@LinuxBox ~]$ strace -o debug2.log rhythmbox --sync
The program 'rhythmbox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
 (Details: serial 54021 error_code 3 request_code 20 minor_code 0)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

 

Takes far longer to update the screen, and produces a much larger debug logfile...

debug.log.zip

debug2.log.zip

Share this post


Link to post
Share on other sites

Ummm, not sure this is the reason, but I can see in the log several lines complaining about lack of space in your home directory.

Can you give us a "df" output?

Share this post


Link to post
Share on other sites

Ummm, not sure this is the reason, but I can see in the log several lines complaining about lack of space in your home directory.

Can you give us a "df" output?

 

[ben@LinuxBox ~]$ df
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1              16G   14G  1.5G  91% /
/dev/sda6             210G  170G   40G  82% /home

 

40GB free in /home, so that should be OK...but hang on, 170GB used?!

Is there a Linux version of something like Treesize Pro, a graphical tool to visualise which files / folders are responsible for that usage?

Time to archive some rarely used stuff onto a portable HDD, methinks!

Edited by mittfh

Share this post


Link to post
Share on other sites

There is a graphical one, aussiejohn has mentioned it before on here, but I can't remember it.

 

I tend to do:

 

cd /home/username
du -sh `ls`

 

and you can get a good representation from this. Then move down a directory when you find a large one and go from there. Not ideal, but if I remember that tools name I'll post it here.

 

EDIT:

 

I remember it now, you can install filelight - it'll pull in a load of KDE dependencies though if you use Gnome.

Share this post


Link to post
Share on other sites

Thanks Ian for the reference.

 

The application is Filelight and it is available in Mandriva repository.

An excellent and valuable tool. (with GUI interface.)

 

Cheers. John.

 

Sorry I didn't notice your edit hence the duplication. :-)

Edited by AussieJohn

Share this post


Link to post
Share on other sites

Thanks Ian for the reference.

 

The application is Filelight and it is available in Mandriva repository.

An excellent and valuable tool. (with GUI interface.)

 

 

Being a GNOME user, I checked out the Wikipedia article for Filelight...

 

...and discovered baobab - which is already installed, courtesy of gnome-utils (but puzzlingly doesn't have a menu entry by default...)

 

And I've discovered the largest hog in userspace - a backup of my portable HDD (must have created that by accident - probably intended to synchronise one folder...)

 

Now to see if there's stuff hiding outside /home that shouldn't be there...

Share this post


Link to post
Share on other sites

Anyway, all these are hardly relevant to the issue with Rhythmbox.

Please check if everything in your ~/.gconf directory is writable, and is owned by the user. If not, then

 

# chown -R ben:ben /home/ben/.gconf

Edited by scarecrow

Share this post


Link to post
Share on other sites

Anyway, all these are hardly relevant to the issue with Rhythmbox.

Please check if everything in your ~/.gconf directory is writable, and is owned by the user. If not, then

 

# chown -R ben:ben /home/ben/.gconf

 

Everything's 600 or 700 (i.e. owner read/write/(execute), no access to group/world)...

 

Meanwhile, although the gnome panel sound icon is working normally at present...

 

Over the weekend, I encountered another temporary problem: the volume control slider moved up and down, but always reset to mute (and the speaker icon showed mute). However the link to Sound Preferences did work, so I could alter the volume that way.

 

This morning, the volume control stayed where it was put, but had no impact upon sound because Pulse decided it couldn't see my soundcard and wanted to output to the null device (or as PulseAudio Manager puts it, auto_null). Yet if I opened up a terminal and run speaker-test (which uses ALSA directly and bypasses Pulse) I got sound loud and clear.

 

If only Pulse wasn't bound up so tightly to Gnome 2.26, I'd uninstall it and revert to ALSA without hesitation. Unfortunately, trying to uninstall Pulse completely will also uninstall the majority of gnome...and even a partial uninstallation will result in the panel icon becoming useless (as it relies on Pulse).

Edited by mittfh

Share this post


Link to post
Share on other sites

No need to uninstall PulseAudio: just disable the pulseaudio daemon from running.

This will also disable the GNOME system sounds. To resolve this, install esd (unless installing esd asks about removing pulseaudio first).

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...