Jump to content

mittfh

Members
  • Content Count

    56
  • Joined

  • Last visited

Everything posted by mittfh

  1. Now solved - albeit by one of the most radical methods possible. urpme -a gnome urpme --auto-orphans Reboot urpmi gnome-task-minimal Reboot - notice MCC, Compiz and Emerald are missing... urpmi drakconf urpmi compiz -oOo- Since I was forced to do the 2010 upgrade in two stages (ran out of room on the root partition, then had to shut down to get to work on time - so when I restarted I shifted /var into the /home partition and symlinked it back before resuming), I suspect something may have got corrupted in the upgrade. So by nuking Gnome and reinstalling it... :)
  2. Hmm...that key didn't exist (! Now created) - and neither does apps / nautilus / desktop [Later on...] Nope. I even removed previous kernels and all the orphans depending on them, just to be on the safe side. In whatever manages to load in gnome, there are no icons, no panels, no right-click menu - about the only signs of life are the default Mandriva background and gkrellm. Oh, and it's the same regardless of whether I log on as myself or guest (which obviously doesn't have any custom configs). Xfce works and loads very fast (well, it is the default "light" desktop environment), but it is a bit plain and I prefer gnome (well, a functional gnome, at least!) :) So, for your viewing pleasure, three different outputs of "ps ax" (to give you a clue as to what is running, and if there's anything odd about the gnome version). All three were taken in tty6 while X was doing its thing in tty7. Nodesk - login prompt only. xfce - in xfce. gnome - in gnome (or at least, what loads as gnome) -oOo- Additional unrelated issue (from before the upgrade): Where does Compiz store its preferences? I once accidentally set the opacity on the CCSM window to 0% (oops!)... ps-nodesk.txt ps-xfce.txt ps-gnome.txt
  3. I upgraded from 2009.1 to 2010 today...love the new splash screen and throbber! BUT although the login screen appears OK, trying to log in (either as myself or the auto-generated guest) results in a blank desktop, with only the background image showing (if it's any help, I don't think gnome-panel loaded...or at least, its splash screen didn't appear). On a hunch, I installed xfce, and have got a fully functional desktop that way, but any hints / tips / suggestions to get GNOME functional would be appreciated :)
  4. It has to be one of the simplest effects out there, but I can't work out how to fade in/out video clips in LiVES. There's a nice convenient option to fade in/out audio, but what about video?
  5. Everything's 600 or 700 (i.e. owner read/write/(execute), no access to group/world)... Meanwhile, although the gnome panel sound icon is working normally at present... Over the weekend, I encountered another temporary problem: the volume control slider moved up and down, but always reset to mute (and the speaker icon showed mute). However the link to Sound Preferences did work, so I could alter the volume that way. This morning, the volume control stayed where it was put, but had no impact upon sound because Pulse decided it couldn't see my soundcard and wanted to output to the null device (or as PulseAudio Manager puts it, auto_null). Yet if I opened up a terminal and run speaker-test (which uses ALSA directly and bypasses Pulse) I got sound loud and clear. If only Pulse wasn't bound up so tightly to Gnome 2.26, I'd uninstall it and revert to ALSA without hesitation. Unfortunately, trying to uninstall Pulse completely will also uninstall the majority of gnome...and even a partial uninstallation will result in the panel icon becoming useless (as it relies on Pulse).
  6. Being a GNOME user, I checked out the Wikipedia article for Filelight... ...and discovered baobab - which is already installed, courtesy of gnome-utils (but puzzlingly doesn't have a menu entry by default...) And I've discovered the largest hog in userspace - a backup of my portable HDD (must have created that by accident - probably intended to synchronise one folder...) Now to see if there's stuff hiding outside /home that shouldn't be there...
  7. [ben@LinuxBox ~]$ df Filesystem Size Used Avail Use% Mounted on /dev/sda1 16G 14G 1.5G 91% / /dev/sda6 210G 170G 40G 82% /home 40GB free in /home, so that should be OK...but hang on, 170GB used?! Is there a Linux version of something like Treesize Pro, a graphical tool to visualise which files / folders are responsible for that usage? Time to archive some rarely used stuff onto a portable HDD, methinks!
  8. Righteo, I've zipped the stack trace (6.9MB --> 242KB) and reproduced the console output below: [ben@LinuxBox ~]$ strace -o debug.log rhythmbox The program 'rhythmbox' received an X Window System error. This probably reflects a bug in the program. The error was 'BadWindow (invalid Window parameter)'. (Details: serial 21574 error_code 3 request_code 20 minor_code 0) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.) OK then, let's try the sync parameter... [ben@LinuxBox ~]$ strace -o debug2.log rhythmbox --sync The program 'rhythmbox' received an X Window System error. This probably reflects a bug in the program. The error was 'BadWindow (invalid Window parameter)'. (Details: serial 54021 error_code 3 request_code 20 minor_code 0) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.) Takes far longer to update the screen, and produces a much larger debug logfile... debug.log.zip debug2.log.zip
  9. One more reason to hate Pulse-bl**dy-Audio and its tight integration into GNOME 2.26 (as shipped with Mandriva 2009.1)... 1) Load RhythmBox 2) Right-click on the volume icon on the taskbar and enter Sound Preferences 3) Close Sound Preferences 4) RhythmBox also closes. Is this likely to be some configuration thing, or can anyone else reproduce it? -oOo- Meanwhile, although I can still get into GNOME-Alsamixer (to tweak the actual mixer channels on my SB Live), I can't save the settings. I'm sure I could in previous versions, but since the 2009.1 upgrade it throws a mini panic attack because the channel names contain a comma. I've seen a 'patch' on the net, but I assume this only works if it's compiled into GNOME-Alsamixer or GConf or something... could someone enlighten me?
  10. This hopefully shouldn't take too long to clear up :) I've got a Logitech QuickCam Pro 3500 attached to my box, pointing out of the nearest window. I'd ideally like to persuade it to capture a still image every X seconds, and save to a sequentially numbered file, so that after 24hrs or when I get bored, I can use ImageMagick to turn them into a time lapse video. I currently have Cheese and xawtv installed (which can both 'see' the camera, unlike Camorama and camstream, which can't), if that's any help... Oh, and the camera will need to be 'turned on' 5-10 seconds before the snapshot is taken (or remain permanently on but not logging) as it takes several seconds to 'warm up'... (Doing the 'traditional' webcam thing I'll worry about later - as I'm on Be*'s 'value' broadband package [dynamic, but rarely changing IP address - only changed once in the 18 months I've been signed up!] I've got to ask in their forums if I can access my PC remotely and if so, if I can do so via http)
  11. I'm using the default IaOra screensaver (xscreensaver's GDadou - calling chbg), and like the 'reflection' effect on the 8 landscapes it uses. However, the reflection effect is 'built in' to the images rather than being done dynamically by the screensaver, so to maintain consistency, plopping any old images into /usr/share/mdk/screensaver won't look as good. So, I'd like to know either a) if there are additional images pre-created I can add with this effect built-in, or B) if I grabbed some 1200x400ish landscape pictures, would it be possible to do something similar using graphics tools (ImageMagick springs to mind, as I could save the relevant command sequence to file, then run the script for each image I wanted to process, rather than doing it manually in a more conventional package like GIMP)? Essentially, the process would be: Copy image, flip copy, apply fade effect to copy, increase vertical aspect of canvas, paste below original image, save. OK, if I had hours upon end of spare time, I could probably figure out the relevant IM options myself, but I'd rather not go through all that trial-and-error if someone here knows the package inside-out - or knows of the location of a library of suitable images :)
  12. About twice a week when using Firefox, a Gnome prompt appears informing me I need to install the "Central Khmer" font to display the document properly. Apart from this being an odd request, since the pages I view are written in English using either ISO-8859-1 or UTF-8 encoding (and I don't generally make a habit of viewing pages written in non-Latin scripts, especially Cambodian!), it won't find / install the font anyway. Clicking Search informs me it can't install the font, and More Details claims that "WhatProvides not yet supported by backend". Since I'm always using FF when the prompt appears, I think it's reasonable to assume that Firefox is triggering the message. However, looking carefully at the dialog when it popped up twice today, the first time it claimed gnome-panel wanted to install the font, the second time emerald (window manager). I'm happy to continue ignoring the requests, but thought I'd post something here in case anyone else has experienced this or knows a fix / workaround...
  13. So if I grabbed hold of a Gnome graphical sudo interface thingy, could I use that to launch to log file viewer with root permissions? My machine is single (human) user, but it's nice to have a modicum of security - both for prevent me accidentally trashing the system and for the unlikely event of me having visitors around long enough to allow them to play around with my computer, in which case I'd set them up with a (heavily restricted) account.
  14. I have gnome-audio (the bulk of the files) and gnome-audio-extra (aka card_shuffle.wav and phone.wav - yes, an entire package for 2 wav files!) installed. I have various sound themes stored in /usr/share/sounds, but none are picked up other than default (Freedesktop) and ia_ora (which just contains login, logout, dialog-warning and dialog-error - plus a whole bunch of 0 byte "disabled" files). It appears to be using the Freedesktop set, minus the logout/shutdown wav (it exists and works if I play it from Nautilus, but it doesn't appear to be attached to the logout/shutdown event) A possible clue to adding extra themes is in /usr/share/doc/gnome-audio/README: But the more I read that, the more mystified I become. The second sentence suggests I can create a "Sounds" folder in /usr/share/doc/gnome-audio/ then drag'n'drop files into that - then some automated process copies them over into /usr/share/sounds. OK, that sounds simple enough. But what about that mysterious third sentence?
  15. Silly question, but is it possible to customise system sounds in 2009.1 / Gnome any more? According to Sound Preferences, I can choose a theme (well, Default or Ia Ora) and the alert sound (from a predefined list), but absolutely nothing else. The new wav it uses for the startup (well, login) sound doesn't appear to reside in /usr/share/sounds with all the rest either (otherwise I would have experimented with a spot of renaming...) I can understand a desire to hide this from novice users, but at least they could have coded in an "Advanced" button for those of us that want to customise and tweak...
  16. Here's a nice quick query: Is it possible to get security.log to display in the log file viewer? It appears to be readable only by root, so unsurprisingly log viewer (running with 'ordinary' user permissions) won't touch it. I could open a terminal, then open it via sudo, but it would be nice to have a more user friendly way of taking a peek after the daily MSEC check :)
  17. This was tweeted about a quarter of an hour ago by @Mandriva (http://www.twitter.com/mandriva) - it might be worth a mention somewhere :) RT @ofaurax If you have a sound bug with #mandriva, participate to sound BugWeek ! http://my.opera.com/pacho/blog/show.dml/3290753 [moved from Weblinks by spinynorman]
  18. After noticing several duplicate files in my music collection (the result of saving to backup, reorganising, saving to backup again, then restoring...), I thought I'd download and install fslint to find the rest of 'em... [ -f /etc/mandrake-release ] && pkg=rpm svn checkout [url="http://fslint.googlecode.com/svn/trunk/"]http://fslint.googlecode.com/svn/trunk/[/url] fslint-2.29 tar czf fslint-2.29.tar.gz --exclude=.svn fslint-2.29 So far, so good... However, the next command in sequence... sudo rpmbuild -ta fslint-2.29.tar.gz ...returns with... RPM build errors: File not found by glob: /root/rpmbuild/BUILDROOT/fslint-2.29-2.mdv.i386/usr/share/fslint/fslint/supprt/rmlint/fixdup.py[oc] What's going wrong? (And yes, I have successfully added myself to sudoers - although I wondered shy it didn't appear to work at first... ...until I RTFM and discovered it's asking for my password, not roots!) [moved from Software by spinynorman]
  19. Samsung SGH-J700 (mobile phone) <--> Belkin F8T017 (USB bluetooth adaptor) <--> Mandriva 2009.1 (desktop computer) This is an odd one... The computer does not appear in "My Devices" on the phone, however if I "Search New Devices", I can see the computer and allegedly pair with it. It still won't appear in "My Devices" though... I can also see the mobile from the computer and pair with it that way. So that's an improvement on 2009.0, which refused to have anything to do with the adaptor... However... If I try to send files from the phone to the computer, the phone informs me "Cannot connect". If I try to browse files on the phone from the computer, I can view and navigate the folder hierarchy, but I cannot see any files... I could hunt around for my microSD card adaptor and transfer the files that way, or take the bluetooth adaptor into work and transfer via bluetooth and a USB stick, but that's not the point! Besides which, both workarounds are a lot more fiddly than if I could get Bluetooth working!
  20. Just a quick update - I have reported it as a bug, and it has been examined. Here's the latest update: https://qa.mandriva.com/show_bug.cgi?id=50735 --- Comment #1 from Frederic Crozat <fcrozat@mandriva.com> 2009-05-14 16:14:43 CEST --- bug in gnome-settings-daemon (gconf key is correctly changed by configuration UI) or Xorg, not sure yet.
  21. A couple of times over the past few days, I've had a notification pop up saying a new version of Mandriva is available - 2009.0 (Stable). Which is curious, because (a.) I'm running 2009.1, (b.) the red (!) hadn't appeared in the systray, and (c.) Mandriva doesn't use the (Stable) moniker. In an attempt to discover what was going on, I clicked the "More Info" link. This brought up a modal dialog (System monitor helpfully revealed it was a Zenity dialog, but no indication of what had spawned it), with the title "System", the text "Your" and an OK button. Click that and the whole thing disappears. I can't see anything unusual in the system logs (is there a way to just view them, rather than running a 'blank' search in MCC?), so... If it happens again, what investigations should I do to determine what's producing this (fake / false alarm) message?
  22. Took 'em long enough... :)
  23. OK, but why would it also ignore mouse orientation in "Mouse Preferences" (System --> Preferences --> Mouse)? It respects double click speed and the Ctrl key 'sonar', just not the button orientation...
  24. Righteo, I just have one teething problem with 2009.1 left... Being a left hander, I have my mouse sitting on the left side of my keyboard, and configured to use left hand button layout (i.e. Secondary / Wheel / Primary). However, since installing 2009.1, it has adopted the right hand button layout (i.e. Primary / Wheel / Secondary), regardless of whether the orientation in Mouse Properties is set to left handes or right handed. I've even attempted remapping the buttons in xorg.conf - again, this has no effect at all (and I've since commented out the line). The mischievous rodent concerned is a Logitech USB optical mouse (M/N: M-BJ58) using the default "Any USB or PS/2 mouse" driver.
  25. Edited the config as mentioned in the errata, and now sound works. The SB Live is an unusual card in that it has two mixers - Sigmatel for all outputs and digital inputs, plus AC97 for analogue inputs. Under 2009.0 and earlier, configuring the card to record from Line In or "Stereo Mix" required different mixer setups. However, under 2009.1 / ALSA / Pulse, things are a lot easier. On my setup at least, just set both input and output to ADC Capture / Standard PCM Playback, and it will cope with both. Still trying to figure out how to record from Line In without recording whatever is playing on the system (so I can record an audio cassette via Line In but simultaneously play YouTube videos / digital audio etc. without recording their outputs!)
×
×
  • Create New...