Jump to content
epretorious

Realtek ALC662 @ Intel 82801GB ICH7 [solved]

Recommended Posts

I am completely stumped - My Shuttle K45 won't play sound and I don't know anything about sound cards! :huh:

 

[root@localhost ~]# lspci | grep -i audio
   00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

   [root@localhost ~]# cat /proc/asound/cards
    0 [intel          ]: HDA-Intel - HDA Intel
                         HDA Intel at 0xfdff8000 irq 16

   [root@localhost ~]# lsmod | grep snd
    snd_seq_dummy           3492  0 
    snd_seq_oss            29888  0 
    snd_seq_midi_event      6912  1 snd_seq_oss
    snd_seq                46800  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device          7276  3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss            37216  0 
    snd_mixer_oss          14784  2 snd_pcm_oss
    snd_hda_intel         284764  1 
    snd_pcm                69636  2 snd_pcm_oss,snd_hda_intel
    snd_timer              19652  2 snd_seq,snd_pcm
    snd_page_alloc          8456  2 snd_hda_intel,snd_pcm
    snd_hwdep               7492  1 snd_hda_intel
    snd                    45092  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
    soundcore               6624  2 snd

   [root@localhost ~]# cat /proc/asound/card0/codec#0 
   Codec: Realtek ALC662 rev1
   Address: 0
   Vendor Id: 0x10ec0662
   Subsystem Id: 0x12970000
   Revision Id: 0x100101
   No Modem Function Group found
   Default PCM:
       rates [0x160]: 44100 48000 96000
       bits [0xe]: 16 20 24
       formats [0x1]: PCM
   Default Amp-In caps: N/A
   Default Amp-Out caps: N/A
   Node 0x02 [Audio Output] wcaps 0x1d: Stereo Amp-Out
     Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
     Amp-Out vals:  [0x00 0x00]
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0xe]: 16 20 24
       formats [0x1]: PCM
   Node 0x03 [Audio Output] wcaps 0x1d: Stereo Amp-Out
     Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
     Amp-Out vals:  [0x00 0x00]
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0xe]: 16 20 24
       formats [0x1]: PCM
   Node 0x04 [Audio Output] wcaps 0x1d: Stereo Amp-Out
     Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
     Amp-Out vals:  [0x00 0x00]
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0xe]: 16 20 24
       formats [0x1]: PCM
   Node 0x05 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0x1e]: 16 20 24 32
       formats [0x1]: PCM
   Node 0x07 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x08 [Audio Input] wcaps 0x10011b: Stereo Amp-In
     Amp-In caps: ofs=0x09, nsteps=0x1f, stepsize=0x05, mute=1
     Amp-In vals:  [0x89 0x89]
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0x6]: 16 20
       formats [0x1]: PCM
     Connection: 1
        0x23
   Node 0x09 [Audio Input] wcaps 0x10011b: Stereo Amp-In
     Amp-In caps: ofs=0x09, nsteps=0x1f, stepsize=0x05, mute=1
     Amp-In vals:  [0x1f 0x1f]
     PCM:
       rates [0x160]: 44100 48000 96000
       bits [0x6]: 16 20
       formats [0x1]: PCM
     Connection: 1
        0x22
   Node 0x0a [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
     Amp-In vals:  [0x1f 0x1f] [0x80 0x80] [0x1f 0x1f] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
     Connection: 9
        0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16
   Node 0x0c [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-In vals:  [0x00 0x00] [0x80 0x80]
     Connection: 2
        0x02 0x0b
   Node 0x0d [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-In vals:  [0x00 0x00] [0x80 0x80]
     Connection: 2
        0x03 0x0b
   Node 0x0e [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-In vals:  [0x00 0x00] [0x80 0x80]
     Connection: 2
        0x04 0x0b
   Node 0x0f [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x10 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x12 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x14 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x00 0x00]
     Pincap 0x081003c: IN OUT HP EAPD Detect
     Pin Default 0x01014010: [Jack] Line Out at Ext Rear
       Conn = 1/8, Color = Green
     Pin-ctls: 0x40: OUT
     Connection: 1
        0x0c
   Node 0x15 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x0810034: IN OUT EAPD Detect
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x20: IN
     Connection: 1
        0x0d
   Node 0x16 [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x0834: IN OUT Detect
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x20: IN
     Connection: 1
        0x0e
   Node 0x17 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x18 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
     Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
     Amp-In vals:  [0x00 0x00]
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x081734: IN OUT Detect
     Pin Default 0x01a19c20: [Jack] Mic at Ext Rear
       Conn = 1/8, Color = Pink
     Pin-ctls: 0x24: IN
     Connection: 1
        0x0e
   Node 0x19 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
     Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
     Amp-In vals:  [0x00 0x00] [0x00 0x00]
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x08173c: IN OUT HP Detect
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x20: IN
     Connection: 2
        0x0c* 0x0e
   Node 0x1a [Pin Complex] wcaps 0x40018d: Stereo Amp-Out
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x0834: IN OUT Detect
     Pin Default 0x0181342f: [Jack] Line In at Ext Rear
       Conn = 1/8, Color = Blue
     Pin-ctls: 0x20: IN
     Connection: 1
        0x0d
   Node 0x1b [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
     Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
     Amp-In vals:  [0x00 0x00] [0x00 0x00]
     Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-Out vals:  [0x80 0x80]
     Pincap 0x08173c: IN OUT HP Detect
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x20: IN
     Connection: 2
        0x0c* 0x0e
   Node 0x1c [Pin Complex] wcaps 0x400001: Stereo
     Pincap 0x0820: IN
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x20: IN
   Node 0x1d [Pin Complex] wcaps 0x400000: Mono
     Pincap 0x0820: IN
     Pin Default 0x40020601: [N/A] Line Out at Ext N/A
       Conn = 1/4, Color = Unknown
     Pin-ctls: 0x20: IN
   Node 0x1e [Pin Complex] wcaps 0x400300: Mono Digital
     Pincap 0x0810: OUT
     Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
       Conn = 1/8, Color = Black
     Pin-ctls: 0x40: OUT
     Connection: 1
        0x06
   Node 0x1f [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
   Node 0x21 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x22 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-In vals:  [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
     Connection: 10
        0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x0b
   Node 0x23 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
     Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
     Amp-In vals:  [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
     Connection: 10
        0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x0b
   Node 0x24 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x25 [Vendor Defined Widget] wcaps 0xf00000: Mono
   Node 0x26 [Vendor Defined Widget] wcaps 0xf00000: Mono

Please help! :cry:

Edited by epretorious

Share this post


Link to post
Share on other sites

I have a K45 too and it plays sound fine both with mandriva Linux 2008.1 and 2009.1.

 

What Linux version did you install? Do you have Pulseaudio enabled or disabled?

 

What programs did you try to test sound with?

Share this post


Link to post
Share on other sites

Hmm, 2008... you may have an arts problem. What's the output (as user) of

grep sound-slot /etc/modprobe.conf

and

/usr/bin/artsshell status

If the arts sound server is running, I would suggest that you try disabling it. Then test your sound again with an audio application.

Share this post


Link to post
Share on other sites

The arts server does not appear to be installed:

 

[epretorious@localhost ~]$ which artsshell
  which: no artsshell in (/bin:/usr/bin:/usr/local/bin:/usr/games:/usr/lib/qt3//bin:/usr/lib/qt3//bin:/home/epretorious/bin:/usr/lib/qt3//bin)
  [epretorious@localhost ~]$ rpm -qa | grep arts
  [epretorious@localhost ~]$ 

...but the hda_intel modules are defined in /etc/modprobe.conf:

 

[epretorious@localhost ~]$ grep sound /etc/modprobe.conf 
  alias sound-slot-0 snd_hda_intel

...and the snd_* modules have been loaded:

 

[epretorious@localhost ~]$ sudo lsmod | grep snd
snd_seq_dummy           3492  0 
snd_seq_oss            29888  0 
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                46800  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7276  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37216  0 
snd_mixer_oss          14784  2 snd_pcm_oss
snd_hda_intel         284764  1 
snd_pcm                69636  2 snd_pcm_oss,snd_hda_intel
snd_timer              19652  2 snd_seq,snd_pcm
snd_page_alloc          8456  2 snd_hda_intel,snd_pcm
snd_hwdep               7492  1 snd_hda_intel
snd                    45092  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore               6624  2 snd

Share this post


Link to post
Share on other sites

check with alsamixer (command line) that all volumes are set to maximum and that none are muted.

Share this post


Link to post
Share on other sites

OK, if you're not using the arts sound server, I would suggest that you (as root) run

alsaconf

to set things up. Then (also as root) run

alsactl store

to save your settings. Now try your sound again with an audio app.

Share this post


Link to post
Share on other sites
check with alsamixer (command line) that all volumes are set to maximum and that none are muted.

alsamixer croaks:

 

       [justine@localhost ~]$ alsamixer

       alsamixer: function snd_mixer_load failed: Invalid argument

       [justine@localhost ~]$ which alsamixer
       /usr/bin/alsamixer

       [justine@localhost ~]$ rpm -qf /usr/bin/alsamixer
       alsa-utils-1.0.15-0.rc1.1mdv2008.0

 

OK, if you're not using the arts sound server, I would suggest that you (as root) run
alsaconf

to set things up. Then (also as root) run

alsactl store

to save your settings. Now try your sound again with an audio app.

alsaconf isn't installed:

 

      [justine@localhost ~]$ sudo alsaconf
      sudo: alsaconf: command not found

      [justine@localhost ~]$ rpm -qa | grep alsa
      alsa-utils-1.0.15-0.rc1.1mdv2008.0
      java-1.6.0-sun-alsa-1.6.0.06-2mdv2008.0
      libalsa2-1.0.15-0.rc1.4mdv2008.0
      libalsa-data-1.0.15-0.rc1.4mdv2008.0
      alsa-plugins-1.0.14-7mdv2008.0
      libalsa-oss0-1.0.14-2mdv2008.0

Thoughts? Suggestions? :huh:

Edited by epretorious

Share this post


Link to post
Share on other sites

The alsamixer error message proved to be the clue that enabled me to crack the case (using Google).

 

Specifically, Genotoo Bug #208016 & the post "EeePC in-kernel ALSA difficulties [solved]" in the Gentoo forums described the symptoms and error messages that I was experiencing so I dedicded to try boomslang's suggested solution:

 

echo "options snd-hda-intel model=3stack-dig" >> /etc/modprobe.conf

to append a necessary line.

...and, viola, sound works properly! :D

 

Thanks!

Edited by epretorious

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...