Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
neddie

Hugin won't call enblend

Recommended Posts

The joys of 2009.0 continue...

After upgrade, hugin fails to stitch panoramas together, it goes through all the motions of loading the photos, letting you allocate control points, previewing the panorama and even mapping each photo to the separate tiffs, but then fails at the last step, calling enblend to merge the photos together.

If you look at the command window, what it actually tries to call is something like "false -compression NONE -o output.tif ..." and the other parameters which should get given to enblend. So why does it try to call "false" instead of "enblend"? Yes I have enblend installed, and it's at /usr/bin/enblend, quite easy to find. It seems to be a bug in hugin though, related to the user config (which worked fine for the previous version of hugin). If you call the same command from the console but with "enblend" instead of "false", it works, and you don't have to redo all your point clicking!

 

I found out how to fix it, you have to edit your ~/.hugin file. You could delete this file and let hugin create a new one (apparently you have to go into preferences and click "OK" - don't click "Cancel"! Or another way is just to add a line in the .hugin file, in the [Enblend] section:

Instead of

EnblendExe=enblend

you need to change this to

EnblendExe=enblend
Exe=enblend

(if he doesn't listen first time, you gotta tell him twice! ;) )

 

There are also funny magnifier things obscuring the view on the control point dialog now, getting in the way of what I want to see, but I guess I'll get used to that.

 

Did I already mention I wish I'd stuck with 2008.1? :wall:

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Another hugin user! Are you using 2009.0 or 2009.1? Reason for asking is that I had hugin 0.7.0 working perfectly with 2009.0, but find that the 0.8 beta shipping with 2009.1 fails to call autopano for reasons as yet still unclear to me.

Share this post


Link to post
Share on other sites

I have hugin-0.7.0-0.rc6.1mdv2009.0. But I don't have autopano, so I don't know whether that works or not. I guess if I was clever I'd use autopano but I didn't want all the mono stuff which autopano needs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×