Jump to content

No mime types installed [solved]


Recommended Posts

I'm running Mandriva 2009 on my main system. I got here through upgrades, the original clean install was 2008. For the most part the upgrade path has worked for me. However, my disk partitioning is not ideal, SDA1 is running close to 100% full. I'm going to install 2009.1, and do a clean install.


In an effort to delay the install, ( got many other things going on where I need this machine running ) I removed some files from SDA1 ( dumb move I know :wall: ), i wound up with errors when KDE 3.5.10 loads.


"No mime types installed" and "application/octet stream not installed" are the errors that appear when KDE starts up.


After doing a lot of searching, I know I removed some files for KDE.


What I would like to know, is there a way with urpmi to verify what files are installed, or missing? If I can identify what package the missing files are from, can I re-install ( refresh ) just that package?


I thought of deleting KDE, but I'm afraid I would wind up with a vegetable. With very little SDA1 space, I don't think this would work.


Other systems, most of the applications in Kmenu are missing. Desktop icons do not appear. I can still launch most applications from the command line. Interesting side light, FIrefox works fine, Konqueror will only launch from a konsole, however it is unuseable. I can not load any of the profiles for it.


I'm in the process of backing up my files, I'm doing that through NFS. Samba isn't working for the most part. The daemons are running, printing from a windoze system is not working, it did before I created this bug...


Is it possible to find out and re-install the files I deleted with urpmi?

Link to comment
Share on other sites

Well, I had no success fixing this problem. I decided to download 2009.1, and did a clean install. I re-partitioned the disk so I wouldn't run out of space on the / partition.


2009.1 looks good so far. This is my first experience with KDE 4. Still discovering new things.


Compiz was much easier to get working on 2009.1 than it was on earlier releases. Good stuff.


Nothing like a clean install to fix up your old bugs. I'm considering this a resolved problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...