Jump to content
Guest Iluvatar

Getting KDE to work at init5 as default

Recommended Posts

Guest Iluvatar

(Warning ! All text thatfollows is entered by a LINUX newbie)

 

I own a commercially developed (but now unsupported) Myth TV box which has Mandrake V10.0 installed. It boots directly into the MyTH TV application (as intended).

 

I wish to run some other applications in a new, separate session. When I initiate such a session (via...Ctrl-Alt-F1, logon as root and then issue 'init 5'), the system then requests a Mandrake logon (with which I oblige) and then fires me directly into the default windows manager (IceWM). I wish to change this process.....

 

I would like to run KDE desktop as an alternative to IceWM. I have done some research, and changed the parameter in /etc/sysconfig/desktop to 'DISPLAYMANAGER=KDE'. This seemed to have no effect.

 

I have also tried 'startx KDE', but get the error:

 

Fatal Server Error:

Server is already active for display 0

 

Can someone please guide me to where I should look to get KDE as my default desktop?

 

Thanks.

Aussie_Newbie

Share this post


Link to post
Share on other sites

As the error says you already have a GUI running on display 0, try using display 1.

startx KDE -- :1

Use Ctrl+Alt+F7/F8 to switch between them.

 

Ken

Share this post


Link to post
Share on other sites
I would like to run KDE desktop as an alternative to IceWM. I have done some research, and changed the parameter in /etc/sysconfig/desktop to 'DISPLAYMANAGER=KDE'. This seemed to have no effect.
You're a special kind of “newbie†if you 1/ searched the Internet, 2/ saw the potential in this config file, 3/ knew how to test it :D Well done! Just a small change: DISPLAYMANAGER is for… the display manager, that is: KDM, GDM, XDM, Slim…, that is the place where you login (if you do). The property you're interested in is DESKTOP. However, seeing you're using a specially-configured box, some other settings may interfer, so report back if this change doesn't work.

 

I have also tried 'startx KDE'
As K Bergen said, append “ -- :1†to this line (there is space on both sides of “--â€). Yet I wonder if this will work without giving the full path to the KDE binary, instead of just “KDEâ€â€¦

 

Yves.

Share this post


Link to post
Share on other sites
Guest Iluvatar

Ken.

 

I typed it in as you instructed and got a blank, black screen !!

 

When I left-click the mouse I get a cross on the screen. I didn't expect that ! :huh:

 

What is it doing ? Help !!!

Share this post


Link to post
Share on other sites
Guest Iluvatar

Yves

 

I added a line: "DESKTOP=KDE" to the desktop file, and rebooted through the process, but only got the IceWM WM with a red screen !!!

 

Yikes

Aussie_Newbie

Share this post


Link to post
Share on other sites
Ken.

 

I typed it in as you instructed and got a blank, black screen !!

 

When I left-click the mouse I get a cross on the screen. I didn't expect that ! :huh:

 

What is it doing ? Help !!!

A shot in the dark but "Mandrake 10.0" is old and so probably is the hardware, it just might not be up to running two desktops.

 

You could try killing IceWM

init 3

as root, then

startx KDE

I know that's not your ultimate goal but it may show whether or not your install of KDE actually works.

 

Ken

Share this post


Link to post
Share on other sites
Guest Iluvatar
A shot in the dark but "Mandrake 10.0" is old and so probably is the hardware, it just might not be up to running two desktops.

 

Yes, I know but I don't want to stuff around with it. I will do that later....

 

You could try killing IceWM

 

Sorry about the newbie question, but, how do I kill Ice WM? Does 'init 3' simply not invoke the WM and run at a different level?

 

init 3

as root, then

startx KDE

 

I'll try this approach and see how I get on.

 

Thanks Ken.

Share this post


Link to post
Share on other sites

Mandrake is more than able to run several graphical displays. I did that with a much older Mandrake (and DSL too for that matter) on my “nomade†laptop.

 

You could try setting the full path to kde in the DESKTOP value, although, once again, some other things may interfer anyway.

 

First of all, you have to make this work with startx. Then look into the DESKTOP thing. Did you try startx with the full path, eg:

startx /usr/bin/startkde -- :1

 

Yves.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...