Jump to content

Action on plugging AND unplugging a mouse


Recommended Posts

I am aware of the Gnome settings for when I plug a mouse. But this is not what I want.


Is there a way to execute something when I plug a mouse, AND when I unplug a mouse. I want to respectively disable, and enable again the touchpad in such case.


My touchpad comes in the way when I type text, but sometimes I need it (when no other mouse). For now, I tried a compromise with

syndaemon -i 2 -K

but that's not satisfactory because the touchpad is unresponsive when I need it, and it keeps clicking randomly when I type text.



Link to comment
Share on other sites

Older it seems…

[yves@localhost ~]$ rpm -qa | grep -i xorg


I don't know much about evdev, but maybe it is used:

[yves@localhost ~]$ sed -n '/mouse/,/Section/p' /etc/X11/xorg.conf
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "[b]/dev/mouse[/b]"
[yves@localhost ~]$ ls -l /dev/mouse
lrwxrwxrwx 1 root root 10 2009-03-10 08:58 /dev/mouse -> input/mice
[yves@localhost ~]$ ls -l /dev/input/mice
crw-r----- 1 root root 13, 63 2009-03-10 09:58 /dev/input/mice
[yves@localhost ~]$ ls -l /dev/input/event*
crw-r----- 1 root root 13, 64 2009-03-10 09:58 /dev/input/event0
crw------- 1 yves root 13, 65 2009-03-10 09:58 /dev/input/event1

The major number from these event* devices is the same as that of mice, and the minor is very close.



Link to comment
Share on other sites

Yep... mmm, I guess with evdev disabled/not used any of these suggestions should work:


However, with the evdev driver loaded instead they will probably not work. You will need an appropriate HAL rule instead to be put in /etc/hal/fdi/policy folder, but I can't be sure about its syntax (I'm an xml goofy).

Maybe the last suggestion above will work if put in, say, /etc/rc.local or any other multiuser startup script.

Edited by scarecrow
Link to comment
Share on other sites

Thank you scarecrow :)


That worked: I created a “/etc/udev/rules.d/85-synaptics.rules†file with this content:

ACTION=="add", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=1"
ACTION=="remove", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=0"


I also added the following new line at the end of both “/etc/X11/gdm/Init/Default†and “/etc/X11/gdm/PreSession/Defaultâ€, just before the “exit 0†last line:

/usr/bin/synclient TouchpadOff=`grep -ic mouse /proc/bus/usb/devices`

I have yet to see if this works, as I haven't disconnected so far.



Edited by theYinYeti
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...