Jump to content
Sign in to follow this  

NETGEAR WG511 and WG311 wireless 802.11g

Recommended Posts


Saturday whilst in a computer store I bought myself a wireless set.

I got an access point, PCI device (WG311) and PC card device (WG511).


It was rather an impulse made to keep me away from the new G5 MAC...


So, to cut a long story short I patched the kernel http://sourceforge.net/projects/madwifi/, recompiled got the three modules running and created a device (ath0)

Whilst I was at it I also stuck in the nvidea nfoce drivers for the sound card, integrated NIC and USB + stuck the 4GG mem on!

Oh and reran the binary NVIDIA graphics compile... from the .run


I used a vanilla 2.4-21 ....

So, it boots, my nvlan and nvaudio are both working...

The ath0 device seems OK.... and my kernel is Athalon optimised.


(Im still wating do do the same on the laptop where the kernel compile is a little more complex)


But, to connect to the access point I need to set the ssid of the card to the same as the access point.

The access point http://www.netgear.com/products/prod_detai...rodID=170&view= is meant to be preset with NETGEAR but the firmware on the cards is I think meant to be set up from the Windows installer ...


It also says it should get its IP directly from dhcp which is set up and definitely working on my home lan.


The problem is the utility to set the ssid doesn't work under linux with this driver.


I can't connect but if I ping I can see led activity on the access point.


It says it should be connected to the LAN via the 100mbit

So the questions:


Do you think if I don't connect it it will keep to the IP range from the

factory defaults ( , the idea being to determine if I can connect or not from my wireless card just to the http server in the box or do I really need to have it connected to the LAN??


Does anyone know, is the ssid already set on the cards ??? Perhaps Im wasting time trying to set something that is already set?




If I installed a win partition, is the ssid persitent. Can I just set it in Window once and then wipe the partition???

Share this post

Link to post
Share on other sites

Check MCC. If the device appears there, you should be able to run a network config in Expert mode to set the ssid of the card.


If you do end up resulting to going to Windows to get this to work, here's a word of caution: The software that came with the card will set the card to automatically pick up any available ssid (if it's the same as mine is) but this will be for Windows ONLY. Meaning if you reboot, the settings in the card will be lost. You can, if you wish, reset the ssid of the WAP through it's windows utility and that will remain set in the firmware on the WAP.

Share this post

Link to post
Share on other sites

I did try the MCC but as usual it isn't designed for non normal setup's. IT finds both but only configures the first one found... it asks if I have another card, I say yes, it finds it itself and then doesn't do anything to it!


It actually detected both the eth0 (nvidia nforce {nvnet}) and the ath0 (netgear {wlan}) but only after I forcibly created the devices.


I can ifup/down the ath0 device without error's so long as I give it a static IP but can't ping anything!


I guess I could actually diable the 100mb card in bios and see if MCC can do its stuff but the madwifi driver specifically doesn't support setting the ssid. Its written in the todo's :-(


If I knew the ssid was actually set correctly and its something else wrong then Id be half on my way to fixing it.


Right now its a bit of a black hole. Im not even sure if its picking up a dhcp address although Ill check that later tonight when I get home.


I hate to have to install windows just to get it all confirmed.....


I think once I have http access to the access point things should start to explain themselves :D



edit: /bump :D

Hey come on, suggestions.....

please ,,, anything that means I don't have to install WinBlows just to configure a damned NIC ....

Share this post

Link to post
Share on other sites

After some searching around..you can hev a look here:



this is teh first interesting thing...




and it has a link to:



http://www.linux-wlan.org/ (don't know if it's opensource..., think it is)



Maybe usefull...:

(it contains also other software (I think..mayeb the one you used) for wlans)




looks interesting (extensions, ...):



Share this post

Link to post
Share on other sites

Well configured the thing under wondows, now i just need to get it working under linux...

At least I know it was never going to work....for some reason it has set its IP range itself instead of my dhcp server so now its static and I know what it is !!!

Share this post

Link to post
Share on other sites

Well the updates:

The access point still will not boot from dhcp but its assigned a static IP now. Perhaps it specifically wants a WINBLOWS dhcp server ???


The WG511 and WG311 are about as similar as apples and oranges.

The 511 (PCMCIA) uses the PRISM chipset whereas the 311 (INTERSTIL) uses the Intersil chipset.


These are completely different drivers with completely different levels of support.


The PCMCIA prism seems the best supported so .... well Im switching my attention to that!


Rather frustrating is the fact the US beurocracy has made providing a GPL'd driver illegal for the US. Intersil actually provide all the parts which they can as GPL but due to US regulations their products would be banned from the US markets if they released the ability for and end-user to alter firmware source.


This is rather annoying because it means to get wireless working you have no option but taint the kernel.


Does anyone know of a WiFi chipset that doesn't want to sell to the US.

Especially you guys in the far east.... surely someone is making one that they don't care if its allowed to be sold in the US or not!!! ????

Share this post

Link to post
Share on other sites

Thats it.

9.1 installed perfectly and actually booted once is disabled PCMCIA.


Then i tried PCMCIA and lockup----- no messages entry just locked.


So I edit the /etc/pcmcia/config.opts and remove references to the serial ports and try again!!!


Well after A few tried I was fsck'd OFF ...

So Now we have Woody installed and Im half way through upgrading it to SID.

PCMCIA starts and stops without problems ... no lockup/power button

Ive seen posts elsewhere where Mandyusers have to pull the battery out becuase the powerswitch is disabled too.


This must be one very badly written bit of CODE.


Yet it works for 80% ??? of people

Its got to be a very low level kernel screw-up to make you need to remove the battery!!!!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...