Jump to content

Suddenly can't chainload [solved]


Recommended Posts

It is my normal practice to install one instance of grub to the MBR and then all others to the first sector of each partition. I then chainload the other versions with a menu.lst entry of (for example):


title Mandriva 2009.1
root (hd0,11)
chainloader +1


Nothing wrong with that, and it has worked perfectly up until today. Now, when I attempt to boot from that entry all I get is a black screen with the word 'GRUB' in capitals and a flashing cursor. Strangely it is impossible to do anything in the screen, you cant type and you cant shut it down either (without pressing the power button) neither Ctl/Alt/Del or Alt/SysRq/B have any effect.


If I had been messing around with grub yesterday I could have understood it, but I haven't even touched it, or menu.lst, so why it should suddenly go like that is a mystery to me.


The mystery deepens when you consider that there is absolutely nothing wrong with grub. I know that because when I copy the menu.lst entry from the 2009.1 menu.lst to the active menu.lst it boots normally - I am typing in it now, it is only the chainloading that won't work.


If anyone can suggest why that might have happened I would be interested to know. It is not a big deal if you can't because, as I said, I can work round it, but it does puzzle me.


Incidentally I did do some updates to 2009.1 yesterday, but I am pretty sure none of them related to grub.

Edited by viking777
Link to comment
Share on other sites

Hey Brilliant Medo that works!! :thumbs: .


What is more I have never seen it used in that form before so I have learnt something for the future. (Written it down in my notes because I probably won't remember next time I need it :lol2: ).


Incidentally you were right in your assumption that it doesn't matter too much what happens to my Cooker installation, it is just a plaything for me I have plently of other options that I take more care of.


Thanks again.


EDIT. Still don't know why it happened though??

Link to comment
Share on other sites

Still don't know why it happened though??

No idea. The difference is the "config /..." line only makes it load the grub in the first sector of the root partition.


BTW this is the way the Mandriva installer added the cooker grub on my machine. I had to reinstall 2009.0 and the installer added the configfile /boot/grub/menu.lst line on its own. That's where I got the idea from.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...