Jump to content
Sign in to follow this  
ilia_kr

compiz problem [solved]

Recommended Posts

Hi there,

I use openSUSE 11.0 and recently I've tried to set up compiz. The problem is that when i turn on desktop effects window borders disappear completely. How can I solve this?

 

Thanks

Edited by ilia_kr

Share this post


Link to post
Share on other sites

I think it is working. All openGL screensavers work and i have an nVidia control center filled with some stuff.

 

suse:/home/ilia # lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4400] (rev a2)
02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
02:0c.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
02:0c.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
suse:/home/ilia # cat /etc/X11/xorg.conf
# /.../
# SaX generated X11 config file
# Created on: 2008-10-08T21:50:37+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
 FontPath	 "/usr/share/fonts/misc:unscaled"
 FontPath	 "/usr/share/fonts/local"
 FontPath	 "/usr/share/fonts/75dpi:unscaled"
 FontPath	 "/usr/share/fonts/100dpi:unscaled"
 FontPath	 "/usr/share/fonts/Type1"
 FontPath	 "/usr/share/fonts/URW"
 FontPath	 "/usr/share/fonts/Speedo"
 FontPath	 "/usr/share/fonts/PEX"
 FontPath	 "/usr/share/fonts/cyrillic"
 FontPath	 "/usr/share/fonts/latin2/misc:unscaled"
 FontPath	 "/usr/share/fonts/latin2/75dpi:unscaled"
 FontPath	 "/usr/share/fonts/latin2/100dpi:unscaled"
 FontPath	 "/usr/share/fonts/latin2/Type1"
 FontPath	 "/usr/share/fonts/latin7/75dpi:unscaled"
 FontPath	 "/usr/share/fonts/baekmuk:unscaled"
 FontPath	 "/usr/share/fonts/japanese:unscaled"
 FontPath	 "/usr/share/fonts/kwintv"
 FontPath	 "/usr/share/fonts/truetype"
 FontPath	 "/usr/share/fonts/uni:unscaled"
 FontPath	 "/usr/share/fonts/CID"
 FontPath	 "/usr/share/fonts/ucs/misc:unscaled"
 FontPath	 "/usr/share/fonts/ucs/75dpi:unscaled"
 FontPath	 "/usr/share/fonts/ucs/100dpi:unscaled"
 FontPath	 "/usr/share/fonts/hellas/misc:unscaled"
 FontPath	 "/usr/share/fonts/hellas/75dpi:unscaled"
 FontPath	 "/usr/share/fonts/hellas/100dpi:unscaled"
 FontPath	 "/usr/share/fonts/hellas/Type1"
 FontPath	 "/usr/share/fonts/misc/sgi:unscaled"
 FontPath	 "/usr/share/fonts/xtest"
 FontPath	 "/opt/kde3/share/fonts"
 InputDevices "/dev/gpmdata"
 InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
 Option	   "AllowMouseOpenFail" "on"
 Option	   "ZapWarning" "on"
EndSection

Section "Module"
 Load		 "glx"
 Load		 "type1"
 Load		 "extmod"
 Load		 "dbe"
 Load		 "freetype"
EndSection

Section "InputDevice"
 Driver	   "kbd"
 Identifier   "Keyboard[0]"
 Option	   "Protocol" "Standard"
 Option	   "XkbLayout" "us"
 Option	   "XkbModel" "microsoftpro"
 Option	   "XkbRules" "xfree86"
EndSection


Section "InputDevice"
 Driver	   "mouse"
 Identifier   "Mouse[1]"
 Option	   "Buttons" "5"
 Option	   "Device" "/dev/input/mice"
 Option	   "Name" "ImPS/2 Generic Wheel Mouse"
 Option	   "Protocol" "explorerps/2"
 Option	   "Vendor" "Sysp"
 Option	   "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
 Option	   "CalcAlgorithm" "XServerPool"
 DisplaySize  376 301
 HorizSync	30-71
 Identifier   "Monitor[0]"
 ModelName	"LG ELECTRONICS L1970HR"
 Option	   "DPMS"
 Option	   "PreferredMode" "1280x1024"
 VendorName   "GSM"
 VertRefresh  43-75
 UseModes	 "Modes[0]"
EndSection


Section "Modes"
 Identifier   "Modes[0]"
 Modeline 	"1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection


Section "Screen"
 DefaultDepth 24
 SubSection "Display"
Depth	  15
Modes	  "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
 EndSubSection
 SubSection "Display"
Depth	  16
Modes	  "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
 EndSubSection
 SubSection "Display"
Depth	  24
Modes	  "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
 EndSubSection
 SubSection "Display"
Depth	  8
Modes	  "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
 EndSubSection
 Device	   "Device[0]"
 Identifier   "Screen[0]"
 Monitor	  "Monitor[0]"
EndSection


Section "Device"
 BoardName	"GeForce4 Ti 4400"
 BusID		"1:0:0"
 Driver	   "NVIDIA"
 Identifier   "Device[0]"
 Option	   "SaXDualHead"
 Option	   "TwinView"
 Option	   "SaXDualMonitorVendor" "GSM"
 Option	   "SecondMonitorHorizSync" "31-83"
 Option	   "SaXDualVSync" "50-75"
 Option	   "MetaModes" "1280x1024,1280x1024;1280x960,1280x960;1280x800,1280x800;1152x864,1152x864;12
80x768,1280x768;1280x720,1280x720;1024x768,1024x768;1280x600,1280x600;1024x600,10
24x600;800x600,800x600;768x576,768x576;640x480,640x480"
 Option	   "SaXDualOrientation" "LeftOf"
 Option	   "SaXDualResolution" "1280x1024"
 Option	   "TwinViewOrientation" "LeftOf"
 Option	   "SaXDualMode" "Xinerama"
 Option	   "SecondMonitorVertRefresh" "50-75"
 Option	   "SaXDualHSync" "31-83"
 Option	   "SaXDualMonitorModel" "LG ELECTRONICS L1750SQ"
 Screen	   0
 VendorName   "NVIDIA"
EndSection



Section "ServerLayout"
 Identifier   "Layout[all]"
 InputDevice  "Keyboard[0]" "CoreKeyboard"
 InputDevice  "Mouse[1]" "CorePointer"
 Option	   "Clone" "off"
 Option	   "Xinerama" "off"
 Screen	   "Screen[0]"
EndSection


Section "DRI"
Group	  "video"
Mode	   0660
EndSection

Section "Extensions"
 Option	   "Composite" "on"
EndSection

suse:/home/ilia #

Share this post


Link to post
Share on other sites

The problem was my NVIDIA drivers. I reinstalled them accordingly to openSuse wiki and now everything works fine.

Thank you AI !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...