Jump to content
epretorious

CD/DVD Creator Won't Recognize CD-RW

Recommended Posts

Creating CD's/DVD's used to work but stopped a couple of weeks ago. Now, when I insert a blank CD-R/DVD-R in the DVD-R, the CD/DVD Creator doesn't start anymore.

 

I found this in /var/log/kernel/errors.log after inserting a blank DVD-R:

 

[root@localhost ~]# tail /var/log/kernel/errors.log
Aug 12 15:29:55 localhost kernel: sr0: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00
Aug 12 15:33:01 localhost kernel: e1000: 0000:02:00.0: e1000_probe: The NVM Checksum Is Not Valid
Aug 12 15:33:02 localhost kernel: usb 2-1: device descriptor read/all, error -71
Aug 12 15:33:02 localhost kernel: ACPI: Error installing bay notify handler

...and I found this in the kernel ring buffer:

 

[root@localhost ~]# dmesg | grep -i cd
ACPI: ECDT 7F6F2D4A, 0052 (r1 LENOVO TP-7B		1060 LNVO		1)
scsi 1:0:0:0: CD-ROM			Hl-dT-St DvDrAm gSa-4083n 1.08 PQ: 0 ANSI: 5
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0

I've also noticed that the SD card reader has stopped mounting my SD card automatically. When I insert the SD card into the reader, this appears in the kernel ring buffer:

 

[root@localhost ~]# dmesg | tail -20
mmcblk0: mmc0:8f8b SD01G 1006080KiB 
mmcblk0: p1

(There were no new errors in /var/log/kernel/errors.log.)

 

This used to work flawlessly but something changed recently. Ideas? :huh:

Share this post


Link to post
Share on other sites

BTW: I am able to mount the SD card manually...

 

[epretorious@localhost ~]$ sudo mount /dev/mmcblk0p1 /mnt/disk/
[epretorious@localhost ~]$ mount
...
/dev/mmcblk0p1 on /mnt/disk type vfat (rw)

Share this post


Link to post
Share on other sites

FWIW: My USB thumb drive doesn't mount automatically either!

 

I found this in the kernel ring buffer:

 

usb 5-5: new high speed USB device using ehci_hcd and address 6
usb 5-5: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
scsi 2:0:0:0: Direct-Access			  Secure Guard	 PMAP PQ: 0 ANSI: 0 CCS
sd 2:0:0:0: [sdb] 2011136 512-byte hardware sectors (1030 MB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
sd 2:0:0:0: [sdb] Assuming drive cache: write through
sd 2:0:0:0: [sdb] 2011136 512-byte hardware sectors (1030 MB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
sd 2:0:0:0: [sdb] Assuming drive cache: write through
sdb: sdb1
sd 2:0:0:0: [sdb] Attached SCSI removable disk
sd 2:0:0:0: Attached scsi generic sg2 type 0
scsi 2:0:0:1: Direct-Access			  Secure Guard	 PMAP PQ: 0 ANSI: 0 CCS
sd 2:0:0:1: [sdc] 2880 512-byte hardware sectors (1 MB)
sd 2:0:0:1: [sdc] Write Protect is off
sd 2:0:0:1: [sdc] Mode Sense: 23 94 00 00
sd 2:0:0:1: [sdc] Assuming drive cache: write through
sd 2:0:0:1: [sdc] 2880 512-byte hardware sectors (1 MB)
sd 2:0:0:1: [sdc] Write Protect is off
sd 2:0:0:1: [sdc] Mode Sense: 23 94 00 00
sd 2:0:0:1: [sdc] Assuming drive cache: write through
sdc: unknown partition table
sd 2:0:0:1: [sdc] Attached SCSI removable disk
sd 2:0:0:1: Attached scsi generic sg3 type 0
usb-storage: device scan complete

...but was able to mount the thumb drive manually:

 

[epretorious@localhost ~]$ sudo mount /dev/sdb1 /mnt/nfs

[epretorious@localhost ~]$ mount
...
/dev/mmcblk0p1 on /mnt/disk type vfat (rw)
/dev/sdb1 on /mnt/nfs type vfat (rw)

Share this post


Link to post
Share on other sites

To me this smells like two entirely different problems. Stuff not automounting is likely just a helper app not running or a bad config option in your desktop environment, but your optical drive issue smells very like a hardware failure to me. As David says, test it in a live CD, preferably of another distro / OS.

Share this post


Link to post
Share on other sites

If I remember correctly, hal and udev need to be installed to get devices to mount normally. At least udev anyway.

Share this post


Link to post
Share on other sites

The CD/DVD problem can be caused by dirt, so cleaning the CD/DVD drive would be an option to consider, if the drive is already more than one year old.

 

Trying a live-CD would be a good idea, another thing you should perhaps test, is (only in case you have updated your kernel recently!) to boot the system with an older kernel and see if the problem reappears.

Share this post


Link to post
Share on other sites
so I guess that rules-out hardware
Yes, it does. Have you checked your system already, booting with a different kernel?

Share this post


Link to post
Share on other sites

I'd probably say that some update was installed in that last two week period that stopped it from working. If LiveCD's are working, and it was working up until two weeks ago, that's at least how it looks like to me. Unfortunately, it might be hard to find what with the time delay in between.

 

If it was for example, that you updated and noticed within a day or two, we might just be able to pin down what package that was installed/updated that broke it. Do you remember anything you did in the last two weeks that might help us pin it down?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...