Jump to content

A twit who doesn't know what he did [solved]


Recommended Posts

How I got Eschalon book 1 to run in the first place I don't know. Ssomehow i extracted it and it ended up here (/home/nic/.opera/cache4/temporary_download/eschalon_book_1_demo/), And it ran quite well.... but without any sound.

So looking on the internet i found something saying to use the sound default, by doing this.


./soundwrapper eschalon........ and not knowing what that really meant i went to the icon for eschalon right clicked, went to properties and entered in the field there ./soundwrapper esch.....

clicked ok, and it was gone.


not one to be detered by doing something stupid I thought perhaps if i repeated the steps on another file in the same directory I would see what happened, So i chose the purchase the full game file, right clicked on the icon, went to properties, entered ./soundwrapper purchaseit..etc. and clicked ok, and now that file was gone.


I'm sure i could do it again with all the other files in the dirctory, but i thought that i had accomplished quite enough for the evening.


My only excuse is that while i understand the file structure/system from old dos and windows I have no idea what is going on in Mandriva/linux, neither do i understand its extensions.




Where do you think my files went to, and how do I get them back.

And once that is done how do I get sound to work in eschalon..


Thanks from, who only the polite call, a newbie.


[moved from Software by Greg2]

Link to comment
Share on other sites

What do you currently have in your ~/.opera/cache4/temporary_download directory? If you still have the eschalon_book_1_demo directory in the temporary_download directory, you can move it to your ~/home/nic/ with right-click > cut or copy > paste. Don't leave any files you want to keep in the /cache4/temporary_download directory, because it's temporary.


When you right-clicked on the icon and entered ./soundwrapper esch....., you changed the name. So open the eschalon_book_1_demo directory with konqueror, go to view and click 'show hidden files', now you should see it. Change the name with right-click > rename, and enter 'launch_icon.png' without the quotes. Now you should see the icon.


Please note that these steps would be the same for the full game, except for the file names.


Now to start the game with sound, I need to know what version of Mandriva you're using?

Link to comment
Share on other sites

Yes! There they are.


OK I've moved them and the whole folder, (to the desk top)


And I'm running Mandriva 2008.1, (just downloaded and installled about a week ago).


And if you can help me get the sound going in eschalon, I will actually buy the game, even though it's runs a little slow.


Thanks for you help


Think if I removed compiz fusion it would run faster?

Link to comment
Share on other sites

OK I've moved them and the whole folder, (to the desk top)


And I'm running Mandriva 2008.1

As tyme has noted, disable compiz fusion for better fps.


Do you have the game directory in /home/nic/Desktop or /home/nic? If it's in Desktop, please move it to /home/nic, so it will be located at /home/nic/eschalon_book_1_demo. Then open a terminal e.g., konsole, go to menu > tools > konsole and click on it. Then in the konsole type (or copy and paste from here)

cd eschalon_book_1_demo; pasuspender ./eschalon_book_1_demo

and hit enter. Let us know if that works for you?

Link to comment
Share on other sites

Greg, that was one neat bit of work.

Even though I don't play the game or know anything about it, I could easily follow your post. :thumbs: :thumbs: :thumbs:


Cheers. John.

Thanks, John!


I've never played this game either, however I'm d/l the demo now to give it a try. :)

Link to comment
Share on other sites

Worked brilliantly!


I have sound.


Um, Now not to overburden your kindness.


How do I get rid of compiz-fusion

I thought it was just a matter of using "install remove softwar" but that does not seem to have done the trick.


If it's of any interest I am trying to parse out my calls for help amungst the various mandriva forum sites.


Thanks, for the continued help.


ps I have now obtained the full eschalon program, and will be trying to install it once this letter is submitted.


Oh, isn't there a way to set up an clickable icon to open Konsole and enter that command rather than me having to do it manually?


Thanks again



Link to comment
Share on other sites

You don't have to remove compiz-fusion, simply turn it off. Go to menu > tools > system tools > configure your computer > hardware > configure 3D desktop effects > check- 'no 3d desktop effects'.


Open your konsole and enter (as root), to do this command as root do


enter your password, and hit enter. Then type

cd /home/nic/eschalon_book_1_demo && cp launch_icon.png /usr/share/icons/

then hit enter, then exit to leave root.


Now go to menu > tools > menu editor > games > Adventure, and click on new. For the name enter Eschalon, for the command enter

cd eschalon_book_1_demo; pasuspender ./eschalon_book_1_demo

then click on the icon and select the one you just copied to /usr/share/icons. Click on save, and you're done. Enjoy the game! :)

Link to comment
Share on other sites

Would be wayyyy easier to install fusion-icon and set it up in sessions. Then you can enable/Disable compiz with a click.



Or make a script for the game;


example for gnome; It disable compiz by replacing it with metacity, launching the game afterwards. When you exit the game compiz starts up again.



metacity --replace &

cd <directory>

compiz --replace &


chmod+x the script file and either you can click it to launch or make a nice shortcut in the menu to the script.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...