Jump to content

More ndiswrapper problems!


Recommended Posts

Ok, so I'm trying to install Mandriva 2008.1 on a brand new Dell Vostro laptop with the Dell 1395 wifi card. I know, shoulda gone with an intel wireless card, but that would have been $200 more, because I would have had to buy an Inspiron. So, anyways, it wouldn't install through mcc, kept throwing the "cannot find ndiswrapper interface" error. So, according to Google, I should try compiling it from source. Well, I downloaded the latest version, completely removed my old ndiswrapper, installed the kernel sources, but when I run make I get:

make -C driver
make[1]: Entering directory '/home/urza9814/ndiswrapper-1.52/driver'
make[1]: *** /.config: Is a directory. Stop.
make[1]: Leaving directory '/home/urza9814/ndiswrapper-1.52/driver'
make: *** [all] Error 2


Now, I've googled that /.config is a directory error, along with 'ndiswrapper', and I got exactly one result. And it's in Italian. So...anyone have any solutions in English? heh

Link to comment
Share on other sites

I assume that you have tried installing it through urpmi?


A quick check of the 2008.1 official main repo shows that exact version of the ndiswrapper rpm.


If you are unable to do that (network connection, or whatever), you could always download it on another machine, burn it to a disc and transfer it over to your Dell.

Link to comment
Share on other sites

There's a tool in Mandriva's control center for setting up NDISWRAPPER, you just do it through the normal networking and select the right options IIRC (this will take care of modprobing and everything). I would go this route as Mandriva may have some weird way of doing things or you may be missing a step (I remember there being extra steps to setting up ndiswrapper). With a distribution like Mandriva it's almost always best to use the tools provided.


(if you DID use this tool, and thats where you got the "could not find module" error, then ignore me ;) )

Edited by tyme
Link to comment
Share on other sites

Ok, so following that...I get the error 'No .config found in , please set KBUILD to configured kernel.'


So, I did. And the error still pops up. Running 'ls -a $KBUILD' even shows a .config. Tried running these commands as both user and root, and yes, I reset KBUILD each time.


Oh, and I also reformatted and reinstalled Mandriva before doing this to ensure nothing I'd been messing with before could interfere.

Edited by Urza9814
Link to comment
Share on other sites

Ok, now I feel stupid. I failed to connect the fact that my laptop came with Vista, therefore the drivers in C:\Drivers are Vista drivers. So that's why the RPM failed. Of course, that still doesn't explain why I can't build from source...but I suppose that's a moot point now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...