Jump to content
richard-gt

broken network configuration

Recommended Posts

On my computer running 2007.1, I connect to my router (192.168.2.1) using an Atheros card (configured for DHCP). Last night, I was trying to set up a new router by connecting an ethernet cable between the wired interface built into the motherboard and the new router, and then pointing my web browser to 192.168.1.1, the default address of the new router. Well, I could ping the new router, but I couldn't get the web interface loaded, so I tried changing settings in the networking section of mcc (gave eth0 a static IP, manually set the gateway and DNS servers, disabling the firewall). I must have done something very wrong, because I can no longer connect to the internet at all, even after unplugging the new router, giving my computer a cold boot, and trying to run the network setup wizard again. Other computers attached to my router can still access the internet, and I can even access the internet when I boot from a live cd of 2008.1. For that matter, I can load up the new router's configuration web page when booting from the live cd.

 

Short of reformatting / and installing from scratch, is there any way that I can clean my network configuration?

Share this post


Link to post
Share on other sites

What ever you do, you do not need to reformat and reinstall to fix this.

 

O.K. the Antheros card, is this wireless? What is it called? Ath0 ?

 

The wired interface is probably eth0.

 

Anyway, open a konsole and as root run the command 'ifconfig' and cut and paste the results here so we know if you have IP addresses on either interface, what is up and what is down.

 

Once you know the names of the interaces, there are files at /etc/sysconfig/network-scripts/ for each interface. I'll assume for now you have a ath0 and a eth0 interface. The files for each will be called ifcfg-eth0 and ath0 in the above directory.

 

Cut and paste the contents of those files here. They can be edited as root. These are the files the wizards create.

 

Here is what the eth-0 file on my system looks like.

 

cat ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.26
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=no
USERCTL=yes
DNS1=207.164.234.193
DNS2=206.47.244.56
RESOLV_MODS=yes
LINK_DETECTION_DELAY=6
IPV6INIT=no
IPV6TO4INIT=no

 

It is a wired card, and I have a router. The DNS settings should be in /etc/resolv.conf as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...