Jump to content
derxen

flaky ethernet [solved]

Recommended Posts

Hello everyone

 

I wonder if anyone could help me with my ethernet connection. My ethernet connection with the dsl gateway went flaky, so i put in a new ethernet card, but it remains patchy. The light goes on and off. This is from /var/log/messages:

Oct 8 20:03:45 localhost ifplugd(eth1)[4034]: Link beat lost.

Oct 8 20:03:50 localhost ifplugd(eth1)[4034]: Link beat detected.

Oct 8 20:05:51 localhost ifplugd(eth1)[4034]: Link beat lost.

Oct 8 20:05:57 localhost ifplugd(eth1)[4034]: Executing '/etc/ifplugd/ifplugd.action eth1 down'.

Oct 8 20:05:57 localhost avahi-daemon[3014]: Withdrawing address record for 192.168.1.64 on eth1.

Oct 8 20:05:57 localhost avahi-daemon[3014]: Leaving mDNS multicast group on interface eth1.IPv4 with address 192.168.1.64.

Oct 8 20:05:57 localhost avahi-daemon[3014]: IP_DROP_MEMBERSHIP failed: No such device

Oct 8 20:05:57 localhost avahi-daemon[3014]: Interface eth1.IPv4 no longer relevant for mDNS.

Oct 8 20:05:57 localhost avahi-daemon[3014]: Withdrawing address record for fe80::204:75ff:fee8:c09f on eth1.

Oct 8 20:05:57 localhost ifplugd(eth1)[4034]: Program executed successfully.

Oct 8 20:05:57 localhost kernel: ACPI: PCI Interrupt 0000:02:02.0[A] -> GSI 18 (level, low) -> IRQ 20

Oct 8 20:05:57 localhost kernel: eth1: setting half-duplex.

Oct 8 20:05:57 localhost kernel: ADDRCONF(NETDEV_UP): eth1: link is not ready

Oct 8 20:06:05 localhost ifplugd(eth1)[4034]: Link beat detected.

Oct 8 20:06:05 localhost kernel: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

Oct 8 20:06:06 localhost ifplugd(eth1)[4034]: Executing '/etc/ifplugd/ifplugd.action eth1 up'.

Oct 8 20:06:07 localhost avahi-daemon[3014]: Registering new address record for fe80::204:75ff:fee8:c09f on eth1.*.

Oct 8 20:06:10 localhost dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67

Oct 8 20:06:10 localhost dhclient: DHCPACK from 192.168.1.1

Oct 8 20:06:10 localhost avahi-daemon[3014]: Joining mDNS multicast group on interface eth1.IPv4 with address 192.168.1.64.

Oct 8 20:06:10 localhost avahi-daemon[3014]: New relevant interface eth1.IPv4 for mDNS.

Oct 8 20:06:10 localhost avahi-daemon[3014]: Registering new address record for 192.168.1.64 on eth1.IPv4.

Oct 8 20:06:10 localhost NET[6802]: /sbin/dhclient-script : updated /etc/resolv.conf

Oct 8 20:06:10 localhost dhclient: bound to 192.168.1.64 -- renewal in 39484 seconds.

Oct 8 20:06:10 localhost ifplugd(eth1)[4034]: client: Determining IP information for eth1... done.

Oct 8 20:06:10 localhost ifplugd(eth1)[4034]: Program executed successfully.

Oct 8 20:09:06 localhost ifplugd(eth1)[4034]: Link beat lost.

Oct 8 20:09:10 localhost kernel: eth1: setting full-duplex.

Oct 8 20:09:11 localhost ifplugd(eth1)[4034]: Link beat detected.

Oct 8 20:13:10 localhost ifplugd(eth1)[4034]: Link beat lost.

Oct 8 20:13:15 localhost ifplugd(eth1)[4034]: Link beat detected.

 

Etcetera. This is ifconfig:

 

eth1 Link encap:Ethernet HWaddr 00:04:75:E8:C0:9F

inet addr:192.168.1.64 Bcast:192.168.1.255 Mask:255.255.255.0

inet6 addr: fe80::204:75ff:fee8:c09f/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:932 errors:0 dropped:0 overruns:11 frame:0

TX packets:1305 errors:0 dropped:0 overruns:0 carrier:882

collisions:0 txqueuelen:1000

RX bytes:477083 (465.9 KiB) TX bytes:452022 (441.4 KiB)

Interrupt:20 Base address:0xf80

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:384 errors:0 dropped:0 overruns:0 frame:0

TX packets:384 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:29568 (28.8 KiB) TX bytes:29568 (28.8 KiB)

 

Is this a hardware problem, or is something misconfigured? It's driving me nuts. Any help wuld be appreciated.

 

derxen

Edited by derxen

Share this post


Link to post
Share on other sites

Mysteriously, it worked perfectly yesterday, after i had taken out the NIC and reinserted it, and switched the gateway off and on. That seems to suggest the hardware is okay. But today it's the same problem again.

Share this post


Link to post
Share on other sites

Did you force full-duplex and speed? Is it also forced on the switch? If you force these settings, it must be forced on both the machine and the switch. If not, you can get link problems. If you cannot force it on the switch, then make sure the machine is set to auto for speed and duplex.

Share this post


Link to post
Share on other sites

thanks ian, that might have something to do with it, because one of the things i did yesterday was to set full duplex on the driver for the nic. i'll check when i get back home and report back.

 

derxen

Share this post


Link to post
Share on other sites

You can reset the configuration most likely within System/Configuration/Configure Your Computer/Networking. In here go to set up LAN connection, and then follow through the configuration and make sure it's auto for speed and duplex - might require enabling advanced options to see it if it's not there by default.

 

Otherwise, post the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 (or whatever the eth number of your device is). We can then look and remove from this config file what we don't need. But try the gui method first.

Share this post


Link to post
Share on other sites

this is ifcfg:

 

DEVICE=eth1

BOOTPROTO=dhcp

ONBOOT=yes

METRIC=10

MII_NOT_SUPPORTED=no

USERCTL=no

RESOLV_MODS=no

IPV6INIT=no

IPV6TO4INIT=no

DHCP_CLIENT=dhclient

NEEDHOSTNAME=no

PEERDNS=yes

PEERYP=yes

PEERNTPD=no

 

i would hate to reinstall the nic, now that it works. i'm pretty sure i didn't get options for speed and duplex when i installed it before via mcc.

 

derxen

Edited by derxen

Share this post


Link to post
Share on other sites

Looks OK to me. I can't see any options in there that we would need to remove as such. If you didn't get the options, then the chances are it's set to auto. You can check however with:

 

mii-tool

 

this will tell you the current setup for the card, and can be a great help to seeing if your nic is OK.

Share this post


Link to post
Share on other sites

Hi Ian,

 

this is the output of mii-diag eth1:

 

Basic registers of MII PHY #24: 3000 7829 0041 6800 0541 45e1 0007 2801.

The autonegotiated capability is 0140.

The autonegotiated media type is 100baseTx-FD.

Basic mode control register 0x3000: Auto-negotiation enabled.

Basic mode status register 0x7829 ... 782d.

Link status: previously broken, but now reestablished.

Your link partner advertised 45e1: Flow-control 100baseTx-FD 100baseTx 10baseT-FD 10baseT, w/ 802.3X flow control.

End of basic transceiver information.

 

mii-tool -w gives:

 

14:20:26 eth1: negotiated 100baseTx-FD flow-control, link ok

14:20:30 eth1: no link

14:20:31 eth1: negotiated 100baseTx-FD flow-control, link ok

14:20:33 eth1: negotiated 100baseTx-FD flow-control, link ok

14:20:56 eth1: no link

14:20:58 eth1: negotiated 100baseTx-FD flow-control, link ok

14:21:07 eth1: no link

 

etcetera. So it looks to be on auto. I can't make any sense of this behavior: yesterday it worked perfectly, then this morning it wouldn't even blink, and now it's patchy, but getting better.

 

derxen

Share this post


Link to post
Share on other sites

I'll mark this as solved, because I have installed 2008 now and ethernet seems fine. It doesn't come on instantly though, so I have a feeling I'll be back with this.

 

derxen

Share this post


Link to post
Share on other sites

Hi Ian

 

I think 2008 disables ipv6 by default, because it is turned off on eth0.

 

What's been happening the last couple of times is that it takes about ten minutes to give signs of life, then little by little it will start to blink more frequently, and eventually a link is established, and then a while later the link is stable. Takes about twenty minutes. It's as if it has to warm up.

 

derxen

Share this post


Link to post
Share on other sites

A final update: I have now found out this was always a hardware problem, see for example http://www.linksysinfo.org/forums/showthread.php?t=55422 Apparently I'm not the only one with this problem. Time for a new modem/router (I'm not handy with a soldering iron). If anyone feels tempted to buy a linksys wag54g: don't, it has many other problems as well. Does anyone know a good replacement?

 

derxen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...