Jump to content
Guest linube

WinFast TV 2000 XP, please help!

Recommended Posts

Guest linube

Hello, I have recently installed Mandriva 2007.0 and everything seems to work perfectly (both on my laptop including wireless and desktop). But I have a problem with my WinFast TV 2000 XP card despite I have tried different things that I have read all over places, and still can't make it work. Please shed a light on me, I don't really want to switch back to Windows just because I only want to watch the TV.

 

Here is the dmesg output:

 

bttv: driver version 0.9.16 loaded

bttv: using 4 buffers with 2080k (520 pages) each for capture

bttv: Bt8xx card found (0).

bttv0: Bt878 (rev 17) at 0000:02:02.0, irq: 20, latency: 32, mmio: 0xdc001000

bttv0: detected: Leadtek TV 2000 XP [card=34], PCI subsystem ID is 107d:6609

bttv0: using: Leadtek WinFast 2000/ WinFast 2000 XP [card=34,insmod option]

bttv0: gpio: en=00000000, out=00000000 in=003ff502 [init]

bttv0: using tuner=5

bttv0: i2c: checking for MSP34xx @ 0x80... not found

bttv0: i2c: checking for TDA9875 @ 0xb0... not found

bttv0: i2c: checking for TDA7432 @ 0x8a... not found

bttv0: i2c: checking for TDA9887 @ 0x86... not found

bttv0: registered device video0

bttv0: registered device vbi0

bttv0: registered device radio0

bttv0: PLL: 28636363 => 35468950 .. ok

input: bttv IR (card=34) as /class/input/input2

bttv-input: bttv IR (card=34) detected at pci-0000:02:02.0/ir0

 

 

Thank you and greatly appreciate for your helps.

Share this post


Link to post
Share on other sites

add one line to /etc/modprobe.conf as root

 

options bttv card=34 tuner=5

 

Reboot

 

Tuner maybe other type, probe ....Jan

Share this post


Link to post
Share on other sites
Guest linube

Hello Lexicon, thank you for your reply.

 

I already tried that but it didn't work. I reckon I will have to buy a different one that will work on Linux. However, I am not too sure which one will work with Mandriva 2007.0 or Fedora.

 

Thank you.

Share this post


Link to post
Share on other sites
Guest linube

I finally make it work!!! It is really simple that I have never though of. Just edit this file: dynamic_dev_v4l_video0_dynamic.desktop

and uncomment the line # in /usr/share/apps/kdesktop/Desktop/dynamic_dev_v4l_video0_dynamic.desktop

 

[Desktop Entry]

Name=KdeTv BT878 video (Leadtek WinFast 20

Comment=Kdetv

Exec=/usr/bin/kdetv

Terminal=false

Icon=kdetv.png

Type=Application

dynamic_device=/dev/v4l/video0

 

 

I am using KDE thought.

Edited by linube

Share this post


Link to post
Share on other sites
Guest linube

Thanks Lexicon,

 

Actually, I just found out that uncomment that line will not work either. Sorry, I am wrong!!! I think I did add the commands that you said in previous post in modprobe.conf in order to make it works.

 

options bttv card=34 autoload=0 radio=1

post-install bttv insmod tuner type=5

 

I apologise for that.

Share this post


Link to post
Share on other sites

I just wanted to say that after a full wasted day I got it to work. for me I needed to set this in modeprobe.conf

 

options bttv card=34 tuner=38

 

and this in modprobe.preload

 

bttv

bt878

 

 

 

also, kdetv was problematic but tvtime worked fine, needed to scan for channels by frequency

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...