Jump to content

Java help please


Recommended Posts

I've been doing a lot of digital photography and image editing lately, and decided to try and calibrate my monitor a little better. I don't dual boot with windows, so using a windows tool to create a color profile for xcalib is out of the question.


I've found two differnet linux tools for calibration.


The first is Monica, which works fine, but is WAY too basic for what I want to do.


The one that looks great to me is called CalibrationAider available at http://www.imagingassociates.com.au/color/...ationaider.jspx


They have a version designed for linux that is written in java. I have the latest version of java installed and working properly, the plugin works fine anyway.


Every time I try to launch CalibrationAider, I get the java splach screen, followed by a brief pause (~3 seconds) followed by an error window that just says "Unable to Launch the Application."


If I click on 'details' the box contains the following error code:


MissingFieldException[ The following required field is missing from the launch file: <jnlp>]
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


If anyone can help me out here, I would REALLY appreciate it.

Link to comment
Share on other sites

That sounds like you're trying to use the web start stuff and it's not finding the right tags in the xml. It's not clear whether you're trying to run it online using the browser, or whether you've downloaded the jar to your machine already.


I just followed your link and downloaded a "CalibrationAider.jar" file, then from a console just did

java -jar CalibrationAider.jar

and it worked ok. But that's not using javaws or jnlp so it can't be the same as what you tried to do...

Link to comment
Share on other sites

The jar works fine for me as well (using JRE 6 update 2).

Factly, I did not even see where the java web start launch applet was on that site!

Anyway- are you sure that "javaws" is in your PATH? If it isn't, then jnlp applets won't start properly.

Also, get sure you haven't wrongly associaated .jar files with java web start application (javaws). The correct way to launch applcation "foo.jar" is as described above ( java -jar foo.jar ).

Edited by scarecrow
Link to comment
Share on other sites

I had been trying 'javaws calibrationaider.jar'


clearly it was just me. Unfortunately, that program seems to be a lot less than advertised. Anybody else know of a good programs for monitor calibration in linux?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...