Jump to content
Sign in to follow this  
Scythe

Dual Monitors on NVIDIA 7300gs [solved]

Recommended Posts

I've just done a fresh install of Mandriva 2007 and am attempting to make my dual monitors work with my setup. I've also installed the latest NVIDIA driver, 1.0-9755, so that's all up to date. This is my xorg.conf file:

 

# File generated by XFdrake (rev 62599)


Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "LCD-MONITOR"
HorizSync 29-81
VertRefresh 54-76

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"	 50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"	 63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce 7 Series"
Driver "nvidia"
Option "DPMS"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Mon Feb 26 23:37:58 PST 2007

# File generated by XFdrake (rev 57713)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
EndSection

Section "Files"
# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath "unix/:-1"
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 15
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 16
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 24
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
Option "DPMS"
EndSection

Section "Extensions"
Option "Composite"
EndSection

 

I've read in other threads that you can trick the xorg.conf into thinking there is one virtual monitor of double width, but I can't find the corresponding section in my xorg.conf. Any help is much appreciated.

Edited by Scythe

Share this post


Link to post
Share on other sites

here's how i did mine. i'm running mdv2007 one. this also works in mdv2007 free, mdv2006 free, mdv2005 free, and pclinuxos 0.92. i'm running nvidia fx5200, 2 samsung syncmaster 204t monitors. total resolution = 3200x1200. i did urpmi dkms nvidia to install the driver and allowed the installer to generate xorg which apparently you have already done as you have "nvidia" in the device section. compiz with aiglx works very nicely on 2 screens. it's pretty neat. you may have probs with some applications that don't know where to place their windows on the screen. they will crash and not run. it's rare and the only one i found that won't run is neverball game. there were a couple of others but i forget what.

 

first make a backup of your xorg.conf

 

so basically you just need to add a couple of entries. make sure there are no typos (caps, commas, quotes, spaces, etc) or X won't start. my monitors are 1600x1200, you'll need to add whatever yours is.

1. in the "Device" section add;

Option "MetaModes" "1600x1200, 1600x1200"

Option "TwinView"

 

this is the trick that fools X into thinking you have 1 monitor. again change these numbers to whatever resolution you're using. just double your width.

2. in the "Screen" section add this line to all depths

Virtual 3200 1200

 

after you save this and restart X you should see the nvidia logo spanning both screens for a second or 2. that's it. it's a thing of beauty, lool. pay close attention to any typographical errors or X won't start. i see a couple of lines that i don't know what effect they will have as i never had to edit them. if you have a problem then maybe they should be changed.

in your "ServerLayout" section it says Screen "screen1" 0 0. mine just says Screen "screen1". i don't know if this will conflict with twinview or not. i would remove the 0's.

in my "Module" section there's a line about loading libglx.so. i don't know if this is necessary as the next line says load glx. i never had this in my other xorg files and i don't know where it came from. possibly from the nvidia installer. probably wouldn't hurt to add it.

 

sorry about making this post a tutorial, lool. hope it works.

 

here's my xorg.

# File generated by XFdrake (rev 57713)

 

# **********************************************************************

# Refer to the xorg.conf man page for details about the format of

# this file.

# **********************************************************************

 

Section "Files"

# font server independent of the X server to render fonts.

FontPath "unix/:-1"

 

# minimal fonts to allow X to run without xfs

FontPath "/usr/share/fonts/misc:unscaled"

EndSection

 

Section "Extensions"

EndSection

 

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse does not work

#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection

 

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"

Load "glx" # 3D layer

EndSection

 

Section "InputDevice"

Identifier "Keyboard1"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

Option "XkbOptions" "compose:rwin"

EndSection

 

Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"

EndSection

 

Section "Monitor"

Identifier "monitor1"

VendorName "Plug'n Play"

ModelName "SyncMaster"

HorizSync 30-81

VertRefresh 56-75

 

# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

 

# 768x576 @ 100 Hz, 61.6 kHz hsync

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

EndSection

 

Section "Device"

Identifier "device1"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce FX (generic)"

Driver "nvidia"

Option "DPMS"

Option "MetaModes" "1600x1200, 1600x1200"

Option "TwinView"

EndSection

 

Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24

 

Subsection "Display"

Depth 8

Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

Virtual 3200 1200

EndSubsection

 

Subsection "Display"

Depth 15

Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

Virtual 3200 1200

EndSubsection

 

Subsection "Display"

Depth 16

Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

Virtual 3200 1200

EndSubsection

 

Subsection "Display"

Depth 24

Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

Virtual 3200 1200

EndSubsection

EndSection

 

Section "ServerLayout"

Identifier "layout1"

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"

Screen "screen1"

EndSection

 

for background wallpapers you'll have to use one image and stretch it to your resolution. you can find some good widescreen papers around the web. some look good some don't.

another way is to create a new image in the gimp at whatever resolution you have and layer 2 smaller images into it. this gives the appearence that each monitor has a different wallpaper but is actually one image.

Edited by cybormoron

Share this post


Link to post
Share on other sites

Well, that certainly gave me the span of two monitors - the only problem is that they're in reverse order. In other words, my right monitor is set as the left one and vice-versa.

 

What I want is to have the taskbar and menu on the right monitor and have the desktop extend into the left one. What would I change for that?

Share this post


Link to post
Share on other sites

i looked around and found a couple of pages with more info for ya. looks like you can just add another option in the device section. i didn't study this any further for my purposes so i don't know what works. hope it works for you.

Option "TwinViewOrientation" "LeftOf"

 

from this page

http://pwp.netcabo.pt/0150048402/linux/Mul...tiple_Head.html

Section "Device"

Identifier "AGP"

Driver "nvidia"

VendorName "Sparkle"

BoardName "NVIDIA GeForce FX5500"

BusID "PCI:1:0:0"

Option "NvAGP" "1"

Option "RenderAccel" "True"

Option "TwinView"

Option "TwinViewOrientation" "LeftOf"

 

from this page

http://www.evl.uic.edu/cavern/agave/docs/setup.htm

Linux:

 

1. The /etc/X11/XF86Config-4 file controls how the display should look. Please look at the README file that Nvidia provides. The following is a chunk out of this file relevant to setting up Twinview.

 

Section "Screen"

Identifier "Screen0"

Device "NVIDIA GeForce 4 (generic)"

Monitor "Monitor0"

DefaultDepth 16

 

Subsection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubsection

 

Option "TwinView"

Option "SecondMonitorHorizSync" "31.5-48.5"

Option "SecondMonitorVertRefresh" "50-70"

Option "MetaModes" "1024x768,1024x768"

Option "TwinViewOrientation" "RightOf"

#Option "TwinViewOrientation" "Clone"

#Option "Stereo" "4"

 

EndSection

 

You can download an example XF86Config-4 file here. This file is configured to run in 'Clone mode' where both your monitors will show the same desktop instead of the desktop being stretched across. Change the 'TwinViewOrientation' to 'RightOf' (or 'LeftOf') ; restart the Xserver and you should see the desktop stretch across the two monitors.

http://www.evl.uic.edu/cavern/agave/vis5d/XF86Config-4.txt

Share this post


Link to post
Share on other sites

That definitely worked :D I'll post my final xorg.conf in case anyone else thinks it might help:

 

# File generated by XFdrake (rev 62599)


Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "LCD-MONITOR"
HorizSync 29-81
VertRefresh 54-76

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"	 50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"	 63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce 7 Series"
Driver "nvidia"
Option "DPMS"
Option "Metamodes" "1280x1024, 1280x1024"
Option "Twinview"
Option "TwinviewOrientation" "LeftOf"

EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Mon Feb 26 23:37:58 PST 2007

# File generated by XFdrake (rev 57713)
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Section "Files"
# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath "unix/:-1"
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
	Virtual 2560 1024
EndSubsection

Subsection "Display"
	Depth 15
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
	Virtual 2560 1024
EndSubsection

Subsection "Display"
	Depth 16
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
	Virtual 2560 1024
EndSubsection

Subsection "Display"
	Depth 24
	Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
	Virtual 2560 1024
EndSubsection
Option "DPMS"
EndSection

Section "Extensions"
Option "Composite"
EndSection

 

Thanks so much for the help. This definitely makes me want to set Mandriva as my primary workspace over Windows for day-to-day stuff.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...