Jump to content

partimage - incompatible version of gcc [solved]


Recommended Posts

Hi all,


I just installed partimage via urpmi but when I attempt to use the program I get the following error:


Error: sizeof(DWORD) != 4 (8)
This version has been compiled with an uncompatible version of gcc.


So I used urpme to uninstall it and downloaded and installed a file from a different server. Same problem.


Next I downloaded the source rpm then used "rpm --rebuild" and installed the resulting rpms. Same result as above.


My OS Mandriva 2007 x86_64 and my gcc version 4.1.1 20060724 (prerelease) (4.1.1-3mdk). Any ideas? I'm at a loss as to what is going on here.




Link to comment
Share on other sites

It doesn't matter now. I've installed the partimage i386 static binary tarball from http://www.partimage.org/ which worked fine. I only wanted to make a backup image file of my WinXP partition so that next time it stuffs itself up I don't have to remove my linux partitions just to reinstall windows (especially when I only use windows every 2 months)!


Still think the gcc version mixup is a bit strange though...



Edited by skinky
Link to comment
Share on other sites

  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...