Jump to content
Sign in to follow this  
sjaglin

Hauppauge wintv nova-t [Solved]

Recommended Posts

Hi,

 

I carry-on my investigations into getting a dvb-t to work under Mandriva 2007. The card is a wintv nova-t from Hauppauge with an IR remote control. The chip on the card is from connexant and its id is cx2388x.

 

[root@linux-box dev]# lsmod | grep cx
cx8800				 28460  0
cx88xx				 55620  1 cx8800
ir_common			  24484  2 bttv,cx88xx
i2c_algo_bit			9352  2 bttv,cx88xx
video_buf			  21220  3 bttv,cx8800,cx88xx
tveeprom			   14192  2 bttv,cx88xx
i2c_core			   17536  5 bttv,nvidia,cx88xx,i2c_algo_bit,tveeprom
v4l2_common			15648  2 bttv,cx8800
compat_ioctl32		  1952  2 bttv,cx8800
v4l1_compat			14212  1 cx8800
btcx_risc			   4840  3 bttv,cx8800,cx88xx
videodev				8064  3 bttv,cx8800,cx88xx
and lspci :
..........
04:09.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
04:09.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
04:09.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
root@linux-box dev]#

 

So it seems that the device is correctly detected. When I start kdetv, the program detects the card and tries to find some channel with no success.

 

Drakconf detects the card with brand and chip correctly recognised, but the IR remote appears in the keyboards (still with correct name).

 

The card works under windows (Boooh!) and detects all the local channels from my local aerial (uk-Mendip).

 

What I don t get is that I should have a device in /dev/dvb/ and I don t have this directory!

 

So my questions are :

 

-even though Drakconf has detected the card and the remote, does it mean that they are correctly installed?

-Where can I find out if they are actually installed.

-where can I see them in my modprobe.conf?

 

alias eth0 forcedeth
alias sound-slot-0 snd-hda-intel
install scsi_hostadapter /sbin/modprobe sata_nv; /bin/true
install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 eth1394
alias ieee1394-controller ohci1394
remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }

options visor vendor=0x0830 product=0x061
blacklist audio
blacklist snd-usb-audio

 

All probably very basic stuff but it's just getting on my nads a little bit!

 

Thanks for your help!

 

Stef.

 

:wall:

Edited by sjaglin@yahoo.co.uk

Share this post


Link to post
Share on other sites
Guest Plisgyn

Stef

I am using same card with kaffeine and I added a line cx88_dvb to /etc/modprobe.preload and

lsmod | grep cx shows.

 

cx88_dvb			   11396  0
cx8802				 10020  1 cx88_dvb
cx88_vp3054_i2c		 4448  1 cx88_dvb
mt352				   6660  1 cx88_dvb
or51132				10020  1 cx88_dvb
video_buf_dvb		   5348  1 cx88_dvb
nxt200x				13444  1 cx88_dvb
zl10353				 5156  1 cx88_dvb
cx24123				13640  1 cx88_dvb
lgdt330x				8156  1 cx88_dvb
cx22702				 6564  1 cx88_dvb
dvb_pll				11140  4 cx88_dvb,or51132,nxt200x,cx22702
cx8800				 28460  0
cx88xx				 55620  3 cx88_dvb,cx8802,cx8800
ir_common			  24484  1 cx88xx
i2c_algo_bit			9352  2 cx88_vp3054_i2c,cx88xx
video_buf			  21220  5 cx88_dvb,cx8802,video_buf_dvb,cx8800,cx88xx
tveeprom			   14192  1 cx88xx
i2c_core			   17536  12 nvidia,cx88_dvb,mt352,or51132,nxt200x,zl10353,cx24123,lgdt330x,cx22702,cx88xx,i2
c_algo_bit,tveeprom
v4l2_common			15648  1 cx8800
compat_ioctl32		  1952  1 cx8800
v4l1_compat			14212  1 cx8800
btcx_risc			   4840  3 cx8802,cx8800,cx88xx
videodev				8064  2 cx8800,cx88xx

Edited by Plisgyn

Share this post


Link to post
Share on other sites

Hi,

I ll try that tomorrow (about to go to bed..) but I might need more help after, I ll keep u updated!

Cheers for that

Stef

Share this post


Link to post
Share on other sites

Yes!

It works perfectly now, I can watch, record etc using Kaffeine.

 

Cheers!

 

Stef :D

Share this post


Link to post
Share on other sites

Just got mine working too :D

 

How are you guys using your remotes ?

 

Numbers 0-9 and also the arrow keys and select button appear to be working out of the box. But Im only able to change channels in Kaffeine with 0-9.

 

Ill need to do some messing around.

 

Thanks again. :thumbs:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...