Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
Rapha

Installing Motorola SB5100 USB Modem

Recommended Posts

Hi,

 

to install the modem just do the following:

 

# modprobe usbnet
# modprobe uhci-hcd
# ifconfig -a
# dhclient eth1 //(or eth1)//

 

It worked perfectly for me.

 

:D

Share this post


Link to post
Share on other sites

Hi all,

Normally I use a cable modem plugged into my ethernet port, and it was trivial to set up. Now I´m trying to hook up the same laptop at a friend´s house where there´s only a cable modem with USB connection. It´s a Motorola SBV5120E surfboard modem, so I followed the instructions above. /var/log/messages already mentioned "using uhci_hcd and address 5" so it sounded good.

 

When I ran "ifconfig -a" it listed three eth connections, eth1, eth2 and eth3 - presumably one is my normal ethernet in, one is my wireless and the third is the USB modem? I wasn´t sure which was which so ran dhclient on all three, but each one just said "DHCPDISCOVER on eth* to 255.255.255.255 port 67 interval *" a few times and then "No DHCPOFFERS received.

No working leases in persistent database - sleeping."

My first attempt at setting it up was using the "Setup a new network interface" wizard, but none of the given options (Ethernet, DVB, Cable modem, DSL, ISDN, Wireless, GPRS, Bluetooth, POTS) led to anything which would let me select the USB device.

 

Any other tips, or should I just give up? It should be possible, right?

Share this post


Link to post
Share on other sites

Bump :D

 

Is there anything special you have to do with a USB modem, or is it better to stick to ethernet connections? Should it work and I am just choosing the wrong buttons, or is it unlikely to work at all this way?

 

Thanks!

Share this post


Link to post
Share on other sites

Meh - ok so it seems that Linux doesn't do USB modems then :unsure:

 

Fortunately this particular modem also has an ethernet socket, and I managed to get hold of an ethernet cable to try it out - with this the network works ok, but the modem seems to need a power cycle to realise whether it should be using the USB output or the ethernet output.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×