Jump to content

Lobster says gtk no --- I say gtk yes


Recommended Posts

Seeing I could not find a rpm, I tried to compile Lobster 1.2.0 source and got this:


checking for gtk-config... no

checking for GTK - version >= 1.2.0... no

*** The gtk-config script installed by GTK could not be found

*** If GTK was installed in PREFIX, make sure PREFIX/bin is in

*** your path, or set the GTK_CONFIG environment variable to the

*** full path to gtk-config.

configure: error: GTK is required!

[root@localhost lopster-1.2.0]#


But I do have gtk> 1.2.0 installed and running?


[root@localhost scoopy]# rpm -qa | grep gtk






Where would I enter the full path to gtk-config and where do I locate this gtk-config file in my LM 9.0 system?



Link to comment
Share on other sites

Well, you can find out where it is with

sh-2.05b$ which gtk-config



sh-2.05b$ whereis gtk-config

gtk-config: /usr/bin/gtk-config /usr/man/man1/gtk-config.1


as far as checking your version and path, just do


sh-2.05b$ gtk-config --version


sh-2.05b$ gtk-config --prefix



This is just general, I don't see why it wouldn't be finding it....

Link to comment
Share on other sites

thanks for the quick reply and those tips qnr, I get gtk-config: command not found


My next hunch was what beesea suggests, which I am working on. I am trying to find the dev package that goes with it, but more problems, I lose my connection, and rpmfind is overloaded at this time.


I'll let you know how I make out with the dev packages asap.

Link to comment
Share on other sites

Not having any luck here.


The only mandrake gtk dev rpm I can find is libgtk+2.0_0-devel-2.0.6-8mdk and I get the same messages as above after installing it.


RPMfind.net only shows PLD's gtk+2-devel-2.1.0-0.i686.rpm

but it wanted its own gtk+2 plus a doc rpms. Figured I better not do this.


Maybe I should stick with the Donkey--- Nah, gotta keep trying now.

Link to comment
Share on other sites

The only mandrake gtk dev rpm I can find is  libgtk+2.0_0-devel-2.0.6-8mdk  and I get the same messages as above after installing it.

that's because gtk2 isn't compatible with gtk1.2. you'll need the 1.2 devel package and i'm positive its on one of your cds. just keep looking and you'll find it

Link to comment
Share on other sites

Thanks beesea, that did it. (and was on cd 2, along with libglib 1.2-dev-1.2.10-6mdk , which was also needed)


From what I saw there were files from both gtk and gtk 2 on my system. I knew gtk was running fine seeing that the gimp works, and I was thinking the version 2 was installed over a version 1, but I guess this is 2 separate gtk's running independant which led to the confusion.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...