Jump to content

RPM problem

Recommended Posts







localhost:/# rpm -qa | grep libgtkhtml2
localhost:/# urpmf libgtkhtml2

localhost:/# urpmf --name libgtkhtml2


so if you have updated your sources, do you get the the packages listed doing the same commands as above?


what happens if you do

urpmi libgtkhtml2_0-devel libgnome-vfs2_0-devel libgail-gnome-devel

Share this post

Link to post
Share on other sites

I also found libgnome-vfs2_0-devel and libgail-gnome-devel, but not gnome-vfs2_0-devel or gail-gnome-devel. It seems that Mandrake/Mandriva adds this "lib" at the beginning, while other distributions don't. Why is that? Is there a difference?

Maybe that's the cause for this situation. The RPM requires the wrong packages.

Share this post

Link to post
Share on other sites

there's some reason for it though i can't remember what it was (i read about it some time ago). i believe the lib is just to indicate it's a library (vs. a program of some sort).

Share this post

Link to post
Share on other sites

Since urpmi refuses to install, I have to use rpm. I've downloaded the required RPMs and did:


rpm -Uvh libgtkhtml2_0-devel-2.6.2-1mdk.i586.rpm libgail17-devel-1.6.6-1mdk.i586.rpm libgnome-vfs2_0-devel-2.6.2-7mdk.i586.rpm libgnomecanvas2_0-devel- libgnome-vfs2_0-2.6.2-7mdk.i586.rpm libbonobo2_0-devel-2.6.2-2mdk.i586.rpm libgtk+2.0_0-devel-2.4.9-9mdk.i586.rpm libxml2-devel-2.6.13-1mdk.i586.rpm libgtk+2.0_0-2.4.9-9mdk.i586.rpm libgtk+-x11-2.0_0-2.4.9-9mdk.i586.rpm libgdk_pixbuf2.0_0-devel-2.4.9-9mdk.i586.rpm libpango1.0_0-devel-1.4.1-1mdk.i586.rpm zlib1-devel- libgdk_pixbuf2.0_0-2.4.9-9mdk.i586.rpm zlib1- libgnome-vfs2_0-2.6.2-7.1.101mdk.i586.rpm libgtk+2.0_0-2.4.9-9.1.101mdk.i586.rpm libgtk+-x11-2.0_0-2.4.9-9.1.101mdk.i586.rpm libgdk_pixbuf2.0_0-2.4.9-9.1.101mdk.i586.rpm


the result:

warning: package libgnome-vfs2_0 = 2.6.2-7mdk was already added, replacing with libgnome-vfs2_0 <= 2.6.2-7.1.101mdk
warning: package libgtk+2.0_0 = 2.4.9-9mdk was already added, replacing with libgtk+2.0_0 <= 2.4.9-9.1.101mdk
warning: package libgtk+-x11-2.0_0 = 2.4.9-9mdk was already added, replacing with libgtk+-x11-2.0_0 <= 2.4.9-9.1.101mdk
warning: package libgdk_pixbuf2.0_0 = 2.4.9-9mdk was already added, replacing with libgdk_pixbuf2.0_0 <= 2.4.9-9.1.101mdk
error: Failed dependencies:
	devel(libexpat) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libfontconfig) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libfreetype) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libX11) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXcursor) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXext) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXft) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXi) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXinerama) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXrandr) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libXrender) is needed by libgtkhtml2_0-devel-2.6.2-1mdk
	devel(libexpat) is needed by libgail17-devel-1.6.6-1mdk
	devel(libfontconfig) is needed by libgail17-devel-1.6.6-1mdk
	devel(libfreetype) is needed by libgail17-devel-1.6.6-1mdk
	devel(libX11) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXcursor) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXext) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXft) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXi) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXinerama) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXrandr) is needed by libgail17-devel-1.6.6-1mdk
	devel(libXrender) is needed by libgail17-devel-1.6.6-1mdk
	libgnome-vfs2_0 = 2.6.2-7mdk is needed by libgnome-vfs2_0-devel-2.6.2-7mdk
	devel(libcrypto) is needed by libgnome-vfs2_0-devel-2.6.2-7mdk
	devel(libssl) is needed by libgnome-vfs2_0-devel-2.6.2-7mdk
	devel(libexpat) is needed by libgnomecanvas2_0-devel-
	devel(libfontconfig) is needed by libgnomecanvas2_0-devel-
	devel(libfreetype) is needed by libgnomecanvas2_0-devel-
	devel(libX11) is needed by libgnomecanvas2_0-devel-
	devel(libXcursor) is needed by libgnomecanvas2_0-devel-
	devel(libXext) is needed by libgnomecanvas2_0-devel-
	devel(libXft) is needed by libgnomecanvas2_0-devel-
	devel(libXi) is needed by libgnomecanvas2_0-devel-
	devel(libXinerama) is needed by libgnomecanvas2_0-devel-
	devel(libXrandr) is needed by libgnomecanvas2_0-devel-
	devel(libXrender) is needed by libgnomecanvas2_0-devel-
	libgtk+2.0_0 = 2.4.9-9mdk is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	libgtk+-x11-2.0_0 = 2.4.9-9mdk is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	XFree86-devel is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libX11) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXcursor) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXext) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXft) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXi) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXinerama) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXrandr) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libXrender) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libexpat) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libfontconfig) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	devel(libfreetype) is needed by libgtk+2.0_0-devel-2.4.9-9mdk
	libgdk_pixbuf2.0_0 = 2.4.9-9mdk is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk
	devel(libX11) is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk
	devel(libXext) is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk
	freetype2-devel >= 2.1.3-4mdk is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libexpat) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libfontconfig) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libfreetype) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libX11) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libXext) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libXft) is needed by libpango1.0_0-devel-1.4.1-1mdk
	devel(libXrender) is needed by libpango1.0_0-devel-1.4.1-1mdk


I have 2 problems:

1. libgdk_pixbuf2.0_0-devel-2.4.9-9mdk needs ibgdk_pixbuf2.0_0 = 2.4.9-9mdk. Other packages need an updated version (2.4.9-9.1.101mdk)

2. There is no XFree86-devel for Mandrake 10.1 . Searching rpm.pbone.net gave this list. As you can see, this package existed in Mandrake 10.0, but not in 10.1. Instead, there is a package called libxorg-x11-devel, but I'm not sure if it is indeed the same thing.

Share this post

Link to post
Share on other sites

Yes, xorg replace xfree86 in Mandrake 10.1, which is why it's only available for Mandrake 10.0. Each release since 10.1 has had xorg.


I just have a funny feeling your install is borked because you're having problems trying to install it, what with all the dependency errors you're getting.


Urpmi should have done all you need without having to manually download rpm's. And I can only think the manually downloading of them, has caused this issue in the first place and you've got stuck in one big loop.


The only other thing worth trying is forcing the install of the libgtk2 rpms and see if they go on that way. If not, not sure what else to suggest except reinstall or upgrade to a newer release. Since no updates are provided for 10.1 now, or have been for a long time.

Share this post

Link to post
Share on other sites

Well, you can do an upgrade using the Mandriva 2006 CD/DVD. However, I normally prefer a clean install backing up my files first.


It's far easier, and at least you won't have any niggling problems left behind from the previous release.


Two ways to upgrade are, use the CD/DVD, or you can use urpmi. Remove all your urpmi sources using:


urpmi.removemedia -a


and then, add all 2006 sources. Then you just do:


urpmi --auto-select --auto


and sit back while it does the upgrade. Just make sure if you do this, you've got fast internet connection. But also, make sure you add all sources - main, contrib, updates, plf-free, plf-nonfree.


However, while this will work there will be little niggle problems, nothing too serious but in light of your existing problems, a clean install might be best.

Share this post

Link to post
Share on other sites

I also think a clean install would be best, but I'm a bit worried that /home might get deleted during install, eventhough it's in a separate partition.

Anyway, this is not a very good time for an upgrade, since Mandriva 2007 will be available in just a few months.


Why is it so difficult to unisinstall RPMs? When I was trying to install all those packages that are required by libgtkhtml2, I installed libfreetype6.

Now I want to uninstall it, but in order to do that I must uninstall a lot of packages that had been there for a long time before.

If those packages require libfreetype6, how did they manage to function properly when libfreetype6 wasn't installed?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...